All of lore.kernel.org
 help / color / mirror / Atom feed
From: Boris Brezillon <boris.brezillon@bootlin.com>
To: Stefan Agner <stefan@agner.ch>
Cc: miquel.raynal@free-electrons.com,
	boris.brezillon@free-electrons.com, computersforpeace@gmail.com,
	dwmw2@infradead.org, marek.vasut@gmail.com,
	cyrille.pitchen@wedev4u.fr, richard@nod.at,
	bpringlemeir@gmail.com, marcel.ziswiler@toradex.com,
	linux-mtd@lists.infradead.org
Subject: Re: [PATCH v8 0/3] mtd: rawnand: vf610_nfc: make use of ->exec_op()
Date: Sun, 18 Mar 2018 22:18:06 +0100	[thread overview]
Message-ID: <20180318221806.0f61b15c@bbrezillon> (raw)
In-Reply-To: <20180318155929.16561-1-stefan@agner.ch>

On Sun, 18 Mar 2018 16:59:26 +0100
Stefan Agner <stefan@agner.ch> wrote:

> Eighth revision of the rework patchset to use exec_op for NXP
> Vybrid (and others) NAND Flash Controller.
> 

Already had fixed the problem locally, so I applied v7, which should be
pretty much the same as your v8. Could you test nand/next or linux-next
and let me know if there is a problem.

Thanks,

Boris

> --
> Stefan
> 
> Changes in v8:
> - Check NAND status in vf610_nfc_write_page
> 
> Changes in v7:
> - (accidentally none)
> 
> Changes in v6:
> - Checkpatch style fixes
> - Subject change
> 
> Changes in v5:
> - Fix COMMAND_NADDR_BYTES macro (fixes oob/page test issues)
> - Renamed page_access to data_access
> - Removed unclear debugging messages
> - Introduce vf610_nfc_fill_row to avoid code duplication in
>   vf610_nfc_(read|write)_page
> - Add patch to enable ONFI SET/GET_FEATURES
> - Comment/commit message fixes
> 
> Changes in v4:
> - Rebased to nand/next
> - Simplify filling of address cycles
> - Use accessors for SRAM (vf610_nfc_rd_from_sram/vf610_nfc_wr_to_sram)
> - Use two op-parser patterns to avoid a single command reading and writing
>   in a single operation
> - Implement (read|write)_(page|oob)[_raw] to set page_access
> - Set and clear vf610_nfc_ecc_mode in ecc (read|write)_page
> - Clear/set 16-bit config when 16-bit bus is used and 8-bit access is
>   requested
> 
> Changes in v3:
> - Separate exec_op() callback addition and removal of old callbacks
> - Push data into regs in one function
> - Readd op parser
> - Implement custom read/write page for hardware ECC
> - Rely on generic ecc.write_page_raw
> - Use nand_read_oob_op instead of nand_read_page_op
> 
> Stefan Agner (3):
>   mtd: rawnand: vf610_nfc: make use of ->exec_op()
>   mtd: rawnand: vf610_nfc: remove old hooks
>   mtd: rawnand: vf610_nfc: support ONFI SET/GET_FEATURES commands
> 
>  drivers/mtd/nand/raw/vf610_nfc.c | 632 +++++++++++++++++++++++----------------
>  1 file changed, 380 insertions(+), 252 deletions(-)
> 



-- 
Boris Brezillon, Bootlin (formerly Free Electrons)
Embedded Linux and Kernel engineering
https://bootlin.com

  parent reply	other threads:[~2018-03-18 21:18 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-03-18 15:59 [PATCH v8 0/3] mtd: rawnand: vf610_nfc: make use of ->exec_op() Stefan Agner
2018-03-18 15:59 ` [PATCH v8 1/3] " Stefan Agner
2018-07-12 20:57   ` Stefan Agner
2018-07-12 21:41     ` Boris Brezillon
2018-07-12 21:57       ` Boris Brezillon
2018-07-17 21:03         ` Miquel Raynal
2018-07-18  8:11           ` Marcel Ziswiler
2018-07-26 16:51         ` Stefan Agner
2018-07-26 18:21           ` Boris Brezillon
2018-07-30  8:46             ` Stefan Agner
2018-07-30 18:42               ` Boris Brezillon
2018-03-18 15:59 ` [PATCH v8 2/3] mtd: rawnand: vf610_nfc: remove old hooks Stefan Agner
2018-03-18 15:59 ` [PATCH v8 3/3] mtd: rawnand: vf610_nfc: support ONFI SET/GET_FEATURES commands Stefan Agner
2018-03-18 21:18 ` Boris Brezillon [this message]
2018-03-19 22:24   ` [PATCH v8 0/3] mtd: rawnand: vf610_nfc: make use of ->exec_op() Stefan Agner

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180318221806.0f61b15c@bbrezillon \
    --to=boris.brezillon@bootlin.com \
    --cc=boris.brezillon@free-electrons.com \
    --cc=bpringlemeir@gmail.com \
    --cc=computersforpeace@gmail.com \
    --cc=cyrille.pitchen@wedev4u.fr \
    --cc=dwmw2@infradead.org \
    --cc=linux-mtd@lists.infradead.org \
    --cc=marcel.ziswiler@toradex.com \
    --cc=marek.vasut@gmail.com \
    --cc=miquel.raynal@free-electrons.com \
    --cc=richard@nod.at \
    --cc=stefan@agner.ch \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.