From: Mark Brown <broonie@kernel.org>
To: Liam Girdwood <liam.r.girdwood@linux.intel.com>
Cc: alsa-devel@alsa-project.org
Subject: Re: [PATCH 01/11] ASoC: SOF: Add Sound Open Firmware driver core
Date: Mon, 23 Jul 2018 19:56:33 +0100 [thread overview]
Message-ID: <20180723185633.GI13981@sirena.org.uk> (raw)
In-Reply-To: <20180719185335.30912-1-liam.r.girdwood@linux.intel.com>
[-- Attachment #1.1: Type: text/plain, Size: 2389 bytes --]
On Thu, Jul 19, 2018 at 07:53:25PM +0100, Liam Girdwood wrote:
> The Sound Open Firmware driver core is a generic architecture
> independent layer that allows SOF to be used on many different different
> architectures and platforms. It abstracts DSP operations and IO methods
> +++ b/include/sound/soc.h
> @@ -1133,6 +1133,7 @@ struct snd_soc_pcm_runtime {
> /* runtime devices */
> struct snd_pcm *pcm;
> struct snd_compr *compr;
> + struct snd_sof_pcm *sof;
> struct snd_soc_dai *codec_dai;
> struct snd_soc_dai *cpu_dai;
Can we rename this somehow to be less specific to SoF or move it to be
somewhere other than the runtime structure? I can see why you've done
this but I can also see every DSP vendor turning up and trying to add
their own field in here.
> +/*
> + * This file is provided under a dual BSD/GPLv2 license. When using or
> + * redistributing this file, you may do so under either license.
> + *
> + * Copyright(c) 2017 Intel Corporation. All rights reserved.
2017?
> index 000000000000..29458909182a
> --- /dev/null
> +++ b/sound/soc/sof/core.c
> @@ -0,0 +1,373 @@
> +// SPDX-License-Identifier: (GPL-2.0 OR BSD-3-Clause)
> +/*
> + * This file is provided under a dual BSD/GPLv2 license. When using or
Please make the entire comment a C++ one, it makes it look more
intentional.
> +static inline unsigned int sof_get_pages(size_t size)
> +{
> + return (size + PAGE_SIZE - 1) >> PAGE_SHIFT;
> +}
This feels like there should be a generic MM function for it?
> +/*
> + * Generic buffer page table creation.
> + */
> +
> +int snd_sof_create_page_table(struct snd_sof_dev *sdev,
> + struct snd_dma_buffer *dmab,
> + unsigned char *page_table, size_t size)
> +{
> + int i, pages;
> +
> + pages = snd_sgbuf_aligned_pages(size);
> +
> + dev_dbg(sdev->dev, "generating page table for %p size 0x%zx pages %d\n",
> + dmab->area, size, pages);
> +
> + for (i = 0; i < pages; i++) {
> + u32 idx = (((i << 2) + i)) >> 1;
> + u32 pfn = snd_sgbuf_get_addr(dmab, i * PAGE_SIZE) >> PAGE_SHIFT;
> + u32 *pg_table;
> +
> + dev_dbg(sdev->dev, "pfn i %i idx %d pfn %x\n", i, idx, pfn);
> +
> + pg_table = (u32 *)(page_table + idx);
> +
> + if (i & 1)
> + *pg_table |= (pfn << 4);
> + else
> + *pg_table |= pfn;
> + }
I'm not 100% clear what this is intended to do - lots of magic numbers
and dependencies on the host memory configuration.
[-- Attachment #1.2: signature.asc --]
[-- Type: application/pgp-signature, Size: 488 bytes --]
[-- Attachment #2: Type: text/plain, Size: 0 bytes --]
next prev parent reply other threads:[~2018-07-23 18:56 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-07-19 18:53 [PATCH 01/11] ASoC: SOF: Add Sound Open Firmware driver core Liam Girdwood
2018-07-19 18:53 ` [PATCH 02/11] ASoC: SOF: Add Sound Open Firmware KControl support Liam Girdwood
2018-07-23 18:58 ` Mark Brown
2018-07-19 18:53 ` [PATCH 03/11] ASoC: SOF: Add driver debug support Liam Girdwood
2018-07-23 19:03 ` Mark Brown
2018-07-19 18:53 ` [PATCH 04/11] ASoC: SOF: Add support for IPC IO between DSP and Host Liam Girdwood
2018-07-19 18:53 ` [PATCH 05/11] ASoC: SOF: Add PCM operations support Liam Girdwood
2018-07-24 15:07 ` Mark Brown
2018-07-19 18:53 ` [PATCH 06/11] ASoC: SOF: Add support for loading topologies Liam Girdwood
2018-07-19 18:53 ` [PATCH 07/11] ASoC: SOF: Add DSP firmware trace event support Liam Girdwood
2018-07-19 18:53 ` [PATCH 08/11] ASoC: SOF: Add DSP HW abstraction operations Liam Girdwood
2018-07-30 15:21 ` Mark Brown
2018-07-19 18:53 ` [PATCH 09/11] ASoC: SOF: Add firmware loader support Liam Girdwood
2018-07-19 18:53 ` [PATCH 10/11] ASoC: SOF: Add userspace ABI support Liam Girdwood
2018-07-19 18:53 ` [PATCH 11/11] ASoC: SOF: Add Build support for SOF core Liam Girdwood
2018-07-20 14:11 ` Pierre-Louis Bossart
2018-07-19 18:58 ` [PATCH 01/11] ASoC: SOF: Add Sound Open Firmware driver core Takashi Iwai
2018-07-20 11:05 ` Liam Girdwood
2018-07-23 18:56 ` Mark Brown [this message]
2018-08-22 16:26 ` Liam Girdwood
2018-07-24 15:57 ` Pierre-Louis Bossart
2018-07-25 7:36 ` Takashi Iwai
2018-07-25 13:57 ` Pierre-Louis Bossart
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180723185633.GI13981@sirena.org.uk \
--to=broonie@kernel.org \
--cc=alsa-devel@alsa-project.org \
--cc=liam.r.girdwood@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.