From mboxrd@z Thu Jan 1 00:00:00 1970 From: Peter Zijlstra Subject: Re: [PATCH RFC 3/4] barriers: convert a control to a data dependency Date: Mon, 7 Jan 2019 16:54:23 +0100 Message-ID: <20190107155423.GM2218@hirez.programming.kicks-ass.net> References: <20190102205715.14054-1-mst@redhat.com> <20190102205715.14054-4-mst@redhat.com> <86023cbe-d1ae-a0d6-7b75-26556f1a0c1f@redhat.com> <20190106231756-mutt-send-email-mst@kernel.org> <20190107094610.GA2861@worktop.programming.kicks-ass.net> <20190107082223-mutt-send-email-mst@kernel.org> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=infradead.org; s=bombadil.20170209; h=In-Reply-To:Content-Type:MIME-Version :References:Message-ID:Subject:Cc:To:From:Date:Sender:Reply-To: Content-Transfer-Encoding:Content-ID:Content-Description:Resent-Date: Resent-From:Resent-Sender:Resent-To:Resent-Cc:Resent-Message-ID:List-Id: List-Help:List-Unsubscribe:List-Subscribe:List-Post:List-Owner:List-Archive; bh=EB8jJo74ngJGhrjSVclXwp46WwssCxFPErndM29eks4=; b=JLSAJM2YVQOUjWUV138MvuYR9 3dPjf9waKIDM2/SO2xRhDIZubSfm4WiTjU1KRVlE61YjDLJBX6BUQeR6hXY70aeXEitHFolg5nUWF BaJYfMxGBI5kEhXiGbsj4uGDUZOO0cKwQ5TgztVLIm0k1/Hvw9xclye+ufU0bEAbJ6UEANhk8ffkc h0Rd/oZ/ZVFxuhY1jj5oXhfWd4feL+hb9fzMcpe5C8RYWl/rF4Cemdu+QVbcrvCfOzQAKAU9eXjfG A7P6JZ5ObfZZxoErjKxkU3AM7TO+uz8iQYnhPcQg5ui+LYFSbIOHWiMF42+c9mZkfoYcQ8U43sJO7 kecSpl8eQ==; Content-Disposition: inline In-Reply-To: <20190107082223-mutt-send-email-mst@kernel.org> List-Id: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: virtualization-bounces@lists.linux-foundation.org Errors-To: virtualization-bounces@lists.linux-foundation.org To: "Michael S. Tsirkin" Cc: Andrea Parri , linux-doc@vger.kernel.org, Akira Yokosawa , Will Deacon , virtualization@lists.linux-foundation.org, David Howells , linux-arch@vger.kernel.org, Jonathan Corbet , linux-sparse@vger.kernel.org, Alan Stern , Matt Turner , "Paul E. McKenney" , Boqun Feng , Arnd Bergmann , Daniel Lustig , Nicholas Piggin , Ivan Kokshaysky , Luc Maranget , Richard Henderson , Jade Alglave , netdev@vger.kernel.org, linux-kernel@vger.kernel.org, linux-alpha@vger.kernel.org, Luc Van Oostenryck On Mon, Jan 07, 2019 at 08:36:36AM -0500, Michael S. Tsirkin wrote: > On Mon, Jan 07, 2019 at 10:46:10AM +0100, Peter Zijlstra wrote: > > How about naming the thing: dependent_ptr() ? That is without any (r)mb > > implications at all. The address dependency is strictly weaker than an > > rmb in that it will only order the two loads in qestion and not, like > > rmb, any prior to any later load. > > So I'm fine with this as it's enough for virtio, but I would like to point out two things: > > 1. E.g. on x86 both SMP and DMA variants can be NOPs but > the madatory one can't, so assuming we do not want > it to be stronger than rmp then either we want > smp_dependent_ptr(), dma_dependent_ptr(), dependent_ptr() > or we just will specify that dependent_ptr() works for > both DMA and SMP. The latter; the construct simply generates dependent loads. It is up to the CPU as to what all that works for. > 2. Down the road, someone might want to order a store after a load. > Address dependency does that for us too. Assuming we make > dependent_ptr a NOP on x86, we will want an mb variant > which isn't a NOP on x86. Will we want to rename > dependent_ptr to dependent_ptr_rmb at that point? Not sure; what is the actual overhead of the construct on x86 vs the NOP? From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from bombadil.infradead.org ([198.137.202.133]:56652 "EHLO bombadil.infradead.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1726511AbfAGPym (ORCPT ); Mon, 7 Jan 2019 10:54:42 -0500 Date: Mon, 7 Jan 2019 16:54:23 +0100 From: Peter Zijlstra Subject: Re: [PATCH RFC 3/4] barriers: convert a control to a data dependency Message-ID: <20190107155423.GM2218@hirez.programming.kicks-ass.net> References: <20190102205715.14054-1-mst@redhat.com> <20190102205715.14054-4-mst@redhat.com> <86023cbe-d1ae-a0d6-7b75-26556f1a0c1f@redhat.com> <20190106231756-mutt-send-email-mst@kernel.org> <20190107094610.GA2861@worktop.programming.kicks-ass.net> <20190107082223-mutt-send-email-mst@kernel.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20190107082223-mutt-send-email-mst@kernel.org> Sender: linux-arch-owner@vger.kernel.org List-ID: To: "Michael S. Tsirkin" Cc: Jason Wang , linux-kernel@vger.kernel.org, Alan Stern , Andrea Parri , Will Deacon , Boqun Feng , Nicholas Piggin , David Howells , Jade Alglave , Luc Maranget , "Paul E. McKenney" , Akira Yokosawa , Daniel Lustig , linux-arch@vger.kernel.org, netdev@vger.kernel.org, virtualization@lists.linux-foundation.org, Jonathan Corbet , Richard Henderson , Ivan Kokshaysky , Matt Turner , Arnd Bergmann , Luc Van Oostenryck , linux-doc@vger.kernel.org, linux-alpha@vger.kernel.org, linux-sparse@vger.kernel.org Message-ID: <20190107155423.MXW-9zTTqH3nCYD6jxz8W0LC-q8vdfv5gLg3_nfpx6E@z> On Mon, Jan 07, 2019 at 08:36:36AM -0500, Michael S. Tsirkin wrote: > On Mon, Jan 07, 2019 at 10:46:10AM +0100, Peter Zijlstra wrote: > > How about naming the thing: dependent_ptr() ? That is without any (r)mb > > implications at all. The address dependency is strictly weaker than an > > rmb in that it will only order the two loads in qestion and not, like > > rmb, any prior to any later load. > > So I'm fine with this as it's enough for virtio, but I would like to point out two things: > > 1. E.g. on x86 both SMP and DMA variants can be NOPs but > the madatory one can't, so assuming we do not want > it to be stronger than rmp then either we want > smp_dependent_ptr(), dma_dependent_ptr(), dependent_ptr() > or we just will specify that dependent_ptr() works for > both DMA and SMP. The latter; the construct simply generates dependent loads. It is up to the CPU as to what all that works for. > 2. Down the road, someone might want to order a store after a load. > Address dependency does that for us too. Assuming we make > dependent_ptr a NOP on x86, we will want an mb variant > which isn't a NOP on x86. Will we want to rename > dependent_ptr to dependent_ptr_rmb at that point? Not sure; what is the actual overhead of the construct on x86 vs the NOP?