From: Yury Norov <yury.norov@gmail.com>
To: Andrew Morton <akpm@linux-foundation.org>,
Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
Rasmus Villemoes <linux@rasmusvillemoes.dk>,
Arnd Bergmann <arnd@arndb.de>, Kees Cook <keescook@chromium.org>,
Matthew Wilcox <willy@infradead.org>,
Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp>,
Mike Travis <travis@sgi.com>, Guenter Roeck <linux@roeck-us.net>
Cc: Yury Norov <ynorov@marvell.com>,
Yury Norov <yury.norov@gmail.com>,
linux-kernel@vger.kernel.org
Subject: [PATCH v5 0/5] lib: rework bitmap_parselist and tests
Date: Mon, 15 Apr 2019 23:37:56 -0700 [thread overview]
Message-ID: <20190416063801.20134-1-ynorov@marvell.com> (raw)
bitmap_parselist has been evolved from a pretty simple idea for long and
now lacks for refactoring. It is not structured, has nested loops and a
set of opaque-named variables.
Things are more complicated because bitmap_parselist() is a part of user
interface, and its behavior should not change.
In this patchset
- bitmap_parselist_user() made a wrapper on bitmap_parselist();
- bitmap_parselist() reworked (patch 2);
- time measurement in test_bitmap_parselist switched to ktime_get
(patch 3);
- new tests introduced (patch 4), and
- bitmap_parselist_user() testing enabled with the same testset as
bitmap_parselist() (patch 5).
v1: https://lkml.org/lkml/2018/12/23/50
v2: https://www.spinics.net/lists/kernel/msg3048976.html
v3: https://lkml.org/lkml/2019/4/3/68
v4: https://lkml.org/lkml/2019/4/5/640
v5: - fix sadly missed '* step' in patch 4, as spotted by Guenter Roeck;
- use _parse_integer() in bitmap_getnum() to avoid opencoding
mentioned by Andy Shevchenko.
Yury Norov (5):
lib: make bitmap_parselist_user() a wrapper on bitmap_parselist()
lib: rework bitmap_parselist
lib/test_bitmap: switch test_bitmap_parselist to ktime_get()
lib/test_bitmap: add testcases for bitmap_parselist
lib/test_bitmap: add tests for bitmap_parselist_user
lib/bitmap.c | 274 ++++++++++++++++++++++++++--------------------
lib/test_bitmap.c | 67 +++++++++---
2 files changed, 207 insertions(+), 134 deletions(-)
--
2.17.1
next reply other threads:[~2019-04-16 6:38 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-04-16 6:37 Yury Norov [this message]
2019-04-16 6:37 ` [PATCH 1/5] lib: make bitmap_parselist_user() a wrapper on bitmap_parselist() Yury Norov
2019-04-16 13:08 ` Andy Shevchenko
2019-04-16 6:37 ` [PATCH 2/5] lib: rework bitmap_parselist Yury Norov
2019-04-16 13:18 ` Andy Shevchenko
2019-04-16 6:37 ` [PATCH 3/5] lib/test_bitmap: switch test_bitmap_parselist to ktime_get() Yury Norov
2019-04-16 6:38 ` [PATCH 4/5] lib/test_bitmap: add testcases for bitmap_parselist Yury Norov
2019-04-16 6:38 ` [PATCH 5/5] lib/test_bitmap: add tests for bitmap_parselist_user Yury Norov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20190416063801.20134-1-ynorov@marvell.com \
--to=yury.norov@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=andriy.shevchenko@linux.intel.com \
--cc=arnd@arndb.de \
--cc=keescook@chromium.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@rasmusvillemoes.dk \
--cc=linux@roeck-us.net \
--cc=penguin-kernel@I-love.SAKURA.ne.jp \
--cc=travis@sgi.com \
--cc=willy@infradead.org \
--cc=ynorov@marvell.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.