From: Roman Gushchin <guro@fb.com>
To: Johannes Weiner <hannes@cmpxchg.org>
Cc: Andrew Morton <akpm@linux-foundation.org>,
Michal Hocko <mhocko@suse.com>,
"linux-mm@kvack.org" <linux-mm@kvack.org>,
"cgroups@vger.kernel.org" <cgroups@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
Kernel Team <Kernel-team@fb.com>
Subject: Re: [PATCH 5/8] mm: vmscan: replace shrink_node() loop with a retry jump
Date: Tue, 22 Oct 2019 22:46:57 +0000 [thread overview]
Message-ID: <20191022224652.GA22777@tower.DHCP.thefacebook.com> (raw)
In-Reply-To: <20191022214249.GB361040@cmpxchg.org>
On Tue, Oct 22, 2019 at 05:42:49PM -0400, Johannes Weiner wrote:
> On Tue, Oct 22, 2019 at 07:56:33PM +0000, Roman Gushchin wrote:
> > On Tue, Oct 22, 2019 at 10:48:00AM -0400, Johannes Weiner wrote:
> > > - /* Record the group's reclaim efficiency */
> > > - vmpressure(sc->gfp_mask, memcg, false,
> > > - sc->nr_scanned - scanned,
> > > - sc->nr_reclaimed - reclaimed);
> > > -
> > > - } while ((memcg = mem_cgroup_iter(root, memcg, NULL)));
> > > + reclaimed = sc->nr_reclaimed;
> > > + scanned = sc->nr_scanned;
> > > + shrink_node_memcg(pgdat, memcg, sc);
> > >
> > > - if (reclaim_state) {
> > > - sc->nr_reclaimed += reclaim_state->reclaimed_slab;
> > > - reclaim_state->reclaimed_slab = 0;
> > > - }
> > > + shrink_slab(sc->gfp_mask, pgdat->node_id, memcg,
> > > + sc->priority);
> > >
> > > - /* Record the subtree's reclaim efficiency */
> > > - vmpressure(sc->gfp_mask, sc->target_mem_cgroup, true,
> > > - sc->nr_scanned - nr_scanned,
> > > - sc->nr_reclaimed - nr_reclaimed);
> > > + /* Record the group's reclaim efficiency */
> > > + vmpressure(sc->gfp_mask, memcg, false,
> > > + sc->nr_scanned - scanned,
> > > + sc->nr_reclaimed - reclaimed);
> >
> > It doesn't look as a trivial change. I'd add some comments to the commit message
> > why it's safe to do.
>
> It's an equivalent change - it's just really misleading because the
> +++ lines are not the counter-part of the --- lines here!
>
> There are two vmpressure calls in this function: one against the
> individual cgroups, and one against the tree. The diff puts them
> adjacent here, but the counter-part for the --- lines is here:
>
> > > + /* Record the subtree's reclaim efficiency */
> > > + vmpressure(sc->gfp_mask, sc->target_mem_cgroup, true,
> > > + sc->nr_scanned - nr_scanned,
> > > + sc->nr_reclaimed - nr_reclaimed);
>
> And the counter-part to the +++ lines is further up (beginning of the
> quoted diff).
>
Ah, ok, got it. You were right in the foreword, indentation change
diffs are hard to read.
Thanks for the explanation!
Reviewed-by: Roman Gushchin <guro@fb.com>
next prev parent reply other threads:[~2019-10-22 22:46 UTC|newest]
Thread overview: 32+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-10-22 14:47 [PATCH 0/8]: mm: vmscan: cgroup-related cleanups Johannes Weiner
2019-10-22 14:47 ` [PATCH 1/8] mm: vmscan: simplify lruvec_lru_size() Johannes Weiner
2019-10-22 19:18 ` Roman Gushchin
2019-10-23 13:48 ` Michal Hocko
2019-10-22 14:47 ` [PATCH 2/8] mm: clean up and clarify lruvec lookup procedure Johannes Weiner
2019-10-22 19:25 ` Roman Gushchin
2019-10-22 21:31 ` Johannes Weiner
2019-10-23 14:00 ` Michal Hocko
2019-10-22 14:47 ` [PATCH 3/8] mm: vmscan: move inactive_list_is_low() swap check to the caller Johannes Weiner
2019-10-22 19:28 ` Roman Gushchin
2019-10-23 14:06 ` Michal Hocko
2019-10-22 14:47 ` [PATCH 4/8] mm: vmscan: naming fixes: global_reclaim() and sane_reclaim() Johannes Weiner
2019-10-22 19:40 ` Roman Gushchin
2019-10-23 16:02 ` Johannes Weiner
2019-10-23 14:14 ` Michal Hocko
2019-10-23 15:56 ` Johannes Weiner
2019-10-22 14:48 ` [PATCH 5/8] mm: vmscan: replace shrink_node() loop with a retry jump Johannes Weiner
2019-10-22 19:56 ` Roman Gushchin
2019-10-22 21:42 ` Johannes Weiner
2019-10-22 22:46 ` Roman Gushchin [this message]
2019-10-23 14:18 ` Michal Hocko
2019-10-25 13:44 ` Johannes Weiner
2019-10-22 14:48 ` [PATCH 6/8] mm: vmscan: turn shrink_node_memcg() into shrink_lruvec() Johannes Weiner
2019-10-22 20:04 ` Roman Gushchin
2019-10-23 14:21 ` Michal Hocko
2019-10-22 14:48 ` [PATCH 7/8] mm: vmscan: split shrink_node() into node part and memcgs part Johannes Weiner
2019-10-22 20:08 ` Roman Gushchin
2019-10-25 14:36 ` Johannes Weiner
2019-10-23 14:24 ` Michal Hocko
2019-10-22 14:48 ` [PATCH 8/8] mm: vmscan: harmonize writeback congestion tracking for nodes & memcgs Johannes Weiner
2019-10-22 21:03 ` Roman Gushchin
2019-10-25 14:41 ` Johannes Weiner
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20191022224652.GA22777@tower.DHCP.thefacebook.com \
--to=guro@fb.com \
--cc=Kernel-team@fb.com \
--cc=akpm@linux-foundation.org \
--cc=cgroups@vger.kernel.org \
--cc=hannes@cmpxchg.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=mhocko@suse.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.