From: Michael Straube <straube.linux@gmail.com>
To: gregkh@linuxfoundation.org
Cc: Larry.Finger@lwfinger.net, devel@driverdev.osuosl.org,
linux-kernel@vger.kernel.org,
Michael Straube <straube.linux@gmail.com>
Subject: [PATCH 5/7] staging: rtl8188eu: remove ternary operator
Date: Sat, 26 Oct 2019 14:11:33 +0200 [thread overview]
Message-ID: <20191026121135.181897-5-straube.linux@gmail.com> (raw)
In-Reply-To: <20191026121135.181897-1-straube.linux@gmail.com>
Instead of using ternary operator to set variable res, use the value
of variable match (or the negation) directly to simplify the code and
improve readability.
Signed-off-by: Michael Straube <straube.linux@gmail.com>
---
drivers/staging/rtl8188eu/core/rtw_sta_mgt.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_sta_mgt.c b/drivers/staging/rtl8188eu/core/rtw_sta_mgt.c
index 282c835a635c..3cadc46836e1 100644
--- a/drivers/staging/rtl8188eu/core/rtw_sta_mgt.c
+++ b/drivers/staging/rtl8188eu/core/rtw_sta_mgt.c
@@ -504,9 +504,9 @@ bool rtw_access_ctrl(struct adapter *padapter, u8 *mac_addr)
spin_unlock_bh(&pacl_node_q->lock);
if (pacl_list->mode == 1)/* accept unless in deny list */
- res = (match) ? false : true;
+ res = !match;
else if (pacl_list->mode == 2)/* deny unless in accept list */
- res = (match) ? true : false;
+ res = match;
else
res = true;
--
2.23.0
next prev parent reply other threads:[~2019-10-26 12:12 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-10-26 12:11 [PATCH 1/7] staging: rtl8188eu: cleanup comments in rtw_sta_mgt.c Michael Straube
2019-10-26 12:11 ` [PATCH 2/7] staging: rtl8188eu: convert unsigned char array to u8 Michael Straube
2019-10-26 12:11 ` [PATCH 3/7] staging: rtl8188eu: rename array bcast_addr Michael Straube
2019-10-26 12:11 ` [PATCH 4/7] staging: rtl8188eu: convert rtw_access_ctrl to return bool Michael Straube
2019-10-26 12:11 ` Michael Straube [this message]
2019-10-26 12:11 ` [PATCH 6/7] staging: rtl8188eu: cleanup long lines in rtw_sta_mgt.c Michael Straube
2019-10-26 12:11 ` [PATCH 7/7] staging: rtl8188eu: reduce indentation level in rtw_alloc_stainfo Michael Straube
2019-10-26 17:18 ` Joe Perches
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20191026121135.181897-5-straube.linux@gmail.com \
--to=straube.linux@gmail.com \
--cc=Larry.Finger@lwfinger.net \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.