All of lore.kernel.org
 help / color / mirror / Atom feed
From: Larry Finger <Larry.Finger@lwfinger.net>
To: kvalo@codeaurora.org
Cc: linux-wireless@vger.kernel.org, Larry Finger <Larry.Finger@lwfinger.net>
Subject: [PATCH 00/14] rtlwifi: Change RT_TRACE into RT_DEBUG for all drivers
Date: Thu, 16 Jul 2020 21:01:47 -0500	[thread overview]
Message-ID: <20200717020201.18209-1-Larry.Finger@lwfinger.net> (raw)

The drivers in the rtlwifi family use a macro named RT_TRACE to log
some debugging information. The name choice is unfortunate in that
it suggests tracing, which it does not. Convert each of them to
RT_DEBUG instead.

Signed-off-by: Larry Finger <Larry.Finger@lwfinger.net>


Larry Finger (14):
  rtlwifi: Replace RT_TRACE with RT_DEBUG
  rtlwifi: btcoexist: Replace RT_TRACE with RT_DEBUG
  rtlwifi: rtl8188ee: Change RT_TRACE to RT_DEBUG
  rtlwifi: rtl8192c_common: Rename RT_TRACE to RT_DEBUG
  rtlwifi: rtl8192ce: Rename RT_TRACE to RT_DEBUG
  rtlwifi: rtl8192cu: Rename RT_TRACE to RT_DEBUG
  rtlwifi: rtl8192de: Rename RT_TRACE to RT_DEBUG
  rtlwifi: rtl8192ee: Rename RT_TRACE to RT_DEBUG
  rtlwifi: rtl8192se: Rename RT_TRACE to RT_DEBUG
  rtlwifi: rtl8723ae: Rename RT_TRACE to RT_DEBUG
  rtlwifi: rtl8723be: Rename RT_TRACE to RT_DEBUG
  rtlwifi: rtl8723-common: Rename RT_TRACE to RT_DEBUG
  rtlwifi: rtl8821ae: Rename RT_TRACE to RT_DEBUG
  rtlwifi: Remove final instances of RT_TRACE macros

 drivers/net/wireless/realtek/rtlwifi/base.c   |  72 ++--
 .../rtlwifi/btcoexist/halbtc8192e2ant.c       | 286 +++++++--------
 .../rtlwifi/btcoexist/halbtc8723b1ant.c       | 156 ++++-----
 .../rtlwifi/btcoexist/halbtc8723b2ant.c       | 300 ++++++++--------
 .../rtlwifi/btcoexist/halbtc8821a1ant.c       | 286 +++++++--------
 .../rtlwifi/btcoexist/halbtc8821a2ant.c       | 308 ++++++++--------
 .../realtek/rtlwifi/btcoexist/halbtcoutsrc.c  |  14 +-
 .../realtek/rtlwifi/btcoexist/rtl_btc.c       |   4 +-
 drivers/net/wireless/realtek/rtlwifi/cam.c    |  38 +-
 drivers/net/wireless/realtek/rtlwifi/core.c   | 130 +++----
 drivers/net/wireless/realtek/rtlwifi/debug.c  |   2 +-
 drivers/net/wireless/realtek/rtlwifi/debug.h  |   4 +-
 drivers/net/wireless/realtek/rtlwifi/efuse.c  |  38 +-
 drivers/net/wireless/realtek/rtlwifi/pci.c    | 116 +++---
 drivers/net/wireless/realtek/rtlwifi/ps.c     |  40 +--
 drivers/net/wireless/realtek/rtlwifi/regd.c   |   8 +-
 .../wireless/realtek/rtlwifi/rtl8188ee/dm.c   |  76 ++--
 .../wireless/realtek/rtlwifi/rtl8188ee/fw.c   |  44 +--
 .../wireless/realtek/rtlwifi/rtl8188ee/hw.c   |  88 ++---
 .../wireless/realtek/rtlwifi/rtl8188ee/led.c  |  10 +-
 .../wireless/realtek/rtlwifi/rtl8188ee/phy.c  | 132 +++----
 .../wireless/realtek/rtlwifi/rtl8188ee/rf.c   |   4 +-
 .../wireless/realtek/rtlwifi/rtl8188ee/trx.c  |  12 +-
 .../realtek/rtlwifi/rtl8192c/dm_common.c      |  66 ++--
 .../realtek/rtlwifi/rtl8192c/fw_common.c      |  40 +--
 .../realtek/rtlwifi/rtl8192c/phy_common.c     |  82 ++---
 .../wireless/realtek/rtlwifi/rtl8192ce/dm.c   |  16 +-
 .../wireless/realtek/rtlwifi/rtl8192ce/hw.c   |  82 ++---
 .../wireless/realtek/rtlwifi/rtl8192ce/led.c  |   6 +-
 .../wireless/realtek/rtlwifi/rtl8192ce/phy.c  |  46 +--
 .../wireless/realtek/rtlwifi/rtl8192ce/rf.c   |   4 +-
 .../wireless/realtek/rtlwifi/rtl8192ce/trx.c  |   8 +-
 .../wireless/realtek/rtlwifi/rtl8192cu/dm.c   |  16 +-
 .../wireless/realtek/rtlwifi/rtl8192cu/hw.c   |  66 ++--
 .../wireless/realtek/rtlwifi/rtl8192cu/led.c  |   6 +-
 .../wireless/realtek/rtlwifi/rtl8192cu/mac.c  |  30 +-
 .../wireless/realtek/rtlwifi/rtl8192cu/phy.c  |  48 +--
 .../wireless/realtek/rtlwifi/rtl8192cu/rf.c   |   4 +-
 .../wireless/realtek/rtlwifi/rtl8192cu/trx.c  |  28 +-
 .../wireless/realtek/rtlwifi/rtl8192de/dm.c   | 110 +++---
 .../wireless/realtek/rtlwifi/rtl8192de/fw.c   |  46 +--
 .../wireless/realtek/rtlwifi/rtl8192de/hw.c   |  98 +++---
 .../wireless/realtek/rtlwifi/rtl8192de/led.c  |   6 +-
 .../wireless/realtek/rtlwifi/rtl8192de/phy.c  | 182 +++++-----
 .../wireless/realtek/rtlwifi/rtl8192de/rf.c   |  20 +-
 .../wireless/realtek/rtlwifi/rtl8192de/trx.c  |  10 +-
 .../wireless/realtek/rtlwifi/rtl8192ee/dm.c   |  24 +-
 .../wireless/realtek/rtlwifi/rtl8192ee/fw.c   |  48 +--
 .../wireless/realtek/rtlwifi/rtl8192ee/hw.c   | 100 +++---
 .../wireless/realtek/rtlwifi/rtl8192ee/led.c  |  10 +-
 .../wireless/realtek/rtlwifi/rtl8192ee/phy.c  | 148 ++++----
 .../wireless/realtek/rtlwifi/rtl8192ee/rf.c   |   4 +-
 .../wireless/realtek/rtlwifi/rtl8192ee/trx.c  |  14 +-
 .../wireless/realtek/rtlwifi/rtl8192se/dm.c   |  14 +-
 .../wireless/realtek/rtlwifi/rtl8192se/fw.c   |  14 +-
 .../wireless/realtek/rtlwifi/rtl8192se/hw.c   |  80 ++---
 .../wireless/realtek/rtlwifi/rtl8192se/led.c  |   6 +-
 .../wireless/realtek/rtlwifi/rtl8192se/phy.c  |  88 ++---
 .../wireless/realtek/rtlwifi/rtl8192se/rf.c   |  26 +-
 .../wireless/realtek/rtlwifi/rtl8192se/sw.c   |   2 +-
 .../wireless/realtek/rtlwifi/rtl8192se/trx.c  |   6 +-
 .../wireless/realtek/rtlwifi/rtl8723ae/dm.c   |  58 +--
 .../wireless/realtek/rtlwifi/rtl8723ae/fw.c   |  32 +-
 .../rtlwifi/rtl8723ae/hal_bt_coexist.c        |  72 ++--
 .../realtek/rtlwifi/rtl8723ae/hal_btc.c       | 330 +++++++++---------
 .../wireless/realtek/rtlwifi/rtl8723ae/hw.c   | 112 +++---
 .../wireless/realtek/rtlwifi/rtl8723ae/led.c  |   6 +-
 .../wireless/realtek/rtlwifi/rtl8723ae/phy.c  | 108 +++---
 .../wireless/realtek/rtlwifi/rtl8723ae/rf.c   |   4 +-
 .../wireless/realtek/rtlwifi/rtl8723ae/trx.c  |   8 +-
 .../wireless/realtek/rtlwifi/rtl8723be/dm.c   |  44 +--
 .../wireless/realtek/rtlwifi/rtl8723be/fw.c   |  32 +-
 .../wireless/realtek/rtlwifi/rtl8723be/hw.c   |  88 ++---
 .../wireless/realtek/rtlwifi/rtl8723be/led.c  |   6 +-
 .../wireless/realtek/rtlwifi/rtl8723be/phy.c  | 130 +++----
 .../wireless/realtek/rtlwifi/rtl8723be/rf.c   |   4 +-
 .../wireless/realtek/rtlwifi/rtl8723be/trx.c  |  12 +-
 .../realtek/rtlwifi/rtl8723com/fw_common.c    |  10 +-
 .../realtek/rtlwifi/rtl8723com/phy_common.c   |  12 +-
 .../wireless/realtek/rtlwifi/rtl8821ae/dm.c   | 282 +++++++--------
 .../wireless/realtek/rtlwifi/rtl8821ae/fw.c   |  64 ++--
 .../wireless/realtek/rtlwifi/rtl8821ae/hw.c   | 222 ++++++------
 .../wireless/realtek/rtlwifi/rtl8821ae/led.c  |  14 +-
 .../wireless/realtek/rtlwifi/rtl8821ae/phy.c  | 236 ++++++-------
 .../wireless/realtek/rtlwifi/rtl8821ae/rf.c   |   4 +-
 .../wireless/realtek/rtlwifi/rtl8821ae/trx.c  |  24 +-
 drivers/net/wireless/realtek/rtlwifi/usb.c    |   8 +-
 87 files changed, 2847 insertions(+), 2847 deletions(-)

-- 
2.27.0


             reply	other threads:[~2020-07-17  2:02 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-17  2:01 Larry Finger [this message]
2020-07-17  2:01 ` [PATCH 01/14] rtlwifi: Replace RT_TRACE with RT_DEBUG Larry Finger
2020-07-17  3:32   ` Joe Perches
2020-07-17  2:01 ` [PATCH 02/14] rtlwifi: btcoexist: " Larry Finger
2020-07-17  2:01 ` [PATCH 03/14] rtlwifi: rtl8188ee: Change RT_TRACE to RT_DEBUG Larry Finger
2020-07-17  2:01 ` [PATCH 04/14] rtlwifi: rtl8192c_common: Rename " Larry Finger
2020-07-17  2:01 ` [PATCH 05/14] rtlwifi: rtl8192ce: " Larry Finger
2020-07-17  2:01 ` [PATCH 06/14] rtlwifi: rtl8192cu: " Larry Finger
2020-07-17  2:01 ` [PATCH 07/14] rtlwifi: rtl8192de: " Larry Finger
2020-07-17  2:01 ` [PATCH 08/14] rtlwifi: rtl8192ee: " Larry Finger
2020-07-17  2:01 ` [PATCH 09/14] rtlwifi: rtl8192se: " Larry Finger
2020-07-17  2:01 ` [PATCH 10/14] rtlwifi: rtl8723ae: " Larry Finger
2020-07-17  2:01 ` [PATCH 11/14] rtlwifi: rtl8723be: " Larry Finger
2020-07-17  2:01 ` [PATCH 12/14] rtlwifi: rtl8723-common: " Larry Finger
2020-07-17  2:02 ` [PATCH 13/14] rtlwifi: rtl8821ae: " Larry Finger
2020-07-17  2:02 ` [PATCH 14/14] rtlwifi: Remove final instances of RT_TRACE macros Larry Finger

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200717020201.18209-1-Larry.Finger@lwfinger.net \
    --to=larry.finger@lwfinger.net \
    --cc=kvalo@codeaurora.org \
    --cc=linux-wireless@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.