From: Denis Pauk <pauk.denis@gmail.com>
To: unlisted-recipients:; (no To-header on input)
Cc: eugene.shalygin@gmail.com, andy.shevchenko@gmail.com,
pauk.denis@gmail.com, platform-driver-x86@vger.kernel.org,
thomas@weissschuh.net, kernel@maidavale.org,
Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
Jean Delvare <jdelvare@suse.com>,
Guenter Roeck <linux@roeck-us.net>,
Jonathan Corbet <corbet@lwn.net>,
linux-hwmon@vger.kernel.org, linux-doc@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: [PATCH v11 0/2] Update ASUS WMI supported boards
Date: Mon, 15 Nov 2021 23:08:39 +0200 [thread overview]
Message-ID: <20211115210842.11972-1-pauk.denis@gmail.com> (raw)
Add support by WMI interface provided by Asus for B550/X570 boards:
* PRIME X570-PRO,
* ROG CROSSHAIR VIII HERO
* ROG CROSSHAIR VIII DARK HERO
* ROG CROSSHAIR VIII FORMULA
* ROG STRIX X570-E GAMING
* ROG STRIX B550-I GAMING
* ROG STRIX B550-E GAMING
Add support by WMI interface provided by Asus for X370/X470/
B450/X399 boards:
* ROG CROSSHAIR VI HERO,
* PRIME X399-A,
* PRIME X470-PRO,
* ROG CROSSHAIR VI EXTREME,
* ROG CROSSHAIR VI HERO (WI-FI AC),
* ROG CROSSHAIR VII HERO,
* ROG CROSSHAIR VII HERO (WI-FI),
* ROG STRIX Z390-F GAMING
* ROG STRIX B450-E GAMING,
* ROG STRIX B450-F GAMING,
* ROG STRIX B450-I GAMING,
* ROG STRIX X399-E GAMING,
* ROG STRIX X470-F GAMING,
* ROG STRIX X470-I GAMING,
* ROG ZENITH EXTREME,
* ROG ZENITH EXTREME ALPHA.
I have added "ROG STRIX Z390-F GAMING" to list of supported boards in
asus_wmi_sensors.
Could you please review?
Signed-off-by: Denis Pauk <pauk.denis@gmail.com>
Signed-off-by: Ed Brindley <kernel@maidavale.org>
Signed-off-by: Eugene Shalygin <eugene.shalygin@gmail.com>
Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
Changes in v11:
- Add "ROG STRIX Z390-F GAMING" to list of supported boards in
asus_wmi_sensors.
Changes in v10:
- Use long for sensor values.
- Remove unrequired linux/hwmon-sysfs.h
- Add "ROG STRIX B550-I GAMING" board support in asus_wmi_ec_sensors.
- Change code style in error status return.
- Remove unuses wmi.buffer and fix type of source in asus_wmi_sensors.
Changes in v9:
- Fix memory leaks in asus_wmi_ec_block_read()
- Fix buffer and parameter lengths in decode and encode algorithms
- Simplify encoding in read query
- Reshuffle structures to make pointer arithmetics simpler or
no-op in some cases
- Shuffle parameters in some functions to make it more logical
- Use temporary variable for EC info data structure
- Many indentation fixes to improve readability (breaks 80 characters rule)
- Fix memory leaks in asus_wmi_sensors:asus_wmi_*().
Changes in v8:
- Add seprate patch for ProArt X570-CREATOR WIFI support.
- Fix codestyle in defines and comments.
- Fix buffer length calculation.
- Use hex2bin/bin2hex for convert values in buffers.
- Remove unrequired acpi_os_free usage.
- Call mutex_lock inside of functions.
Changes in v7:
- Use for directly get sensors list by board.
- Add depends on ACPI_WMI to Kconfig.
- Add response buffer size check in asus_wmi_ec_decode_reply_buffer.
- Clean up defines names.
Changes in v6:
- asus_wmi_ec_sensors: Generate query for all sensors on sensors setup
- asus_wmi_ec_sensors: Move binary to sensor value logic to separate
get_sensor_value (by Eugene Shalygin)
- asus_wmi_ec_sensors: Use acpi_os_free without NULL pointer check.
- Add asus_wmi_sensor to documentation index.
- Add asus_wmi_ec_sensor to documentation index.
Changes in v5:
- Fixes build issue reported by kernel test robot with disabled ACPI_WMI.
- asus_wmi_sensors: Remove sensor->name check as always evaluated to true.
Changes in v4:
- Implement wmi driver instead platform driver.
- Update documentation with known issues.
Changes in v3:
- Use MODULE_DEVICE_TABLE for match devices.
- asus_wmi_ec_sensors: Use get_unaligned_be32 instead incorrectly used
get_unaligned_le32.
- Add documentaion for drivers.
Changes in v2:
- asus_wmi_ec_sensors: Rename asus_wmi_sensors to asus_wmi_ec_sensors for
B550/X570 boards.
- asus_wmi_ec_sensors: Use utf8s_to_utf16s/utf16s_to_utf8s instead handmade
fuctions.
- asus_wmi_ec_sensors: Use post increment.
- asus_wmi_ec_sensors: Use get_unaligned* for convert values.
- asus_wmi_ec_sensors: Use PTR_ERR_OR_ZERO.
- asus_wmi_ec_sensors: Specify per-board sensors in a declarative way
(by Eugene Shalygin).
- asus_wmi_sensors: Add support for X370/X470/B450/X399 boards.
---
Denis Pauk (2):
hwmon: (asus_wmi_ec_sensors) Support B550 Asus WMI.
hwmon: (asus_wmi_sensors) Support X370 Asus WMI.
Documentation/hwmon/asus_wmi_ec_sensors.rst | 38 ++
Documentation/hwmon/asus_wmi_sensors.rst | 77 +++
Documentation/hwmon/index.rst | 2 +
MAINTAINERS | 8 +
drivers/hwmon/Kconfig | 24 +
drivers/hwmon/Makefile | 2 +
drivers/hwmon/asus_wmi_ec_sensors.c | 621 ++++++++++++++++++
drivers/hwmon/asus_wmi_sensors.c | 665 ++++++++++++++++++++
8 files changed, 1437 insertions(+)
create mode 100644 Documentation/hwmon/asus_wmi_ec_sensors.rst
create mode 100644 Documentation/hwmon/asus_wmi_sensors.rst
create mode 100644 drivers/hwmon/asus_wmi_ec_sensors.c
create mode 100644 drivers/hwmon/asus_wmi_sensors.c
base-commit: 879af177e7210478f39ea366ce6d95e1e7a48d0e
--
2.33.0
next reply other threads:[~2021-11-15 23:36 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-11-15 21:08 Denis Pauk [this message]
2021-11-15 21:08 ` [PATCH v11 1/2] hwmon: (asus_wmi_ec_sensors) Support B550 Asus WMI Denis Pauk
2021-11-15 21:08 ` [PATCH v11 2/2] hwmon: (asus_wmi_sensors) Support X370 " Denis Pauk
2021-11-15 22:54 ` Guenter Roeck
2021-11-15 21:56 ` [PATCH v11 0/2] Update ASUS WMI supported boards Andy Shevchenko
2021-11-15 22:01 ` Andy Shevchenko
2021-11-15 23:15 ` Guenter Roeck
2021-11-16 10:38 ` Andy Shevchenko
2021-11-16 14:32 ` Guenter Roeck
2021-11-16 15:27 ` Andy Shevchenko
2021-11-15 22:21 ` Ed Brindley
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20211115210842.11972-1-pauk.denis@gmail.com \
--to=pauk.denis@gmail.com \
--cc=andriy.shevchenko@linux.intel.com \
--cc=andy.shevchenko@gmail.com \
--cc=corbet@lwn.net \
--cc=eugene.shalygin@gmail.com \
--cc=jdelvare@suse.com \
--cc=kernel@maidavale.org \
--cc=linux-doc@vger.kernel.org \
--cc=linux-hwmon@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@roeck-us.net \
--cc=platform-driver-x86@vger.kernel.org \
--cc=thomas@weissschuh.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.