From: "Jérôme Pouiller" <jerome.pouiller@silabs.com>
To: Jaehee Park <jhpark1013@gmail.com>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org,
outreachy@lists.linux.dev
Subject: Re: [PATCH] staging: wfx: change variable name to be consistent
Date: Sun, 03 Apr 2022 22:34:59 +0200 [thread overview]
Message-ID: <2021471.8hb0ThOEGa@pc-42> (raw)
In-Reply-To: <Ykl+ngCtuMIeF+Fw@kroah.com>
On Sunday 3 April 2022 13:01:50 CEST Greg Kroah-Hartman wrote:
> On Fri, Apr 01, 2022 at 10:53:50AM -0400, Jaehee Park wrote:
> > Change variable name to be consistent with the naming conventions.
> > ssidlen was changed to ssid_len and ssidie was changed to ssid_ie to be
> > consistent. This makes the variables more readable. The other ssid
> > names in the code are separated by an underscore. For example,
> > bssid_filter and num_of_ssids have the ssid separated from the rest of
> > the words with an underscore.
> >
> > Signed-off-by: Jaehee Park <jhpark1013@gmail.com>
> > ---
> > drivers/staging/wfx/hif_tx.c | 10 +++++-----
> > drivers/staging/wfx/sta.c | 20 ++++++++++----------
> > 2 files changed, 15 insertions(+), 15 deletions(-)
> >
> > diff --git a/drivers/staging/wfx/hif_tx.c b/drivers/staging/wfx/hif_tx.c
> > index ae3cc5919dcd..9c653d0e9034 100644
> > --- a/drivers/staging/wfx/hif_tx.c
> > +++ b/drivers/staging/wfx/hif_tx.c
> > @@ -280,7 +280,7 @@ int wfx_hif_stop_scan(struct wfx_vif *wvif)
> > }
> >
> > int wfx_hif_join(struct wfx_vif *wvif, const struct ieee80211_bss_conf *conf,
> > - struct ieee80211_channel *channel, const u8 *ssid, int ssidlen)
> > + struct ieee80211_channel *channel, const u8 *ssid, int ssid_len)
>
> This is not really a "coding style" cleanup, it is up to the driver
> author how they wish to name these variables. It is not a requirement
> to change them as the orginal names are just fine.
I have no real opinion. Let's say you can apply it:
Signed-off-by: Jérôme Pouiller <jerome.pouiller@silabs.com>
--
Jérôme Pouiller
prev parent reply other threads:[~2022-04-03 20:35 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-04-01 14:53 [PATCH] staging: wfx: change variable name to be consistent Jaehee Park
2022-04-03 11:01 ` Greg Kroah-Hartman
2022-04-03 20:34 ` Jérôme Pouiller [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2021471.8hb0ThOEGa@pc-42 \
--to=jerome.pouiller@silabs.com \
--cc=gregkh@linuxfoundation.org \
--cc=jhpark1013@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
--cc=outreachy@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.