From: Josh Poimboeuf <jpoimboe@redhat.com>
To: Marcos Paulo de Souza <mpdesouza@suse.com>
Cc: live-patching@vger.kernel.org, mbenes@suse.cz, pmladek@suse.com,
nstange@suse.de
Subject: Re: [PATCH 1/4] livepatch/shadow: Separate code to get or use pre-allocated shadow variable
Date: Fri, 1 Jul 2022 14:01:44 -0700 [thread overview]
Message-ID: <20220701210144.2wbrrmjswey2tilb@treble> (raw)
In-Reply-To: <20220701194817.24655-2-mpdesouza@suse.com>
On Fri, Jul 01, 2022 at 04:48:14PM -0300, Marcos Paulo de Souza wrote:
> From: Petr Mladek <pmladek@suse.com>
>
> Separate code that is used in klp_shadow_get_or_alloc() under klp_mutex.
> It splits a long spaghetti function into two. Also it unifies the error
> handling. The old used a mix of duplicated code, direct returns,
> and goto. The new code has only one unlock, free, and return calls.
>
> Background: The change was needed by an earlier variant of the code adding
> garbage collection of shadow variables. It is not needed in
> the end. But the change still looks like an useful clean up.
>
> It is code refactoring without any functional changes.
>
> Signed-off-by: Petr Mladek <pmladek@suse.com>
Hi Marcos,
Invalid Signed-off-by chain, it will need your SOB added as well.
Also, when posting patches please add lkml to Cc so they're archived and
visible to the wider community.
--
Josh
next prev parent reply other threads:[~2022-07-01 21:01 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-07-01 19:48 [PATCH 0/4] livepatch: Add garbage collection for shadow variables Marcos Paulo de Souza
2022-07-01 19:48 ` [PATCH 1/4] livepatch/shadow: Separate code to get or use pre-allocated shadow variable Marcos Paulo de Souza
2022-07-01 21:01 ` Josh Poimboeuf [this message]
2022-07-29 15:06 ` Petr Mladek
2022-07-01 19:48 ` [PATCH 2/4] livepatch/shadow: Separate code removing all shadow variables for a given id Marcos Paulo de Souza
2022-07-29 15:09 ` Petr Mladek
2022-07-01 19:48 ` [PATCH 3/4] livepatch/shadow: Introduce klp_shadow_type structure Marcos Paulo de Souza
2022-07-01 21:04 ` Josh Poimboeuf
2022-07-29 16:07 ` Petr Mladek
2022-08-25 14:50 ` Joe Lawrence
2022-08-25 14:54 ` Joe Lawrence
2022-10-24 13:24 ` Petr Mladek
2022-10-24 12:59 ` Petr Mladek
2022-07-01 19:48 ` [PATCH 4/4] livepatch/shadow: Add garbage collection of shadow variables Marcos Paulo de Souza
2022-08-25 12:59 ` Petr Mladek
2022-08-25 16:26 ` Joe Lawrence
2022-10-24 15:09 ` Petr Mladek
2022-11-01 11:02 ` Petr Mladek
2022-11-02 12:51 ` Joe Lawrence
2022-11-04 14:44 ` Joe Lawrence
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20220701210144.2wbrrmjswey2tilb@treble \
--to=jpoimboe@redhat.com \
--cc=live-patching@vger.kernel.org \
--cc=mbenes@suse.cz \
--cc=mpdesouza@suse.com \
--cc=nstange@suse.de \
--cc=pmladek@suse.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.