All of lore.kernel.org
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: Sagi Grimberg <sagi@grimberg.me>
Cc: Christoph Hellwig <hch@lst.de>,
	Joel Granados <j.granados@samsung.com>,
	kbusch@kernel.org, joshi.k@samsung.com,
	linux-nvme@lists.infradead.org, gost.dev@samsung.com,
	k.jensen@samsung.com
Subject: Re: [PATCH 5/5] nvme: enable generic interface (/dev/ngXnY) for unknown command sets
Date: Wed, 13 Jul 2022 12:19:33 +0200	[thread overview]
Message-ID: <20220713101933.GB27936@lst.de> (raw)
In-Reply-To: <7ca70ac5-db80-eb0d-5678-18bc1902a072@grimberg.me>

On Wed, Jul 13, 2022 at 12:25:38PM +0300, Sagi Grimberg wrote:
>>   	default:
>> -		dev_warn(ns->ctrl->device, "unknown csi %u for nsid %u\n",
>> -			info->ids.csi, info->nsid);
>> -		return -ENODEV;
>
> Maybe we want to keep the log? can be converted to dev_info/dev_dbg, but
> seems useful to have.

As-is I think it is more suitable for a dev_dbg as it sound like
gibberish to a user..


  reply	other threads:[~2022-07-13 10:19 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <CGME20220713054925eucas1p2f1015324abe9ccf6a665212f41d553c7@eucas1p2.samsung.com>
2022-07-13  5:49 ` enable generic interface (/dev/ngX) for unknown command sets Christoph Hellwig
2022-07-13  5:49   ` [PATCH 1/5] nvme: rename nvme_validate_or_alloc_ns to nvme_scan_ns Christoph Hellwig
2022-07-13  7:29     ` Chaitanya Kulkarni
2022-07-13  9:11     ` Sagi Grimberg
2022-07-13 10:23     ` Kanchan Joshi
2022-07-13  5:49   ` [PATCH 2/5] nvme: generalize the nvme_multi_css check in nvme_scan_ns Christoph Hellwig
2022-07-13  7:32     ` Chaitanya Kulkarni
2022-07-13  9:12     ` Sagi Grimberg
2022-07-13 10:24     ` Kanchan Joshi
2022-07-13  5:49   ` [PATCH 3/5] nvme: refactor namespace probing Christoph Hellwig
2022-07-13  9:21     ` Sagi Grimberg
2022-07-13 10:16       ` Christoph Hellwig
2022-07-13 11:29         ` Sagi Grimberg
2022-07-13 10:17     ` Kanchan Joshi
2022-07-13 11:27       ` Christoph Hellwig
2022-07-13  5:49   ` [PATCH 4/5] nvme: factor out a nvme_ns_is_readonly helper Christoph Hellwig
2022-07-13  7:55     ` Chaitanya Kulkarni
2022-07-13  9:23     ` Sagi Grimberg
2022-07-13 10:26     ` Kanchan Joshi
2022-07-13  5:49   ` [PATCH 5/5] nvme: enable generic interface (/dev/ngXnY) for unknown command sets Christoph Hellwig
2022-07-13  9:25     ` Sagi Grimberg
2022-07-13 10:19       ` Christoph Hellwig [this message]
2022-07-13  9:27   ` enable generic interface (/dev/ngX) " Javier González
2022-07-18  5:24 enable generic interface (/dev/ngX) for unknown command sets v2 Christoph Hellwig
2022-07-18  5:25 ` [PATCH 5/5] nvme: enable generic interface (/dev/ngXnY) for unknown command sets Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220713101933.GB27936@lst.de \
    --to=hch@lst.de \
    --cc=gost.dev@samsung.com \
    --cc=j.granados@samsung.com \
    --cc=joshi.k@samsung.com \
    --cc=k.jensen@samsung.com \
    --cc=kbusch@kernel.org \
    --cc=linux-nvme@lists.infradead.org \
    --cc=sagi@grimberg.me \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.