From: "Ritesh Harjani (IBM)" <ritesh.list@gmail.com>
To: Matthew Wilcox <willy@infradead.org>
Cc: Christoph Hellwig <hch@infradead.org>,
linux-xfs@vger.kernel.org, linux-fsdevel@vger.kernel.org,
Aravinda Herle <araherle@in.ibm.com>
Subject: Re: [RFCv2 3/3] iomap: Support subpage size dirty tracking to improve write performance
Date: Tue, 31 Jan 2023 02:14:59 +0530 [thread overview]
Message-ID: <20230130204459.fcfisawoh7jc62ej@rh-tp> (raw)
In-Reply-To: <Y9gF6RVxDkvEgQoG@casper.infradead.org>
On 23/01/30 06:01PM, Matthew Wilcox wrote:
> On Mon, Jan 30, 2023 at 09:16:33AM -0800, Christoph Hellwig wrote:
> > > + if (from_writeback && folio_test_uptodate(folio))
> > > + bitmap_fill(iop->state, 2 * nr_blocks);
> > > + else if (folio_test_uptodate(folio)) {
> >
> > This code is very confusing. First please only check
> > folio_test_uptodate one, and then check the from_writeback flag
> > inside the branch. And as mentioned last time I think you really
> > need some symbolic constants for dealing with dirty vs uptodate
> > state and not just do a single fill for them.
>
> And I don't think this 'from_writeback' argument is well-named.
> Presumably it's needed because folio_test_dirty() will be false
> at this point in the writeback path because it got cleared by the VFS?
Yes, folio_test_dirty() is false. We clear it in write_cache_pages() by calling
clear_page_dirty_for_io() before calling iomap_do_writepage().
> But in any case, it should be called 'dirty' or something, not tell me
> where the function was called from. I think what this should really
> do is:
>
> if (dirty)
> iop_set_dirty(iop, 0, nr_blocks);
> if (folio_test_uptodate(folio))
> iop_set_uptodate(iop, 0, nr_blocks);
Sure I got the idea. I will use "bool is_dirty".
>
> > > + unsigned start = offset_in_folio(folio,
> > > + folio_pos(folio)) >> inode->i_blkbits;
> > > + bitmap_set(iop->state, start, nr_blocks);
> >
> > Also this code leaves my head scratching. Unless I'm missing something
> > important
> >
> > offset_in_folio(folio, folio_pos(folio))
> >
> > must always return 0.
>
> You are not missing anything. I don't understand the mental process
> that gets someone to writing that. It should logically be 0.
Sorry about the confusion. Yes, that is correct. I ended up using above at some
place and 0 at others. Then for final cleanup I ended up using the above call.
I will correct it in the next rev.
>
> > Also the from_writeback logic is weird. I'd rather have a
> > "bool is_dirty" argument and then pass true for writeback beause
> > we know the folio is dirty, false where we know it can't be
> > dirty and do the folio_test_dirty in the caller where we don't
> > know the state.
>
> hahaha, you think the same. ok, i'm leaving my above comment though ;-)
>
No problem ;)
Thanks for your review!!
-ritesh
next prev parent reply other threads:[~2023-01-30 20:45 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-01-30 16:14 [RFCv2 0/3] iomap: Add support for subpage dirty state tracking to improve write performance Ritesh Harjani (IBM)
2023-01-30 16:14 ` [RFCv2 1/3] iomap: Move creation of iomap_page early in __iomap_write_begin Ritesh Harjani (IBM)
2023-01-30 17:02 ` Christoph Hellwig
2023-01-30 20:21 ` Ritesh Harjani (IBM)
2023-01-30 21:00 ` Matthew Wilcox
2023-01-31 18:37 ` Ritesh Harjani (IBM)
2023-01-31 18:48 ` Matthew Wilcox
2023-01-31 20:00 ` Ritesh Harjani (IBM)
2023-01-30 16:14 ` [RFCv2 2/3] iomap: Change uptodate variable name to state Ritesh Harjani (IBM)
2023-01-30 21:56 ` Dave Chinner
2023-01-30 22:24 ` Matthew Wilcox
2023-01-31 15:07 ` Christoph Hellwig
2023-01-31 18:05 ` Ritesh Harjani (IBM)
2023-01-30 16:14 ` [RFCv2 3/3] iomap: Support subpage size dirty tracking to improve write performance Ritesh Harjani (IBM)
2023-01-30 17:16 ` Christoph Hellwig
2023-01-30 18:01 ` Matthew Wilcox
2023-01-30 20:44 ` Ritesh Harjani (IBM) [this message]
2023-01-30 20:27 ` Ritesh Harjani (IBM)
2023-01-30 17:54 ` Matthew Wilcox
2023-01-30 20:34 ` Ritesh Harjani (IBM)
2023-01-30 18:10 ` [RFCv2 0/3] iomap: Add support for subpage dirty state " Matthew Wilcox
2023-01-30 21:01 ` Ritesh Harjani (IBM)
2023-02-02 4:45 ` Ritesh Harjani (IBM)
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230130204459.fcfisawoh7jc62ej@rh-tp \
--to=ritesh.list@gmail.com \
--cc=araherle@in.ibm.com \
--cc=hch@infradead.org \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-xfs@vger.kernel.org \
--cc=willy@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.