From: Damien Le Moal <dlemoal@kernel.org>
To: linux-pci@vger.kernel.org, Bjorn Helgaas <bhelgaas@google.com>
Cc: Lorenzo Pieralisi <lpieralisi@kernel.org>,
Kishon Vijay Abraham I <kishon@kernel.org>,
Manivannan Sadhasivami <manivannan.sadhasivam@linaro.org>,
Serge Semin <fancer.lancer@gmail.com>,
Yoshihiro Shimoda <yoshihiro.shimoda.uh@renesas.com>
Subject: [PATCH 0/2] Cleanup IRQ type definitions
Date: Mon, 31 Jul 2023 10:25:48 +0900 [thread overview]
Message-ID: <20230731012550.728070-1-dlemoal@kernel.org> (raw)
The first patch renames PCI_IRQ_LEGACY to PCI_IRQ_INTX as suggested by
Bjorn (hence the patch authorship is given to him).
The second patch removes the redundant IRQ type definitions
PCI_EPC_IRQ_XXX and replace these with a direct use of the PCI_IRQ_XXX
definitions. Going forward, more cleanups renaming "legacy" to "intx"
in various drivers can be added on top of this series.
Bjorn Helgaas (1):
PCI: Rename PCI_IRQ_LEGACY to PCI_IRQ_INTX
Damien Le Moal (1):
PCI: endpoint: Drop PCI_EPC_IRQ_XXX definitions
drivers/pci/controller/cadence/pcie-cadence-ep.c | 9 ++++-----
drivers/pci/controller/dwc/pci-dra7xx.c | 6 +++---
drivers/pci/controller/dwc/pci-imx6.c | 9 ++++-----
drivers/pci/controller/dwc/pci-keystone.c | 9 ++++-----
drivers/pci/controller/dwc/pci-layerscape-ep.c | 8 ++++----
drivers/pci/controller/dwc/pcie-artpec6.c | 8 ++++----
drivers/pci/controller/dwc/pcie-designware-ep.c | 2 +-
drivers/pci/controller/dwc/pcie-designware-plat.c | 9 ++++-----
drivers/pci/controller/dwc/pcie-designware.h | 2 +-
drivers/pci/controller/dwc/pcie-keembay.c | 13 ++++++-------
drivers/pci/controller/dwc/pcie-qcom-ep.c | 6 +++---
drivers/pci/controller/dwc/pcie-tegra194.c | 9 ++++-----
drivers/pci/controller/dwc/pcie-uniphier-ep.c | 7 +++----
drivers/pci/controller/pcie-rcar-ep.c | 7 +++----
drivers/pci/controller/pcie-rockchip-ep.c | 7 +++----
drivers/pci/endpoint/functions/pci-epf-mhi.c | 2 +-
drivers/pci/endpoint/functions/pci-epf-ntb.c | 4 ++--
drivers/pci/endpoint/functions/pci-epf-test.c | 6 +++---
drivers/pci/endpoint/functions/pci-epf-vntb.c | 7 ++-----
drivers/pci/endpoint/pci-epc-core.c | 2 +-
include/linux/pci-epc.h | 11 ++---------
include/linux/pci.h | 4 +++-
22 files changed, 65 insertions(+), 82 deletions(-)
--
2.41.0
next reply other threads:[~2023-07-31 1:26 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-07-31 1:25 Damien Le Moal [this message]
2023-07-31 1:25 ` [PATCH 1/2] PCI: Rename PCI_IRQ_LEGACY to PCI_IRQ_INTX Damien Le Moal
2023-08-01 21:06 ` Bjorn Helgaas
2023-07-31 1:25 ` [PATCH 2/2] PCI: endpoint: Drop PCI_EPC_IRQ_XXX definitions Damien Le Moal
2023-07-31 1:56 ` [PATCH 0/2] Cleanup IRQ type definitions Yoshihiro Shimoda
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230731012550.728070-1-dlemoal@kernel.org \
--to=dlemoal@kernel.org \
--cc=bhelgaas@google.com \
--cc=fancer.lancer@gmail.com \
--cc=kishon@kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=lpieralisi@kernel.org \
--cc=manivannan.sadhasivam@linaro.org \
--cc=yoshihiro.shimoda.uh@renesas.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.