From: "Darrick J. Wong" <djwong@kernel.org>
To: Christoph Hellwig <hch@lst.de>
Cc: linux-xfs@vger.kernel.org, osandov@osandov.com
Subject: Re: [PATCH 5/8] xfs: create helpers for rtbitmap block/wordcount computations
Date: Thu, 12 Oct 2023 14:55:46 -0700 [thread overview]
Message-ID: <20231012215546.GN21298@frogsfrogsfrogs> (raw)
In-Reply-To: <20231012054433.GD2795@lst.de>
On Thu, Oct 12, 2023 at 07:44:33AM +0200, Christoph Hellwig wrote:
> On Wed, Oct 11, 2023 at 11:07:32AM -0700, Darrick J. Wong wrote:
> > +/*
> > + * Compute the number of rtbitmap blocks needed to track the given number of rt
> > + * extents.
> > + */
> > +xfs_filblks_t
> > +xfs_rtbitmap_blockcount(
> > + struct xfs_mount *mp,
> > + xfs_rtbxlen_t rtextents)
> > +{
> > + return howmany_64(rtextents, NBBY * mp->m_sb.sb_blocksize);
> > +}
>
> Given that this only has a few users, the !RT stub is a pain, and
> having a different result from before in the transaction reservation
> is somewhat unexpected change (even if harmless),
Ohh, right, I didn't even notice that the result changes slightly when
the we go from dividing by NBBY before howmany'ing with blocksize to
howmany'ing with (NBBY * blocksize).
> maybe just mark this inline?
I could make these inline functions at the bottom of xfs_rtbitmap.h, and
even put them outside of the #ifdef RT bits. That'll get rid of two
stubs for now, but later the rtgroups patchset wants to add a header
to rtbitmap blocks. Then we'll need a function to compute the number of
rtextents covered by a single bitmap block:
/* Compute the number of rt extents tracked by a single bitmap block. */
xfs_rtxnum_t
xfs_rtbitmap_rtx_per_rbmblock(
struct xfs_mount *mp)
{
unsigned int rbmblock_bytes = mp->m_sb.sb_blocksize;
if (xfs_has_rtgroups(mp))
rbmblock_bytes -= sizeof(struct xfs_rtbuf_blkinfo);
return rbmblock_bytes * NBBY;
}
So then either this function will need to have a stub that returns a
garbage value. Alternately, it could move out of xfs_rtbitmap.c.
Right now, xfs_rtbitmap_rtx_per_rbmblock isn't even a defined symbol for
!RT, and the stub version of _wordcount and _blockcount return 0, which
at least makes sense.
> > +/*
> > + * Compute the number of rtbitmap words needed to populate every block of a
> > + * bitmap that is large enough to track the given number of rt extents.
> > + */
> > +unsigned long long
> > +xfs_rtbitmap_wordcount(
> > + struct xfs_mount *mp,
> > + xfs_rtbxlen_t rtextents)
> > +{
> > + xfs_filblks_t blocks;
> > +
> > + blocks = xfs_rtbitmap_blockcount(mp, rtextents);
> > + return XFS_FSB_TO_B(mp, blocks) >> XFS_WORDLOG;
> > +}
>
> This one isn't used in this patch or the rest of the series. Maybe
> move it to the patch (-series) that adds the caller in the repair
> code?
<shrug> The xfsprogs version of this patch uses this helper to decrapify
the incore rtbitmap computation in xfs_repair:
diff --git a/repair/rt.c b/repair/rt.c
index 8f3b9082a9b..244b59f04ce 100644
--- a/repair/rt.c
+++ b/repair/rt.c
@@ -19,6 +19,8 @@
void
rtinit(xfs_mount_t *mp)
{
+ unsigned long long wordcnt;
+
if (mp->m_sb.sb_rblocks == 0)
return;
@@ -26,11 +28,9 @@ rtinit(xfs_mount_t *mp)
* realtime init -- blockmap initialization is
* handled by incore_init()
*/
- /*
- sumfile = calloc(mp->m_rsumsize, 1);
- */
- if ((btmcompute = calloc(mp->m_sb.sb_rbmblocks *
- mp->m_sb.sb_blocksize, 1)) == NULL)
+ wordcnt = libxfs_rtbitmap_wordcount(mp, mp->m_sb.sb_rextents);
+ btmcompute = calloc(wordcnt, sizeof(xfs_rtword_t));
+ if (!btmcompute)
do_error(
_("couldn't allocate memory for incore realtime bitmap.\n"));
So I'd rather leave these two helpers defined as they are.
--D
next prev parent reply other threads:[~2023-10-12 21:55 UTC|newest]
Thread overview: 86+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-10-11 17:57 [PATCHBOMB RFC]: xfs: realtime units cleanups Darrick J. Wong
2023-10-11 18:01 ` [PATCHSET RFC v1.0 0/3] xfs: minor bugfixes for rt stuff Darrick J. Wong
2023-10-11 18:02 ` [PATCH 1/3] xfs: bump max fsgeom struct version Darrick J. Wong
2023-10-12 4:51 ` Christoph Hellwig
2023-10-12 17:34 ` Darrick J. Wong
2023-10-11 18:02 ` [PATCH 2/3] xfs: prevent rt growfs when quota is enabled Darrick J. Wong
2023-10-12 4:51 ` Christoph Hellwig
2023-10-11 18:02 ` [PATCH 3/3] xfs: rt stubs should return negative errnos when rt disabled Darrick J. Wong
2023-10-12 4:52 ` Christoph Hellwig
2023-10-11 18:01 ` [PATCHSET RFC v1.0 0/7] xfs: clean up realtime type usage Darrick J. Wong
2023-10-11 18:02 ` [PATCH 1/7] xfs: make sure maxlen is still congruent with prod when rounding down Darrick J. Wong
2023-10-12 4:59 ` Christoph Hellwig
2023-10-12 17:31 ` Darrick J. Wong
2023-10-13 4:22 ` Christoph Hellwig
2023-10-11 18:03 ` [PATCH 2/7] xfs: move the xfs_rtbitmap.c declarations to xfs_rtbitmap.h Darrick J. Wong
2023-10-12 6:33 ` Christoph Hellwig
2023-10-11 18:03 ` [PATCH 3/7] xfs: convert xfs_extlen_t to xfs_rtxlen_t in the rt allocator Darrick J. Wong
2023-10-12 5:00 ` Christoph Hellwig
2023-10-11 18:03 ` [PATCH 4/7] xfs: convert rt bitmap/summary block numbers to xfs_fileoff_t Darrick J. Wong
2023-10-12 5:01 ` Christoph Hellwig
2023-10-11 18:03 ` [PATCH 5/7] xfs: convert rt bitmap extent lengths to xfs_rtbxlen_t Darrick J. Wong
2023-10-12 5:01 ` Christoph Hellwig
2023-10-11 18:04 ` [PATCH 6/7] xfs: rename xfs_verify_rtext to xfs_verify_rtbext Darrick J. Wong
2023-10-12 5:02 ` Christoph Hellwig
2023-10-11 18:04 ` [PATCH 7/7] xfs: convert rt extent numbers to xfs_rtxnum_t Darrick J. Wong
2023-10-12 5:03 ` Christoph Hellwig
2023-10-12 5:05 ` [PATCHSET RFC v1.0 0/7] xfs: clean up realtime type usage Christoph Hellwig
2023-10-12 22:30 ` Darrick J. Wong
2023-10-13 4:24 ` Christoph Hellwig
2023-10-17 0:48 ` Darrick J. Wong
2023-10-17 4:05 ` Christoph Hellwig
2023-10-11 18:01 ` [PATCHSET RFC v1.0 0/7] xfs: refactor rt extent unit conversions Darrick J. Wong
2023-10-11 18:04 ` [PATCH 1/7] xfs: create a helper to convert rtextents to rtblocks Darrick J. Wong
2023-10-12 5:10 ` Christoph Hellwig
2023-10-11 18:04 ` [PATCH 2/7] xfs: create a helper to compute leftovers of realtime extents Darrick J. Wong
2023-10-12 5:11 ` Christoph Hellwig
2023-10-12 17:40 ` Darrick J. Wong
2023-10-11 18:05 ` [PATCH 3/7] " Darrick J. Wong
2023-10-12 6:34 ` Christoph Hellwig
2023-10-11 18:05 ` [PATCH 4/7] xfs: create helpers to convert rt block numbers to rt extent numbers Darrick J. Wong
2023-10-12 5:17 ` Christoph Hellwig
2023-10-12 17:58 ` Darrick J. Wong
2023-10-13 4:25 ` Christoph Hellwig
2023-10-11 18:05 ` [PATCH 5/7] xfs: convert do_div calls to xfs_rtb_to_rtx helper calls Darrick J. Wong
2023-10-12 5:22 ` Christoph Hellwig
2023-10-12 18:10 ` Darrick J. Wong
2023-10-11 18:05 ` [PATCH 6/7] xfs: create rt extent rounding helpers for realtime extent blocks Darrick J. Wong
2023-10-12 5:22 ` Christoph Hellwig
2023-10-11 18:06 ` [PATCH 7/7] xfs: use shifting and masking when converting rt extents, if possible Darrick J. Wong
2023-10-12 5:25 ` Christoph Hellwig
2023-10-12 18:19 ` Darrick J. Wong
2023-10-16 17:19 ` Omar Sandoval
2023-10-17 0:51 ` Darrick J. Wong
2023-10-11 18:01 ` [PATCHSET RFC v1.0 0/8] xfs: refactor rtbitmap/summary macros Darrick J. Wong
2023-10-11 18:06 ` [PATCH 1/8] xfs: convert the rtbitmap block and bit macros to static inline functions Darrick J. Wong
2023-10-12 6:34 ` Christoph Hellwig
2023-10-11 18:06 ` [PATCH 2/8] xfs: remove XFS_BLOCKWSIZE and XFS_BLOCKWMASK macros Darrick J. Wong
2023-10-12 5:33 ` Christoph Hellwig
2023-10-12 18:20 ` Darrick J. Wong
2023-10-13 5:53 ` Christoph Hellwig
2023-10-17 0:49 ` Darrick J. Wong
2023-10-11 18:07 ` [PATCH 3/8] xfs: convert open-coded xfs_rtword_t pointer accesses to helper Darrick J. Wong
2023-10-12 5:39 ` Christoph Hellwig
2023-10-12 18:26 ` Darrick J. Wong
2023-10-11 18:07 ` [PATCH 4/8] xfs: convert rt summary macros to helpers Darrick J. Wong
2023-10-12 5:41 ` Christoph Hellwig
2023-10-11 18:07 ` [PATCH 5/8] xfs: create helpers for rtbitmap block/wordcount computations Darrick J. Wong
2023-10-12 5:44 ` Christoph Hellwig
2023-10-12 21:55 ` Darrick J. Wong [this message]
2023-10-13 4:26 ` Christoph Hellwig
2023-10-11 18:07 ` [PATCH 6/8] xfs: use accessor functions for bitmap words Darrick J. Wong
2023-10-12 6:19 ` Christoph Hellwig
2023-10-12 22:11 ` Darrick J. Wong
2023-10-13 4:28 ` Christoph Hellwig
2023-10-13 16:58 ` Darrick J. Wong
2023-10-11 18:08 ` [PATCH 7/8] xfs: create helpers for rtsummary block/wordcount computations Darrick J. Wong
2023-10-12 6:25 ` Christoph Hellwig
2023-10-12 22:18 ` Darrick J. Wong
2023-10-13 4:29 ` Christoph Hellwig
2023-10-13 17:11 ` Darrick J. Wong
2023-10-11 18:08 ` [PATCH 8/8] xfs: use accessor functions for summary info words Darrick J. Wong
2023-10-12 6:26 ` Christoph Hellwig
2023-10-12 22:21 ` Darrick J. Wong
-- strict thread matches above, loose matches on Subject: below --
2023-10-17 15:46 [PATCHSET RFC v1.1 0/8] xfs: refactor rtbitmap/summary macros Darrick J. Wong
2023-10-17 15:53 ` [PATCH 5/8] xfs: create helpers for rtbitmap block/wordcount computations Darrick J. Wong
2023-10-17 16:33 ` Christoph Hellwig
2022-12-30 22:17 [PATCHSET v1.0 0/8] xfs: refactor rtbitmap/summary macros Darrick J. Wong
2022-12-30 22:17 ` [PATCH 5/8] xfs: create helpers for rtbitmap block/wordcount computations Darrick J. Wong
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20231012215546.GN21298@frogsfrogsfrogs \
--to=djwong@kernel.org \
--cc=hch@lst.de \
--cc=linux-xfs@vger.kernel.org \
--cc=osandov@osandov.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.