All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jakub Kicinski <kuba@kernel.org>
To: davem@davemloft.net
Cc: netdev@vger.kernel.org, edumazet@google.com, pabeni@redhat.com,
	johannes.berg@intel.com, mpe@ellerman.id.au, j@w1.fi,
	jiri@resnulli.us
Subject: [PATCH net-next v2 0/6] net: deduplicate netdev name allocation
Date: Mon, 23 Oct 2023 08:23:40 -0700	[thread overview]
Message-ID: <20231023152346.3639749-1-kuba@kernel.org> (raw)

After recent fixes we have even more duplicated code in netdev name
allocation helpers. There are two complications in this code.
First, __dev_alloc_name() clobbers its output arg even if allocation
fails, forcing callers to do extra copies. Second as our experience in
commit 55a5ec9b7710 ("Revert "net: core: dev_get_valid_name is now the same as dev_alloc_name_ns"") and
commit 029b6d140550 ("Revert "net: core: maybe return -EEXIST in __dev_alloc_name"")
taught us, user space is very sensitive to the exact error codes.

Align the callers of __dev_alloc_name(), and remove some of its
complexity.

v2: extend commit message on patch 4
v1: https://lore.kernel.org/all/20231020011856.3244410-1-kuba@kernel.org/

Jakub Kicinski (6):
  net: don't use input buffer of __dev_alloc_name() as a scratch space
  net: make dev_alloc_name() call dev_prep_valid_name()
  net: reduce indentation of __dev_alloc_name()
  net: trust the bitmap in __dev_alloc_name()
  net: remove dev_valid_name() check from __dev_alloc_name()
  net: remove else after return in dev_prep_valid_name()

 net/core/dev.c | 120 +++++++++++++++++++------------------------------
 1 file changed, 45 insertions(+), 75 deletions(-)

-- 
2.41.0


             reply	other threads:[~2023-10-23 15:23 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-10-23 15:23 Jakub Kicinski [this message]
2023-10-23 15:23 ` [PATCH net-next v2 1/6] net: don't use input buffer of __dev_alloc_name() as a scratch space Jakub Kicinski
2023-10-23 15:23 ` [PATCH net-next v2 2/6] net: make dev_alloc_name() call dev_prep_valid_name() Jakub Kicinski
2023-10-23 15:23 ` [PATCH net-next v2 3/6] net: reduce indentation of __dev_alloc_name() Jakub Kicinski
2023-10-23 15:23 ` [PATCH net-next v2 4/6] net: trust the bitmap in __dev_alloc_name() Jakub Kicinski
2023-10-24  7:12   ` Jiri Pirko
2023-10-23 15:23 ` [PATCH net-next v2 5/6] net: remove dev_valid_name() check from __dev_alloc_name() Jakub Kicinski
2023-10-23 15:23 ` [PATCH net-next v2 6/6] net: remove else after return in dev_prep_valid_name() Jakub Kicinski
2023-10-24 20:10 ` [PATCH net-next v2 0/6] net: deduplicate netdev name allocation patchwork-bot+netdevbpf

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20231023152346.3639749-1-kuba@kernel.org \
    --to=kuba@kernel.org \
    --cc=davem@davemloft.net \
    --cc=edumazet@google.com \
    --cc=j@w1.fi \
    --cc=jiri@resnulli.us \
    --cc=johannes.berg@intel.com \
    --cc=mpe@ellerman.id.au \
    --cc=netdev@vger.kernel.org \
    --cc=pabeni@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.