All of lore.kernel.org
 help / color / mirror / Atom feed
From: kernel test robot <lkp@intel.com>
To: Junxian Huang <huangjunxian6@hisilicon.com>,
	jgg@ziepe.ca, leon@kernel.org
Cc: oe-kbuild-all@lists.linux.dev, linux-rdma@vger.kernel.org,
	linuxarm@huawei.com, linux-kernel@vger.kernel.org,
	huangjunxian6@hisilicon.com
Subject: Re: [PATCH for-rc 6/6] RDMA/hns: Improve the readability of free mr uninit
Date: Wed, 6 Dec 2023 13:04:59 +0800	[thread overview]
Message-ID: <202312061253.0VL1jlNs-lkp@intel.com> (raw)
In-Reply-To: <20231129094434.134528-7-huangjunxian6@hisilicon.com>

Hi Junxian,

kernel test robot noticed the following build warnings:

[auto build test WARNING on linus/master]
[also build test WARNING on v6.7-rc4]
[cannot apply to rdma/for-next next-20231205]
[If your patch is applied to the wrong git tree, kindly drop us a note.
And when submitting patch, we suggest to use '--base' as documented in
https://git-scm.com/docs/git-format-patch#_base_tree_information]

url:    https://github.com/intel-lab-lkp/linux/commits/Junxian-Huang/RDMA-hns-Rename-the-interrupts/20231129-183932
base:   linus/master
patch link:    https://lore.kernel.org/r/20231129094434.134528-7-huangjunxian6%40hisilicon.com
patch subject: [PATCH for-rc 6/6] RDMA/hns: Improve the readability of free mr uninit
config: sparc64-allmodconfig (https://download.01.org/0day-ci/archive/20231206/202312061253.0VL1jlNs-lkp@intel.com/config)
compiler: sparc64-linux-gcc (GCC) 13.2.0
reproduce (this is a W=1 build): (https://download.01.org/0day-ci/archive/20231206/202312061253.0VL1jlNs-lkp@intel.com/reproduce)

If you fix the issue in a separate patch/commit (i.e. not just a new version of
the same patch/commit), kindly add following tags
| Reported-by: kernel test robot <lkp@intel.com>
| Closes: https://lore.kernel.org/oe-kbuild-all/202312061253.0VL1jlNs-lkp@intel.com/

All warnings (new ones prefixed by >>):

   drivers/infiniband/hw/hns/hns_roce_hw_v2.c: In function 'free_mr_exit':
>> drivers/infiniband/hw/hns/hns_roce_hw_v2.c:2684:23: warning: unused variable 'qp' [-Wunused-variable]
    2684 |         struct ib_qp *qp;
         |                       ^~


vim +/qp +2684 drivers/infiniband/hw/hns/hns_roce_hw_v2.c

  2679	
  2680	static void free_mr_exit(struct hns_roce_dev *hr_dev)
  2681	{
  2682		struct hns_roce_v2_priv *priv = hr_dev->priv;
  2683		struct hns_roce_v2_free_mr *free_mr = &priv->free_mr;
> 2684		struct ib_qp *qp;
  2685		int i;
  2686	
  2687		for (i = 0; i < ARRAY_SIZE(free_mr->rsv_qp); i++)
  2688			free_mr_uninit_qp(hr_dev, i);
  2689	
  2690		free_mr_uninit_cq(hr_dev);
  2691	
  2692		free_mr_uninit_pd(hr_dev);
  2693	}
  2694	

-- 
0-DAY CI Kernel Test Service
https://github.com/intel/lkp-tests/wiki

  reply	other threads:[~2023-12-06  5:06 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-11-29  9:44 [PATCH for-rc 0/6] Bugfixes and improvements for hns RoCE Junxian Huang
2023-11-29  9:44 ` [PATCH for-rc 1/6] RDMA/hns: Rename the interrupts Junxian Huang
2023-11-29  9:44 ` [PATCH for-rc 2/6] RDMA/hns: Response dmac to userspace Junxian Huang
2023-11-29  9:44 ` [PATCH for-rc 3/6] RDMA/hns: Add a max length of gid table Junxian Huang
2023-11-29  9:44 ` [PATCH for-rc 4/6] RDMA/hns: Remove unnecessary checks for NULL in mtr_alloc_bufs() Junxian Huang
2023-11-29  9:44 ` [PATCH for-rc 5/6] RDMA/hns: Fix memory leak in free_mr_init() Junxian Huang
2023-11-29  9:44 ` [PATCH for-rc 6/6] RDMA/hns: Improve the readability of free mr uninit Junxian Huang
2023-12-06  5:04   ` kernel test robot [this message]
2023-12-04 14:24 ` [PATCH for-rc 0/6] Bugfixes and improvements for hns RoCE Leon Romanovsky
2023-12-05  2:05   ` Junxian Huang
2023-12-06 14:27     ` Leon Romanovsky

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=202312061253.0VL1jlNs-lkp@intel.com \
    --to=lkp@intel.com \
    --cc=huangjunxian6@hisilicon.com \
    --cc=jgg@ziepe.ca \
    --cc=leon@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-rdma@vger.kernel.org \
    --cc=linuxarm@huawei.com \
    --cc=oe-kbuild-all@lists.linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.