All of lore.kernel.org
 help / color / mirror / Atom feed
From: Erick Archer <erick.archer@gmx.com>
To: Hu Haowen <2023002089@link.tyut.edu.cn>,
	Jonathan Corbet <corbet@lwn.net>
Cc: Erick Archer <erick.archer@gmx.com>, Alex Shi <alexs@kernel.org>,
	Yanteng Si <siyanteng@loongson.cn>,
	"Gustavo A. R. Silva" <gustavoars@kernel.org>,
	linux-doc@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-hardening@vger.kernel.org
Subject: Re: [PATCH] docs/zh_CN/power: Use kcalloc() instead of kzalloc()
Date: Sun, 21 Jan 2024 11:02:00 +0100	[thread overview]
Message-ID: <20240121100200.GA2790@titan> (raw)
In-Reply-To: <a567932c-d878-44e5-836f-90fa15999ba6@link.tyut.edu.cn>

Hi Hu and Jonathan,

On Sat, Jan 20, 2024 at 10:24:42PM +0800, Hu Haowen wrote:
>
> 在 2024/1/20 20:22, Erick Archer 写道:
> > As noted in the "Deprecated Interfaces, Language Features, Attributes,
> > and Conventions" documentation [1], size calculations (especially
> > multiplication) should not be performed in memory allocator (or similar)
> > function arguments due to the risk of them overflowing. This could lead
> > to values wrapping around and a smaller allocation being made than the
> > caller was expecting. Using those allocations could lead to linear
> > overflows of heap memory and other misbehaviors.
> >
> > So, in the example code use the purpose specific kcalloc() function
> > instead of the argument size * count in the kzalloc() function.
> >
> > Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> > Link: https://github.com/KSPP/linux/issues/162
> > Signed-off-by: Erick Archer <erick.archer@gmx.com>
> > ---
> >   Documentation/translations/zh_CN/power/opp.rst | 2 +-
> >   1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/Documentation/translations/zh_CN/power/opp.rst b/Documentation/translations/zh_CN/power/opp.rst
> > index 8d6e3f6f6202..7470fa2d4c43 100644
> > --- a/Documentation/translations/zh_CN/power/opp.rst
> > +++ b/Documentation/translations/zh_CN/power/opp.rst
> > @@ -274,7 +274,7 @@ dev_pm_opp_get_opp_count
> >   	 {
> >   		/* 做一些事情 */
> >   		num_available = dev_pm_opp_get_opp_count(dev);
> > -		speeds = kzalloc(sizeof(u32) * num_available, GFP_KERNEL);
> > +		speeds = kcalloc(num_available, sizeof(u32), GFP_KERNEL);
>
>
> If the translated version is modified, I think the original file should
> follow as well at Documentation/power/opp.rst line 308:
>
> diff --git a/Documentation/power/opp.rst b/Documentation/power/opp.rst
> index a7c03c470980..dca35018214a 100644
> --- a/Documentation/power/opp.rst
> +++ b/Documentation/power/opp.rst
> @@ -305,7 +305,7 @@ dev_pm_opp_get_opp_count
>          {
>                 /* Do things */
>                 num_available = dev_pm_opp_get_opp_count(dev);
> -               speeds = kzalloc(sizeof(u32) * num_available, GFP_KERNEL);
> +               speeds = kcalloc(sizeof(u32) * num_available, GFP_KERNEL);
>                 /* populate the table in increasing order */
>                 freq = 0;
>                 while (!IS_ERR(opp = dev_pm_opp_find_freq_ceil(dev, &freq)))
> {

As you both suggested, this change should be made if the original file is
changed. Therefore, before this patch I already sent another one [1] that
made the proposed changes to the original file.

[1] https://lore.kernel.org/linux-hardening/20240120120527.3866-1-erick.archer@gmx.com/

But if you prefer, I can send just one patch with the two changes.

Best regards,
Erick

>
> Thanks,
> Hu Haowen
>
>
> >   		/* 按升序填充表 */
> >   		freq = 0;
> >   		while (!IS_ERR(opp = dev_pm_opp_find_freq_ceil(dev, &freq))) {
> > --
> > 2.25.1
> >
> >
> >

  reply	other threads:[~2024-01-21 10:02 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-01-20 12:22 [PATCH] docs/zh_CN/power: Use kcalloc() instead of kzalloc() Erick Archer
2024-01-20 14:24 ` Hu Haowen
2024-01-21 10:02   ` Erick Archer [this message]
2024-01-20 15:38 ` Jonathan Corbet

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20240121100200.GA2790@titan \
    --to=erick.archer@gmx.com \
    --cc=2023002089@link.tyut.edu.cn \
    --cc=alexs@kernel.org \
    --cc=corbet@lwn.net \
    --cc=gustavoars@kernel.org \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-hardening@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=siyanteng@loongson.cn \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.