From: Bjorn Helgaas <helgaas@kernel.org>
To: Frank Li <Frank.Li@nxp.com>
Cc: "Bjorn Helgaas" <bhelgaas@google.com>,
"Jingoo Han" <jingoohan1@gmail.com>,
"Gustavo Pimentel" <gustavo.pimentel@synopsys.com>,
"Manivannan Sadhasivam" <manivannan.sadhasivam@linaro.org>,
"Lorenzo Pieralisi" <lpieralisi@kernel.org>,
"Krzysztof Wilczyński" <kw@linux.com>,
"Rob Herring" <robh@kernel.org>,
"Krzysztof Kozlowski" <krzysztof.kozlowski+dt@linaro.org>,
"Conor Dooley" <conor+dt@kernel.org>,
imx@lists.linux.dev, linux-pci@vger.kernel.org,
linux-kernel@vger.kernel.org, devicetree@vger.kernel.org,
"Yoshihiro Shimoda" <yoshihiro.shimoda.uh@renesas.com>,
"Serge Semin" <fancer.lancer@gmail.com>
Subject: Re: [PATCH 2/6] PCI: dwc: Change arguments of dw_pcie_prog_outbound_atu()
Date: Wed, 31 Jan 2024 09:41:15 -0600 [thread overview]
Message-ID: <20240131154115.GA587326@bhelgaas> (raw)
In-Reply-To: <20240130-pme_msg-v1-2-d52b0add5c7c@nxp.com>
Nit: could the subject line be more specific than "change arguments"?
E.g., something about collecting dw_pcie_prog_outbound_atu() arguments
in a struct? If you know that's the fundamental change, it's a lot
easier to read the commit log and the patch because you know the goal.
On Tue, Jan 30, 2024 at 07:45:27PM -0500, Frank Li wrote:
> From: Yoshihiro Shimoda <yoshihiro.shimoda.uh@renesas.com>
>
> This is a preparation before adding the Msg-type outbound iATU
> mapping. The respective update will require two more arguments added
> to __dw_pcie_prog_outbound_atu(). That will make the already
> complicated function prototype even more hard to comprehend accepting
> _eight_ arguments. In order to prevent that and keep the code
> more-or-less readable all the outbound iATU-related arguments are
> moved to the new config-structure: struct dw_pcie_ob_atu_cfg pointer
> to which shall be passed to dw_pcie_prog_outbound_atu(). The structure
> is supposed to be locally defined and populated with the outbound iATU
> settings implied by the caller context.
>
> As a result of the denoted change there is no longer need in having
> the two distinctive methods for the Host and End-point outbound iATU
> setups since the corresponding code can directly call the
> dw_pcie_prog_outbound_atu() method with the config-structure
> populated. Thus dw_pcie_prog_ep_outbound_atu() is dropped.
>
> Signed-off-by: Yoshihiro Shimoda <yoshihiro.shimoda.uh@renesas.com>
> Reviewed-by: Serge Semin <fancer.lancer@gmail.com>
> Reviewed-by: Manivannan Sadhasivam <manivannan.sadhasivam@linaro.org>
> Signed-off-by: Frank Li <Frank.Li@nxp.com>
> ...
next prev parent reply other threads:[~2024-01-31 15:41 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-01-31 0:45 [PATCH 0/6] PCI: dwc: Add common pme_turn_off message by using outbound iATU Frank Li
2024-01-31 0:45 ` [PATCH 1/6] PCI: Add INTx Mechanism Messages macros Frank Li
2024-01-31 15:37 ` Bjorn Helgaas
2024-02-01 17:53 ` Bjorn Helgaas
2024-01-31 0:45 ` [PATCH 2/6] PCI: dwc: Change arguments of dw_pcie_prog_outbound_atu() Frank Li
2024-01-31 15:41 ` Bjorn Helgaas [this message]
2024-01-31 15:56 ` Frank Li
2024-01-31 18:23 ` Bjorn Helgaas
2024-01-31 0:45 ` [PATCH 3/6] PCI: dwc: Add outbound MSG TLPs support Frank Li
2024-02-01 3:07 ` Yoshihiro Shimoda
2024-02-01 4:18 ` Frank Li
2024-01-31 0:45 ` [PATCH 4/6] PCI: Add PME_TURN_OFF message macro Frank Li
2024-01-31 0:45 ` [PATCH 5/6] dt-bindings: PCI: dwc: Add 'msg" register region Frank Li
2024-01-31 16:01 ` Bjorn Helgaas
2024-01-31 0:45 ` [PATCH 6/6] PCI: dwc: Add common send pme_turn_off message method Frank Li
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20240131154115.GA587326@bhelgaas \
--to=helgaas@kernel.org \
--cc=Frank.Li@nxp.com \
--cc=bhelgaas@google.com \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=fancer.lancer@gmail.com \
--cc=gustavo.pimentel@synopsys.com \
--cc=imx@lists.linux.dev \
--cc=jingoohan1@gmail.com \
--cc=krzysztof.kozlowski+dt@linaro.org \
--cc=kw@linux.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=lpieralisi@kernel.org \
--cc=manivannan.sadhasivam@linaro.org \
--cc=robh@kernel.org \
--cc=yoshihiro.shimoda.uh@renesas.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.