From: Conor Dooley <conor@kernel.org>
To: Guenter Roeck <linux@roeck-us.net>
Cc: Hardware Monitoring <linux-hwmon@vger.kernel.org>,
Naresh Solanki <naresh.solanki@9elements.com>,
Zev Weiss <zev@bewilderbeest.net>,
Patrick Rudolph <patrick.rudolph@9elements.com>
Subject: Re: [PATCH 0/3] hwmon: (pmbus) Use PMBUS_REGULATOR_ONE to declare regulators with single output
Date: Wed, 21 Feb 2024 19:06:53 +0000 [thread overview]
Message-ID: <20240221-founder-upward-3464de32031c@spud> (raw)
In-Reply-To: <b4265631-1835-4b9b-86a0-62b404cca5ae@roeck-us.net>
[-- Attachment #1: Type: text/plain, Size: 2251 bytes --]
On Mon, Feb 19, 2024 at 07:13:33AM -0800, Guenter Roeck wrote:
> On 2/19/24 06:48, Conor Dooley wrote:
> > On Sat, Feb 17, 2024 at 10:00:30PM +0000, Conor Dooley wrote:
> > > On Wed, Feb 14, 2024 at 11:43:39AM -0800, Guenter Roeck wrote:
> > > > If a chip only provides a single regulator, it should be named 'vout'
> > > > and not 'vout0'. Declare regulators for chips with a single ouput using
> > > > PMBUS_REGULATOR_ONE() to make that happen.
> > >
> > > If we're gonna do this, we should go ahead and document each of these
> > > regulators. If Naresh sends a v2 for the tda, I could do the others.
> >
> > As it turns out, the infineon devices in question are not PMICs, but
> > regulators themselves. I think something like the following is what we
> > need. Perhaps Zev or the 9elements guys can comment.
> >
> IMO The lm25066 patch should be separate.
It should already be a pair of changes - one for the infineon stuff and
another for the ti devices:
> > commit 9cf2671c0b98c0a0dd599fe9152985d1320bf320
> > Author: Conor Dooley <conor.dooley@microchip.com>
> > Date: Mon Feb 19 14:24:48 2024 +0000
> >
> > dt-bindings: regulator: promote infineon buck converters to their own binding
> > These devices may need to make use of the common regulator properties,
> > but these are not permitted while only documented in
> > trivial-devices.yaml
> > Signed-off-by: Conor Dooley <conor.dooley@microchip.com>
> > commit 597739840d2bc95ebb884d7f5fc4f3cc206d9af6
> > Author: Conor Dooley <conor.dooley@microchip.com>
> > Date: Mon Feb 19 13:29:12 2024 +0000
> >
> > dt-bindings: hwmon/pmbus: ti,lm25066: document regulators
> > All devices documented in the lm25066 binding are intended for use with
> > a regulator, be that for purely monitoring purposes (lm25056) or, for
> > the other devices, as the controller of that regulator. The binding does
> > not currently allow regulator child nodes, so add one.
> > Each of these devices interacts with only a single regulator and
> > documentation refers to it as "Vout", hence the choice of child node
> > name.
> > Signed-off-by: Conor Dooley <conor.dooley@microchip.com>
[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 228 bytes --]
next prev parent reply other threads:[~2024-02-21 19:06 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-02-14 19:43 [PATCH 0/3] hwmon: (pmbus) Use PMBUS_REGULATOR_ONE to declare regulators with single output Guenter Roeck
2024-02-14 19:43 ` [PATCH 1/3] hwmon: (pmbus/tda38640) Use PMBUS_REGULATOR_ONE to declare regulator Guenter Roeck
2024-02-14 19:43 ` [PATCH 2/3] hwmon: (pmbus/lm25066) " Guenter Roeck
2024-02-15 1:04 ` Zev Weiss
2024-02-15 1:22 ` Guenter Roeck
2024-02-15 10:14 ` Zev Weiss
2024-02-15 12:33 ` Conor Dooley
2024-02-14 19:43 ` [PATCH 3/3] hwmon: (pmbus/ir38064) " Guenter Roeck
2024-02-17 22:00 ` [PATCH 0/3] hwmon: (pmbus) Use PMBUS_REGULATOR_ONE to declare regulators with single output Conor Dooley
2024-02-19 14:48 ` Conor Dooley
2024-02-19 15:13 ` Guenter Roeck
2024-02-21 19:06 ` Conor Dooley [this message]
2024-02-22 1:10 ` Zev Weiss
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20240221-founder-upward-3464de32031c@spud \
--to=conor@kernel.org \
--cc=linux-hwmon@vger.kernel.org \
--cc=linux@roeck-us.net \
--cc=naresh.solanki@9elements.com \
--cc=patrick.rudolph@9elements.com \
--cc=zev@bewilderbeest.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.