All of lore.kernel.org
 help / color / mirror / Atom feed
From: Greg KH <gregkh@linuxfoundation.org>
To: Mukesh Ojha <quic_mojha@quicinc.com>
Cc: mcgrof@kernel.org, russ.weight@linux.dev, rafael@kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH vRFC 3/8] treewide: rename firmware_request_platform()
Date: Fri, 23 Feb 2024 07:21:31 +0100	[thread overview]
Message-ID: <2024022347-ribcage-clench-37c4@gregkh> (raw)
In-Reply-To: <20240222180033.23775-4-quic_mojha@quicinc.com>

On Thu, Feb 22, 2024 at 11:30:28PM +0530, Mukesh Ojha wrote:
> Rename firmware_request_platform() to request_firmware_platform()
> to be more concrete and align with the name of other request
> firmware family functions.

Sorry, but no, it should be "noun_verb" for public functions.

Yes, we mess this up a lot, but keeping the namespace this way works out
better for global symbols, so "firmware_*" is best please.

thanks,

greg k-h

  reply	other threads:[~2024-02-23  6:21 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-02-22 18:00 [PATCH vRFC 0/8] Refactor and rename request firmware API Mukesh Ojha
2024-02-22 18:00 ` [PATCH vRFC 1/8] firmware_loader: Refactor request firmware lower level functions Mukesh Ojha
2024-02-22 18:00 ` [PATCH vRFC 2/8] treewide: rename firmware_request_nowarn() Mukesh Ojha
2024-02-22 18:00 ` [PATCH vRFC 3/8] treewide: rename firmware_request_platform() Mukesh Ojha
2024-02-23  6:21   ` Greg KH [this message]
2024-02-23 15:15     ` Luis Chamberlain
2024-02-23 15:33       ` Greg KH
2024-02-23 19:42         ` Luis Chamberlain
2024-02-24  5:36           ` Greg KH
2024-02-26 10:52             ` Mukesh Ojha
2024-02-26 13:09               ` Greg KH
2024-02-26 13:22                 ` Mukesh Ojha
2024-02-26 16:06                   ` Luis Chamberlain
2024-02-22 18:00 ` [PATCH vRFC 4/8] treewide: rename firmware_request_cache() Mukesh Ojha
2024-02-22 18:00 ` [PATCH vRFC 5/8] firmware: Convert minor inline function to macro Mukesh Ojha
2024-02-23  6:22   ` Greg KH
2024-02-22 18:00 ` [PATCH vRFC 6/8] firmware: Move module template to the bottom Mukesh Ojha
2024-02-22 18:00 ` [PATCH vRFC 7/8] firmware: remove prototype of fw_cache_piggyback_on_request() Mukesh Ojha
2024-02-22 18:00 ` [PATCH vRFC 8/8] firmware: FW_OPT_UEVENT for all request_firmware family functions Mukesh Ojha

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2024022347-ribcage-clench-37c4@gregkh \
    --to=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mcgrof@kernel.org \
    --cc=quic_mojha@quicinc.com \
    --cc=rafael@kernel.org \
    --cc=russ.weight@linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.