From: Valentin Schneider <vschneid@redhat.com>
To: rcu@vger.kernel.org, linux-kernel@vger.kernel.org
Cc: Frederic Weisbecker <frederic@kernel.org>,
"Paul E. McKenney" <paulmck@kernel.org>,
Peter Zijlstra <peterz@infradead.org>,
Neeraj Upadhyay <quic_neeraju@quicinc.com>,
Joel Fernandes <joel@joelfernandes.org>,
Josh Triplett <josh@joshtriplett.org>,
Boqun Feng <boqun.feng@gmail.com>,
Steven Rostedt <rostedt@goodmis.org>,
Mathieu Desnoyers <mathieu.desnoyers@efficios.com>,
Lai Jiangshan <jiangshanlai@gmail.com>,
Zqiang <qiang.zhang1211@gmail.com>
Subject: [PATCH 0/2] context_tracking, rcu: Standardize naming related to contex_tracking.state
Date: Wed, 27 Mar 2024 12:29:00 +0100 [thread overview]
Message-ID: <20240327112902.1184822-1-vschneid@redhat.com> (raw)
Hi folks,
As I'm working on respinning [1] I'm trying to send standalone things
separately, and this is one of them.
No code change, just enum/const renaming, see [2].
[1]: https://lore.kernel.org/lkml/20230720163056.2564824-1-vschneid@redhat.com/
[2]: https://lore.kernel.org/lkml/ZL6QI4mV-NKlh4Ox@localhost.localdomain/#t
Cheers,
Valentin
Valentin Schneider (2):
treewide: context_tracking: Rename CONTEXT_FOO to CT_STATE_FOO
context_tracking, rcu: Rename RCU_DYNTICKS_IDX to CT_DYNTICKS_IDX
arch/Kconfig | 2 +-
arch/arm64/kernel/entry-common.c | 2 +-
arch/powerpc/include/asm/interrupt.h | 6 +++---
arch/powerpc/kernel/interrupt.c | 6 +++---
arch/powerpc/kernel/syscall.c | 2 +-
arch/x86/entry/common.c | 2 +-
include/linux/context_tracking.h | 22 +++++++++----------
include/linux/context_tracking_state.h | 20 ++++++++---------
include/linux/entry-common.h | 2 +-
kernel/context_tracking.c | 30 +++++++++++++-------------
kernel/entry/common.c | 2 +-
kernel/rcu/tree.c | 12 +++++------
kernel/sched/core.c | 4 ++--
13 files changed, 56 insertions(+), 56 deletions(-)
--
2.43.0
next reply other threads:[~2024-03-27 11:29 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-03-27 11:29 Valentin Schneider [this message]
2024-03-27 11:29 ` [PATCH 1/2] treewide: context_tracking: Rename CONTEXT_FOO to CT_STATE_FOO Valentin Schneider
2024-04-04 13:30 ` Frederic Weisbecker
2024-03-27 11:29 ` [PATCH 2/2] context_tracking, rcu: Rename RCU_DYNTICKS_IDX to CT_DYNTICKS_IDX Valentin Schneider
2024-04-04 13:38 ` Frederic Weisbecker
2024-04-09 19:53 ` Paul E. McKenney
2024-04-10 10:30 ` Frederic Weisbecker
2024-04-10 19:19 ` Paul E. McKenney
2024-04-15 16:36 ` Valentin Schneider
2024-04-15 21:08 ` Frederic Weisbecker
2024-04-16 8:36 ` Valentin Schneider
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20240327112902.1184822-1-vschneid@redhat.com \
--to=vschneid@redhat.com \
--cc=boqun.feng@gmail.com \
--cc=frederic@kernel.org \
--cc=jiangshanlai@gmail.com \
--cc=joel@joelfernandes.org \
--cc=josh@joshtriplett.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mathieu.desnoyers@efficios.com \
--cc=paulmck@kernel.org \
--cc=peterz@infradead.org \
--cc=qiang.zhang1211@gmail.com \
--cc=quic_neeraju@quicinc.com \
--cc=rcu@vger.kernel.org \
--cc=rostedt@goodmis.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.