All of lore.kernel.org
 help / color / mirror / Atom feed
From: Shahar Avidar <ikobh7@gmail.com>
To: gregkh@linuxfoundation.org, hverkuil-cisco@xs4all.nl,
	andriy.shevchenko@linux.intel.com, robh@kernel.org,
	felixkimbu1@gmail.com
Cc: linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: [PATCH v3 0/7] staging: pi433: Cleanup & fix potential resource leak.
Date: Fri,  5 Apr 2024 10:39:53 +0300	[thread overview]
Message-ID: <20240405074000.3481217-1-ikobh7@gmail.com> (raw)

This patchset improves readability, maintainability & fixes 1 bug:
        - Rename device related vars.
        - Update pi433_receive param type.
        - Remove duplicated code in pi433_init.
        - Reorder pi433_exit calls.
        - Fix a potential debugfs resource leak.

v2->v1:
Followed by Dan Carpenter's <dan.carpenter@linaro.org> comments:
        - Remove empty "fail" goto tag.
        - Reorder pi433 init & exit calls so they have reverse order.
        - Add "unreg_spi_drv" goto tag.
        - Check "debugfs_create_dir" return value.
        - Update "if" statements for consistency.
        - Rename pi433_init return var to the more common used "ret".
v2->v3:
Followed by more of Dan Carpenter's <dan.carpenter@linaro.org> comments:
        - Undo pi433 init calls reordering.
        - Remove "unreg_spi_drv" tag.
        - Undo return value check for "debugfs_create_dir".
        - Undo "if" statements update.
        - Undo pi433_init return var renaming.
        - Split patch 5 into 3: duplicate code removal, bug fix, reorder
          exit calls.


Shahar Avidar (7):
  staging: pi433: Rename struct pi433_device buffer field to tx_buffer.
  staging: pi433: Rename struct pi433_device instances to pi433.
  staging: pi433: Replace pi433_receive param void type to struct
    pi433_device.
  staging: pi433: Rename "pi433_dev" of type "dev_t" to "pi433_devt"
  staging: pi433: Remove duplicated code using the "goto" error recovery
    scheme.
  staging: pi433: Add debugfs_remove in case of driver register fails.
  staging: pi433: Reorder pi433_exit cleanup calls.

 drivers/staging/pi433/pi433_if.c | 690 +++++++++++++++----------------
 1 file changed, 345 insertions(+), 345 deletions(-)


base-commit: a103e5ad21992384b0b4332df52e0467107eb113
prerequisite-patch-id: 91943193af2fea74182be67fb583235a3fbeb77b
prerequisite-patch-id: 2cad031ba6a0782a67ab1645ff034a8be65c2e76
prerequisite-patch-id: 1a852ed8f9d133aec7c651fd9007e59e39c55fb7
-- 
2.34.1


             reply	other threads:[~2024-04-05  7:40 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-04-05  7:39 Shahar Avidar [this message]
2024-04-05  7:39 ` [PATCH v3 1/7] staging: pi433: Rename struct pi433_device buffer field to tx_buffer Shahar Avidar
2024-04-05  7:39 ` [PATCH v3 2/7] staging: pi433: Rename struct pi433_device instances to pi433 Shahar Avidar
2024-04-05  7:39 ` [PATCH v3 3/7] staging: pi433: Replace pi433_receive param void type to struct pi433_device Shahar Avidar
2024-04-05  7:39 ` [PATCH v3 4/7] staging: pi433: Rename "pi433_dev" of type "dev_t" to "pi433_devt" Shahar Avidar
2024-04-05  7:39 ` [PATCH v3 5/7] staging: pi433: Remove duplicated code using the "goto" error recovery scheme Shahar Avidar
2024-04-05 10:05   ` Markus Elfring
2024-04-05 10:09     ` Greg Kroah-Hartman
2024-04-05  7:39 ` [PATCH v3 6/7] staging: pi433: Add debugfs_remove in case of driver register fails Shahar Avidar
2024-04-05 10:42   ` Markus Elfring
2024-04-05 10:50     ` Greg Kroah-Hartman
2024-04-05  7:40 ` [PATCH v3 7/7] staging: pi433: Reorder pi433_exit cleanup calls Shahar Avidar
2024-04-05 10:34 ` [PATCH v3 0/7] staging: pi433: Cleanup & fix potential resource leak Dan Carpenter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20240405074000.3481217-1-ikobh7@gmail.com \
    --to=ikobh7@gmail.com \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=felixkimbu1@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hverkuil-cisco@xs4all.nl \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-staging@lists.linux.dev \
    --cc=robh@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.