All of lore.kernel.org
 help / color / mirror / Atom feed
From: Greg KH <gregkh@linuxfoundation.org>
To: vivek t s <vivek6429.ts@gmail.com>
Cc: linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] Staging: rtl8723bs: Rename function SelectChannel()
Date: Wed, 28 Aug 2024 11:38:18 +0200	[thread overview]
Message-ID: <2024082848-ice-unfixable-6a09@gregkh> (raw)
In-Reply-To: <Zs7vQXhcYRCxCDaH@victor-IdeaPad-Gaming-3-16IAH7>

On Wed, Aug 28, 2024 at 03:04:57PM +0530, vivek t s wrote:
> --- a/drivers/staging/rtl8723bs/include/rtw_mlme_ext.h
> +++ b/drivers/staging/rtl8723bs/include/rtw_mlme_ext.h
> @@ -455,7 +455,7 @@ u8 rtw_get_center_ch(u8 channel, u8 chnl_bw, u8 chnl_offset);
>  unsigned long rtw_get_on_cur_ch_time(struct adapter *adapter);
>  
>  void set_channel_bwmode(struct adapter *padapter, unsigned char channel, unsigned char channel_offset, unsigned short bwmode);
> -void SelectChannel(struct adapter *padapter, unsigned char channel);
> +void select_channel(struct adapter *padapter, unsigned char channel);

This is a pretty horrible name for a symbol in the global namespace, can
you rename it to be more sane for this driver (i.e. put a prefix on it?)

thanks,

greg k-h

  reply	other threads:[~2024-08-28  9:38 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-08-28  9:34 [PATCH] Staging: rtl8723bs: Rename function SelectChannel() vivek t s
2024-08-28  9:38 ` Greg KH [this message]
2024-08-28 10:01   ` YOUR NAME
2024-08-28 10:25 ` Dan Carpenter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2024082848-ice-unfixable-6a09@gregkh \
    --to=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-staging@lists.linux.dev \
    --cc=vivek6429.ts@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.