All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Darrick J. Wong" <djwong@kernel.org>
To: Christoph Hellwig <hch@infradead.org>
Cc: cem@kernel.org, aalbersh@kernel.org, linux-xfs@vger.kernel.org
Subject: Re: [PATCH 6/8] xfs_db: enable conversion of rt space units
Date: Mon, 28 Oct 2024 10:58:22 -0700	[thread overview]
Message-ID: <20241028175822.GS2386201@frogsfrogsfrogs> (raw)
In-Reply-To: <Zx9OQo1uhTgy-UIP@infradead.org>

On Mon, Oct 28, 2024 at 01:41:38AM -0700, Christoph Hellwig wrote:
> > +	[CT_AGBLOCK] = {
> > +		.allowed = M(AGNUMBER)|M(BBOFF)|M(BLKOFF)|M(INOIDX)|M(INOOFF),
> 
> Can you space these out with whitespaces around the operators?
> 
> > +		.allowed = M(AGBLOCK)|M(AGINO)|M(BBOFF)|M(BLKOFF)|M(INOIDX)|M(INOOFF),
> 
> And break up the overly long lines?  In fact I wonder if just having
> each M() on it's own line might be even nicer for readability.

That does look a lot better:

	[CT_AGBLOCK] = {
		.allowed = M(AGNUMBER) |
			   M(BBOFF) |
			   M(BLKOFF) |
			   M(INOIDX) |
			   M(INOOFF),
		.names   = agblock_names,
	},

> > +static inline xfs_rtblock_t
> > +xfs_daddr_to_rtb(
> > +	struct xfs_mount	*mp,
> > +	xfs_daddr_t		daddr)
> > +{
> > +	return daddr >> mp->m_blkbb_log;
> > +}
> 
> We already have this in xfs_rtgroup.h in the latest tree, but
> I guess that comes later?

Yeah, that won't show up until we start working on 6.13, or whenever
metadir goes in.

(Also I changed my mind on naming and decided to use "xfs_" on the
db/block.h helpers that I mentioned in the previous two replies to
reduce churn downwind.)

--D

> >  Set current address to SB header in allocation group
> >  .IR agno .
> > 
> > 
> ---end quoted text---
> 

  reply	other threads:[~2024-10-28 17:58 UTC|newest]

Thread overview: 57+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-10-25  6:26 [PATCHBOMB] xfsprogs: utility changes for 6.12 Darrick J. Wong
2024-10-25  6:31 ` Darrick J. Wong
2024-10-25  6:31 ` [PATCHSET v31.2 1/5] xfsprogs: atomic file content commits Darrick J. Wong
2024-10-25  6:32   ` [PATCH 1/7] man: document file range commit ioctls Darrick J. Wong
2024-10-28  8:31     ` Christoph Hellwig
2024-10-25  6:32   ` [PATCH 2/7] libfrog: add support for commit range ioctl family Darrick J. Wong
2024-10-28  8:32     ` Christoph Hellwig
2024-10-25  6:33   ` [PATCH 3/7] libxfs: remove unused xfs_inode fields Darrick J. Wong
2024-10-28  8:32     ` Christoph Hellwig
2024-10-25  6:33   ` [PATCH 4/7] libxfs: validate inumber in xfs_iget Darrick J. Wong
2024-10-28  8:32     ` Christoph Hellwig
2024-10-25  6:33   ` [PATCH 5/7] xfs_fsr: port to new file exchange library function Darrick J. Wong
2024-10-28  8:33     ` Christoph Hellwig
2024-10-25  6:34   ` [PATCH 6/7] xfs_io: add a commitrange option to the exchangerange command Darrick J. Wong
2024-10-28  8:33     ` Christoph Hellwig
2024-10-25  6:34   ` [PATCH 7/7] xfs_io: add atomic file update commands to exercise file commit range Darrick J. Wong
2024-10-28  8:33     ` Christoph Hellwig
2024-10-25  6:31 ` [PATCHSET v2.6 2/5] xfs_db: debug realtime geometry Darrick J. Wong
2024-10-25  6:34   ` [PATCH 1/8] xfs_db: support passing the realtime device to the debugger Darrick J. Wong
2024-10-28  8:34     ` Christoph Hellwig
2024-10-25  6:34   ` [PATCH 2/8] xfs_db: report the realtime device when associated with each io cursor Darrick J. Wong
2024-10-28  8:34     ` Christoph Hellwig
2024-10-25  6:35   ` [PATCH 3/8] xfs_db: make the daddr command target the realtime device Darrick J. Wong
2024-10-28  8:35     ` Christoph Hellwig
2024-10-25  6:35   ` [PATCH 4/8] xfs_db: access realtime file blocks Darrick J. Wong
2024-10-28  8:37     ` Christoph Hellwig
2024-10-28 17:50       ` Darrick J. Wong
2024-10-25  6:35   ` [PATCH 5/8] xfs_db: access arbitrary realtime blocks and extents Darrick J. Wong
2024-10-28  8:38     ` Christoph Hellwig
2024-10-28 17:51       ` Darrick J. Wong
2024-10-25  6:35   ` [PATCH 6/8] xfs_db: enable conversion of rt space units Darrick J. Wong
2024-10-28  8:41     ` Christoph Hellwig
2024-10-28 17:58       ` Darrick J. Wong [this message]
2024-10-25  6:36   ` [PATCH 7/8] xfs_db: convert rtbitmap geometry Darrick J. Wong
2024-10-28  8:42     ` Christoph Hellwig
2024-10-25  6:36   ` [PATCH 8/8] xfs_db: convert rtsummary geometry Darrick J. Wong
2024-10-28  8:42     ` Christoph Hellwig
2024-10-25  6:31 ` [PATCHSET v2.6 3/5] xfs_metadump: support external devices Darrick J. Wong
2024-10-25  6:36   ` [PATCH 1/1] xfs_db: allow setting current address to log blocks Darrick J. Wong
2024-10-28  8:43     ` Christoph Hellwig
2024-10-25  6:32 ` [PATCHSET v2.6 4/5] mkfs/repair: use new rtbitmap helpers Darrick J. Wong
2024-10-25  6:36   ` [PATCH 1/6] xfs_repair: checking rt free space metadata must happen during phase 4 Darrick J. Wong
2024-10-28  8:43     ` Christoph Hellwig
2024-10-25  6:37   ` [PATCH 2/6] xfs_repair: use xfs_validate_rt_geometry Darrick J. Wong
2024-10-25  6:37   ` [PATCH 3/6] mkfs: remove a pointless rtfreesp_init forward declaration Darrick J. Wong
2024-10-25  6:37   ` [PATCH 4/6] mkfs: use xfs_rtfile_initialize_blocks Darrick J. Wong
2024-10-25  6:37   ` [PATCH 5/6] xfs_repair: use libxfs_rtfile_initialize_blocks Darrick J. Wong
2024-10-25  6:38   ` [PATCH 6/6] xfs_repair: stop preallocating blocks in mk_rbmino and mk_rsumino Darrick J. Wong
2024-10-25  6:32 ` [PATCHSET v31.2 5/5] xfs_scrub_all: bug fix for 6.12 Darrick J. Wong
2024-10-25  6:38   ` [PATCH 1/1] xfs_scrub_all: wait for services to start activating Darrick J. Wong
2024-10-28  8:44     ` Christoph Hellwig
2024-10-28 16:45       ` Darrick J. Wong
  -- strict thread matches above, loose matches on Subject: below --
2024-10-31 23:07 [PATCHSET v5.3 3/7] xfs_db: debug realtime geometry Darrick J. Wong
2024-10-31 23:22 ` [PATCH 6/8] xfs_db: enable conversion of rt space units Darrick J. Wong
2024-10-29 15:47 [PATCHSET v5.2 1/2] xfs_db: debug realtime geometry Darrick J. Wong
2024-10-29 15:49 ` [PATCH 6/8] xfs_db: enable conversion of rt space units Darrick J. Wong
2024-10-30  4:35   ` Christoph Hellwig
2023-12-31 19:52 [PATCHSET v2.0 03/17] xfs_db: debug realtime geometry Darrick J. Wong
2023-12-31 23:46 ` [PATCH 6/8] xfs_db: enable conversion of rt space units Darrick J. Wong
2022-12-30 22:19 [PATCHSET v1.0 0/8] xfs_db: debug realtime geometry Darrick J. Wong
2022-12-30 22:19 ` [PATCH 6/8] xfs_db: enable conversion of rt space units Darrick J. Wong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20241028175822.GS2386201@frogsfrogsfrogs \
    --to=djwong@kernel.org \
    --cc=aalbersh@kernel.org \
    --cc=cem@kernel.org \
    --cc=hch@infradead.org \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.