From: Mirsad Todorovac <mtodorovac69@gmail.com>
To: Andrew Morton <akpm@linux-foundation.org>,
Suren Baghdasaryan <surenb@google.com>,
Mirsad Todorovac <mtodorovac69@gmail.com>,
linux-mm@kvack.org, linux-kselftest@vger.kernel.org,
linux-kernel@vger.kernel.org
Cc: Shuah Khan <shuah@kernel.org>,
Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
Dave Hansen <dave.hansen@linux.intel.com>,
x86@kernel.org, "H. Peter Anvin" <hpa@zytor.com>,
Peter Xu <peterx@redhat.com>
Subject: [PATCH v1 2/2] selftests/mm: fix coccinelle WARNING recommending the use of ARRAY_SIZE()
Date: Fri, 1 Nov 2024 12:15:25 +0100 [thread overview]
Message-ID: <20241101111523.1293193-4-mtodorovac69@gmail.com> (raw)
In-Reply-To: <20241101111523.1293193-2-mtodorovac69@gmail.com>
Coccinelle gives WARNING recommending the use of ARRAY_SIZE() macro definition
to improve the code readability:
./tools/testing/selftests/mm/uffd-unit-tests.c:1484:32-33: WARNING: Use ARRAY_SIZE
./tools/testing/selftests/mm/uffd-unit-tests.c:1485:30-31: WARNING: Use ARRAY_SIZE
Fixes: 16a45b57cbf2 ("selftests/mm: add framework for uffd-unit-test")
Cc: Andrew Morton <akpm@linux-foundation.org>
Cc: Shuah Khan <shuah@kernel.org>
Cc: Peter Xu <peterx@redhat.com>
Cc: linux-mm@kvack.org
Cc: linux-kselftest@vger.kernel.org
Cc: linux-kernel@vger.kernel.org
Signed-off-by: Mirsad Todorovac <mtodorovac69@gmail.com>
---
v1: initial version.
tools/testing/selftests/mm/uffd-unit-tests.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/tools/testing/selftests/mm/uffd-unit-tests.c b/tools/testing/selftests/mm/uffd-unit-tests.c
index a2e71b1636e7..4f6a7440a9aa 100644
--- a/tools/testing/selftests/mm/uffd-unit-tests.c
+++ b/tools/testing/selftests/mm/uffd-unit-tests.c
@@ -1481,8 +1481,8 @@ static void usage(const char *prog)
int main(int argc, char *argv[])
{
- int n_tests = sizeof(uffd_tests) / sizeof(uffd_test_case_t);
- int n_mems = sizeof(mem_types) / sizeof(mem_type_t);
+ int n_tests = ARRAY_SIZE(uffd_tests);
+ int n_mems = ARRAY_SIZE(mem_types);
const char *test_filter = NULL;
bool list_only = false;
uffd_test_case_t *test;
--
2.43.0
next prev parent reply other threads:[~2024-11-01 11:17 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-11-01 11:15 [PATCH v1 1/2] selftests/x86/syscall: fix coccinelle WARNING recommending the use of ARRAY_SIZE() Mirsad Todorovac
2024-11-01 11:15 ` Mirsad Todorovac [this message]
2024-11-01 13:48 ` [PATCH v1 2/2] selftests/mm: " Peter Xu
2024-11-02 18:53 ` Mirsad Todorovac
2024-11-01 12:04 ` [PATCH v1 1/2] selftests/x86/syscall: " Muhammad Usama Anjum
2024-11-02 18:55 ` Mirsad Todorovac
2025-03-03 11:51 ` [tip: x86/cleanups] selftests/x86/syscall: Fix " tip-bot2 for Mirsad Todorovac
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20241101111523.1293193-4-mtodorovac69@gmail.com \
--to=mtodorovac69@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=bp@alien8.de \
--cc=dave.hansen@linux.intel.com \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=mingo@redhat.com \
--cc=peterx@redhat.com \
--cc=shuah@kernel.org \
--cc=surenb@google.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.