All of lore.kernel.org
 help / color / mirror / Atom feed
From: Greg KH <gregkh@linuxfoundation.org>
To: Ekansh Gupta <quic_ekangupt@quicinc.com>
Cc: srinivas.kandagatla@linaro.org, linux-arm-msm@vger.kernel.org,
	quic_bkumar@quicinc.com, linux-kernel@vger.kernel.org,
	quic_chennak@quicinc.com, dri-devel@lists.freedesktop.org,
	arnd@arndb.de
Subject: Re: [PATCH v1 3/4] misc: fastrpc: Introduce fastrpc_shared.h header
Date: Mon, 18 Nov 2024 14:58:51 +0100	[thread overview]
Message-ID: <2024111832-sprinkled-boastful-8fba@gregkh> (raw)
In-Reply-To: <20241118084046.3201290-4-quic_ekangupt@quicinc.com>

On Mon, Nov 18, 2024 at 02:10:45PM +0530, Ekansh Gupta wrote:
> Move fastrpc structures and MACRO definitions to a new header file.
> These definitions are consumed by other upcoming features like
> debugfs, PDR support etc.
> 
> Signed-off-by: Ekansh Gupta <quic_ekangupt@quicinc.com>
> ---
>  drivers/misc/fastrpc/fastrpc_main.c   | 136 +---------------------
>  drivers/misc/fastrpc/fastrpc_shared.h | 155 ++++++++++++++++++++++++++

Again, why not just "fastrpc.h"?  No need for the huge prefix here,
right?

thanks,

greg k-h

  reply	other threads:[~2024-11-18 13:59 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-11-18  8:40 [PATCH v1 0/4] Add debugfs support for fastrpc driver Ekansh Gupta
2024-11-18  8:40 ` [PATCH v1 1/4] misc: fastrpc: Move fastrpc driver to misc/fastrpc/ Ekansh Gupta
2024-11-18  8:40 ` [PATCH v1 2/4] misc: fastrpc: Rename fastrpc.c to fastrpc_main.c Ekansh Gupta
2024-11-18 13:58   ` Greg KH
2024-11-21  6:24     ` Ekansh Gupta
2024-11-18  8:40 ` [PATCH v1 3/4] misc: fastrpc: Introduce fastrpc_shared.h header Ekansh Gupta
2024-11-18 13:58   ` Greg KH [this message]
2024-11-21  6:29     ` Ekansh Gupta
2024-11-18  8:40 ` [PATCH v1 4/4] misc: fastrpc: Add debugfs support for fastrpc Ekansh Gupta
2024-11-18 14:02   ` Greg KH
2024-11-21  6:42     ` Ekansh Gupta
2024-11-21 13:30       ` Greg KH
2024-11-21 18:53       ` Dmitry Baryshkov
2024-12-02  9:57         ` Ekansh Gupta
2024-12-02 12:48           ` Dmitry Baryshkov
2024-12-03  5:21             ` Ekansh Gupta
2024-12-03 11:57               ` Dmitry Baryshkov
2025-04-11  8:25                 ` Ekansh Gupta
2025-04-14  7:11                   ` Deepika Singh
2025-04-14  7:48                     ` Dmitry Baryshkov
2025-04-14  7:56                       ` Dmitry Baryshkov
2025-04-21  6:11                       ` Deepika Singh
2025-04-21  8:14                         ` Dmitry Baryshkov
2025-04-15 13:17                     ` Greg KH
2025-04-21  8:21                       ` Deepika Singh
2025-04-21  8:49                         ` Greg KH
2025-04-14  7:44                   ` Dmitry Baryshkov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2024111832-sprinkled-boastful-8fba@gregkh \
    --to=gregkh@linuxfoundation.org \
    --cc=arnd@arndb.de \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=quic_bkumar@quicinc.com \
    --cc=quic_chennak@quicinc.com \
    --cc=quic_ekangupt@quicinc.com \
    --cc=srinivas.kandagatla@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.