From: Jonathan Cameron <jic23@kernel.org>
To: Claudiu <claudiu.beznea@tuxon.dev>
Cc: prabhakar.mahadev-lad.rj@bp.renesas.com, lars@metafoo.de,
robh@kernel.org, krzk+dt@kernel.org, conor+dt@kernel.org,
geert+renesas@glider.be, magnus.damm@gmail.com,
mturquette@baylibre.com, sboyd@kernel.org,
p.zabel@pengutronix.de, linux-iio@vger.kernel.org,
linux-renesas-soc@vger.kernel.org, devicetree@vger.kernel.org,
linux-kernel@vger.kernel.org, linux-clk@vger.kernel.org,
Claudiu Beznea <claudiu.beznea.uj@bp.renesas.com>
Subject: Re: [PATCH v2 02/15] iio: adc: rzg2l_adc: Convert dev_err() to dev_err_probe()
Date: Sat, 7 Dec 2024 18:10:58 +0000 [thread overview]
Message-ID: <20241207181058.3df9c7a0@jic23-huawei> (raw)
In-Reply-To: <20241206111337.726244-3-claudiu.beznea.uj@bp.renesas.com>
On Fri, 6 Dec 2024 13:13:24 +0200
Claudiu <claudiu.beznea@tuxon.dev> wrote:
> From: Claudiu Beznea <claudiu.beznea.uj@bp.renesas.com>
>
> Convert all occurrences of dev_err() in the probe path to dev_err_probe().
> This improves readability and simplifies the code.
>
> Signed-off-by: Claudiu Beznea <claudiu.beznea.uj@bp.renesas.com>
Hi Claudiu,
> + if (IS_ERR(adc->presetn))
> + return dev_err_probe(dev, PTR_ERR(adc->presetn), "failed to get presetn\n");
>
> ret = reset_control_deassert(adc->adrstn);
> - if (ret) {
> - dev_err(&pdev->dev, "failed to deassert adrstn pin, %d\n", ret);
> - return ret;
> - }
> + if (ret)
> + return dev_err_probe(&pdev->dev, ret, "failed to deassert adrstn pin, %d\n", ret);
Take a closer look at the implementation of dev_err_probe().
It already prints the return code (where appropriate) and in a pretty text form
which is easier to read. So we should not print it again.
I'd also prefer wrapping some of the longer lines in here a little earlier. For IIO
I still prefer to stay under 80 chars or only a little over it where it doesn't
hurt readability.
Jonathan
next prev parent reply other threads:[~2024-12-07 18:11 UTC|newest]
Thread overview: 36+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-12-06 11:13 [PATCH v2 00/15] iio: adc: rzg2l_adc: Add support for RZ/G3S Claudiu
2024-12-06 11:13 ` [PATCH v2 01/15] clk: renesas: r9a08g045: Add clocks, resets and power domain support for the ADC IP Claudiu
2024-12-06 13:54 ` Geert Uytterhoeven
2024-12-08 19:42 ` Lad, Prabhakar
2024-12-06 11:13 ` [PATCH v2 02/15] iio: adc: rzg2l_adc: Convert dev_err() to dev_err_probe() Claudiu
2024-12-07 18:10 ` Jonathan Cameron [this message]
2024-12-08 19:43 ` Lad, Prabhakar
2024-12-06 11:13 ` [PATCH v2 03/15] iio: adc: rzg2l_adc: Use devres helpers to request pre-deasserted reset controls Claudiu
2024-12-07 18:23 ` Jonathan Cameron
2024-12-08 19:44 ` Lad, Prabhakar
2024-12-06 11:13 ` [PATCH v2 04/15] iio: adc: rzg2l_adc: Simplify the runtime PM code Claudiu
2024-12-08 20:23 ` Lad, Prabhakar
2024-12-06 11:13 ` [PATCH v2 05/15] iio: adc: rzg2l_adc: Switch to RUNTIME_PM_OPS() and pm_ptr() Claudiu
2024-12-08 20:32 ` Lad, Prabhakar
2024-12-06 11:13 ` [PATCH v2 06/15] iio: adc: rzg2l_adc: Use read_poll_timeout() Claudiu
2024-12-08 20:53 ` Lad, Prabhakar
2024-12-06 11:13 ` [PATCH v2 07/15] iio: adc: rzg2l_adc: Simplify the locking scheme in rzg2l_adc_read_raw() Claudiu
2024-12-08 20:58 ` Lad, Prabhakar
2024-12-06 11:13 ` [PATCH v2 08/15] iio: adc: rzg2l_adc: Enable runtime PM autosuspend support Claudiu
2024-12-08 21:00 ` Lad, Prabhakar
2024-12-06 11:13 ` [PATCH v2 09/15] iio: adc: rzg2l_adc: Prepare for the addition of RZ/G3S support Claudiu
2024-12-08 21:06 ` Lad, Prabhakar
2024-12-06 11:13 ` [PATCH v2 10/15] iio: adc: rzg2l_adc: Add support for channel 8 Claudiu
2024-12-08 21:19 ` Lad, Prabhakar
2024-12-06 11:13 ` [PATCH v2 11/15] iio: adc: rzg2l_adc: Add suspend/resume support Claudiu
2024-12-08 21:35 ` Lad, Prabhakar
2024-12-11 19:19 ` Jonathan Cameron
2024-12-06 11:13 ` [PATCH v2 12/15] dt-bindings: iio: adc: renesas,rzg2l-adc: Document RZ/G3S SoC Claudiu
2024-12-06 11:13 ` [PATCH v2 13/15] iio: adc: rzg2l_adc: Add support for Renesas RZ/G3S Claudiu
2024-12-07 18:34 ` Jonathan Cameron
2024-12-09 8:51 ` Claudiu Beznea
2024-12-06 11:13 ` [PATCH v2 14/15] arm64: dts: renesas: r9a08g045: Add ADC node Claudiu
2024-12-11 13:27 ` Geert Uytterhoeven
2024-12-11 13:53 ` Claudiu Beznea
2024-12-06 11:13 ` [PATCH v2 15/15] arm64: dts: renesas: rzg3s-smarc-som: Enable ADC Claudiu
2024-12-11 13:32 ` Geert Uytterhoeven
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20241207181058.3df9c7a0@jic23-huawei \
--to=jic23@kernel.org \
--cc=claudiu.beznea.uj@bp.renesas.com \
--cc=claudiu.beznea@tuxon.dev \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=geert+renesas@glider.be \
--cc=krzk+dt@kernel.org \
--cc=lars@metafoo.de \
--cc=linux-clk@vger.kernel.org \
--cc=linux-iio@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-renesas-soc@vger.kernel.org \
--cc=magnus.damm@gmail.com \
--cc=mturquette@baylibre.com \
--cc=p.zabel@pengutronix.de \
--cc=prabhakar.mahadev-lad.rj@bp.renesas.com \
--cc=robh@kernel.org \
--cc=sboyd@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.