From: Tom Rini <trini@konsulko.com>
To: Simon Glass <sjg@chromium.org>
Cc: "Heinrich Schuchardt" <xypron.glpk@gmx.de>,
"Ilias Apalodimas" <ilias.apalodimas@linaro.org>,
"AKASHI Takahiro" <akashi.tkhro@gmail.com>,
"Janne Grunau" <j@jannau.net>,
"Moritz Fischer" <moritzf@google.com>,
"Sughosh Ganu" <sughosh.ganu@linaro.org>,
"Vincent Stehlé" <vincent.stehle@arm.com>,
"U-Boot Mailing List" <u-boot@lists.denx.de>
Subject: Re: [PATCH v4 09/25] efi_loader: Use the enum for memory type
Date: Tue, 10 Dec 2024 11:13:08 -0600 [thread overview]
Message-ID: <20241210171308.GE2457179@bill-the-cat> (raw)
In-Reply-To: <CAFLszTi88v1BFXLJCpp8UbnV_JO3Hg4Bx5CtWxEZ42__oVCFFA@mail.gmail.com>
[-- Attachment #1: Type: text/plain, Size: 1548 bytes --]
On Tue, Dec 10, 2024 at 09:17:43AM -0700, Simon Glass wrote:
> Hi Heinrich,
>
> On Tue, 3 Dec 2024 at 08:53, Simon Glass <sjg@chromium.org> wrote:
> >
> > Hi Heinrich,
> >
> > On Tue, 3 Dec 2024 at 07:38, Heinrich Schuchardt <xypron.glpk@gmx.de> wrote:
> > >
> > > On 01.12.24 16:24, Simon Glass wrote:
> > > > Rather than an integer, it is better to use the enum provided, when
> > > > referring to an EFI memory-type. Update existing uses.
> > > >
> > > > Call the value 'mem_type' consistently. Fix up one instance of
> > > > upper-case hex.
> > > >
> > > > Fix up the calls in struct efi_boot_services so that they use the same
> > > > enum, adding the missing parameter names and enum efi_allocate_type.
> > > >
> > > > While we are here, rename the 'memory' parameter to 'memoryp' so that it
> > > > is clear it is a return value.
> > > >
> > > > Signed-off-by: Simon Glass <sjg@chromium.org>
> > >
> > > Simon, I have no clue why you keep ignoring reviews.
> > > This is just annoying and won't lead to merging patches.
> >
> > I got your feedback on [1] and incorporated it in v2 onwards. Did you notice?
> >
> > >
> > > NAK
>
> It has been a week and I have not had any response on this. Does that
> mean you are OK with the patch now?
I'm unclear what part of NAK implies that Heinrich is OK with this
patch? I believe not since part of it was to not rename "memory" to
"memoryp" and you're calling out doing that still. But I suspect you'll
just keep this in your fork all the same.
--
Tom
[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 659 bytes --]
next prev parent reply other threads:[~2024-12-10 17:13 UTC|newest]
Thread overview: 48+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-12-01 15:24 [PATCH v4 00/25] efi: Tidy up confusion between pointers and addresses Simon Glass
2024-12-01 15:24 ` [PATCH v4 01/25] efi: Define fields in struct efi_mem_desc Simon Glass
2024-12-01 15:24 ` [PATCH v4 02/25] efi_loader: Fix typos in enum efi_allocate_type Simon Glass
2024-12-02 20:17 ` Tom Rini
2024-12-01 15:24 ` [PATCH v4 03/25] efi_loader: Drop extra brackets in efi_mem_carve_out() Simon Glass
2024-12-02 20:16 ` Tom Rini
2024-12-03 0:24 ` Simon Glass
2024-12-03 0:37 ` Tom Rini
2024-12-03 13:46 ` Simon Glass
2024-12-03 14:04 ` Tom Rini
2024-12-03 15:53 ` Simon Glass
2024-12-03 16:02 ` Tom Rini
2024-12-03 19:45 ` Simon Glass
2024-12-01 15:24 ` [PATCH v4 04/25] efi_loader: Add comments where incorrect addresses are used Simon Glass
2024-12-02 20:18 ` Tom Rini
2024-12-03 0:22 ` Simon Glass
2024-12-03 0:38 ` Tom Rini
2024-12-03 8:48 ` Ilias Apalodimas
2024-12-03 13:45 ` Simon Glass
2024-12-03 14:09 ` Tom Rini
2024-12-03 15:55 ` Simon Glass
2024-12-01 15:24 ` [PATCH v4 05/25] efi_loader: Show the resulting memory address from an alloc Simon Glass
2024-12-01 15:24 ` [PATCH v4 06/25] efi_loader: Update startimage_exit self-test to check error Simon Glass
2024-12-01 15:24 ` [PATCH v4 07/25] efi_loader: Move some memory-function comments to header Simon Glass
2024-12-01 15:24 ` [PATCH v4 08/25] doc: efi: Add the EFI-loader API documentation Simon Glass
2024-12-01 15:24 ` [PATCH v4 09/25] efi_loader: Use the enum for memory type Simon Glass
2024-12-03 14:32 ` Heinrich Schuchardt
2024-12-03 15:53 ` Simon Glass
2024-12-10 16:17 ` Simon Glass
2024-12-10 17:13 ` Tom Rini [this message]
2024-12-01 15:24 ` [PATCH v4 10/25] efi_loader: Use a separate struct for memory nodes Simon Glass
2024-12-01 15:24 ` [PATCH v4 11/25] efi_loader: Drop virtual_start from priv_mem_desc Simon Glass
2024-12-01 15:24 ` [PATCH v4 12/25] efi_loader: Drop reserved " Simon Glass
2024-12-01 15:24 ` [PATCH v4 13/25] efi_loader: Use the enum for the memory type in priv_mem_desc Simon Glass
2024-12-01 15:24 ` [PATCH v4 14/25] efi_loader: Avoid assigning desc in efi_mem_carve_out() Simon Glass
2024-12-01 15:24 ` [PATCH v4 15/25] efi_loader: Move struct efi_mem_list fields together Simon Glass
2024-12-01 15:24 ` [PATCH v4 16/25] efi_loader: Rename struct efi_mem_list to mem_node Simon Glass
2024-12-01 15:24 ` [PATCH v4 17/25] efi_loader: Rename physical_start to base Simon Glass
2024-12-01 15:24 ` [PATCH v4 18/25] efi_loader: Use correct type in efi_add_runtime_mmio() Simon Glass
2024-12-01 15:24 ` [PATCH v4 19/25] efi_loader: Show the address for pool allocations Simon Glass
2024-12-01 15:24 ` [PATCH v4 20/25] efi_loader: Don't try to add sandbox runtime code Simon Glass
2024-12-01 15:24 ` [PATCH v4 21/25] efi_loader: Update to use addresses internally Simon Glass
2024-12-01 15:24 ` [PATCH v4 22/25] efi_loader: Correct address-usage in copy_fdt() Simon Glass
2024-12-01 15:24 ` [PATCH v4 23/25] efi_loader: Drop comments about incorrect addresses Simon Glass
2024-12-01 15:24 ` [PATCH v4 24/25] efi_bootmgr: Avoid casts in try_load_from_uri_path() Simon Glass
2024-12-01 15:24 ` [PATCH v4 25/25] efi_loader: Simplify efi_dp_from_mem() Simon Glass
2024-12-04 14:46 ` [PATCH v4 00/25] efi: Tidy up confusion between pointers and addresses Ilias Apalodimas
2024-12-04 15:13 ` Simon Glass
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20241210171308.GE2457179@bill-the-cat \
--to=trini@konsulko.com \
--cc=akashi.tkhro@gmail.com \
--cc=ilias.apalodimas@linaro.org \
--cc=j@jannau.net \
--cc=moritzf@google.com \
--cc=sjg@chromium.org \
--cc=sughosh.ganu@linaro.org \
--cc=u-boot@lists.denx.de \
--cc=vincent.stehle@arm.com \
--cc=xypron.glpk@gmx.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.