All of lore.kernel.org
 help / color / mirror / Atom feed
From: Sakari Ailus <sakari.ailus@linux.intel.com>
To: "Daniel Scally" <djrscally@gmail.com>,
	"Hans de Goede" <hdegoede@redhat.com>,
	"Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>
Cc: platform-driver-x86@vger.kernel.org,
	Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	laurent.pinchart@ideasonboard.com, hverkuil@xs4all.nl,
	linux-media@vger.kernel.org
Subject: [PATCH v5 0/3] int3472: Support GPIO con_id based on _HID
Date: Fri, 31 Jan 2025 14:01:49 +0200	[thread overview]
Message-ID: <20250131120152.1109476-1-sakari.ailus@linux.intel.com> (raw)

Hi folks,

One patch turned into a set, the second patch being the original one.

since v4:

- Split the newly added if () clause into two for better readability in
  int3472_get_func_and_polarity().

Sakari Ailus (3):
  platform/x86: int3472: Use correct type for "polarity", call it
    gpio_flags
  platform/x86: int3472: Call "reset" GPIO "enable" for INT347E
  platform/x86: int3472: Call "func" "con_id" instead

 drivers/platform/x86/intel/int3472/discrete.c | 100 ++++++++++++------
 1 file changed, 70 insertions(+), 30 deletions(-)

-- 
2.39.5


             reply	other threads:[~2025-01-31 12:01 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-01-31 12:01 Sakari Ailus [this message]
2025-01-31 12:01 ` [PATCH v5 1/3] platform/x86: int3472: Use correct type for "polarity", call it gpio_flags Sakari Ailus
2025-01-31 12:01 ` [PATCH v5 2/3] platform/x86: int3472: Call "reset" GPIO "enable" for INT347E Sakari Ailus
2025-01-31 17:18   ` Andy Shevchenko
2025-02-03  7:42     ` Sakari Ailus
2025-02-03  8:52       ` Andy Shevchenko
2025-02-03  8:03   ` Ilpo Järvinen
2025-02-03  8:20     ` Sakari Ailus
2025-02-03  8:26       ` Ilpo Järvinen
2025-01-31 12:01 ` [PATCH v5 3/3] platform/x86: int3472: Call "func" "con_id" instead Sakari Ailus

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250131120152.1109476-1-sakari.ailus@linux.intel.com \
    --to=sakari.ailus@linux.intel.com \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=djrscally@gmail.com \
    --cc=hdegoede@redhat.com \
    --cc=hverkuil@xs4all.nl \
    --cc=ilpo.jarvinen@linux.intel.com \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=linux-media@vger.kernel.org \
    --cc=platform-driver-x86@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.