All of lore.kernel.org
 help / color / mirror / Atom feed
From: Maxime Ripard <mripard@kernel.org>
To: Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
	 Thomas Zimmermann <tzimmermann@suse.de>,
	David Airlie <airlied@gmail.com>,
	 Simona Vetter <simona@ffwll.ch>,
	Andrzej Hajda <andrzej.hajda@intel.com>,
	 Neil Armstrong <neil.armstrong@linaro.org>,
	Robert Foss <rfoss@kernel.org>,
	 Laurent Pinchart <Laurent.pinchart@ideasonboard.com>,
	 Jonas Karlman <jonas@kwiboo.se>,
	Jernej Skrabec <jernej.skrabec@gmail.com>,
	 Douglas Anderson <dianders@chromium.org>
Cc: dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org,
	 Maxime Ripard <mripard@kernel.org>
Subject: [PATCH v2 12/35] drm/bridge: Change parameter name of drm_atomic_bridge_chain_disable()
Date: Tue, 04 Feb 2025 15:57:40 +0100	[thread overview]
Message-ID: <20250204-bridge-connector-v2-12-35dd6c834e08@kernel.org> (raw)
In-Reply-To: <20250204-bridge-connector-v2-0-35dd6c834e08@kernel.org>

drm_atomic_bridge_chain_disable() disables all bridges affected by a new
commit. It takes the drm_atomic_state being committed as a parameter.

However, that parameter name is called (and documented) as old_state,
which is pretty confusing. Let's rename that variable as state.

Signed-off-by: Maxime Ripard <mripard@kernel.org>
---
 drivers/gpu/drm/drm_bridge.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/gpu/drm/drm_bridge.c b/drivers/gpu/drm/drm_bridge.c
index a5d60d908251b6381f452c10ddfd7469fa01902f..0a8c7176959d13937124d2a3bf7e69309898b947 100644
--- a/drivers/gpu/drm/drm_bridge.c
+++ b/drivers/gpu/drm/drm_bridge.c
@@ -544,32 +544,32 @@ void drm_bridge_chain_mode_set(struct drm_bridge *bridge,
 EXPORT_SYMBOL(drm_bridge_chain_mode_set);
 
 /**
  * drm_atomic_bridge_chain_disable - disables all bridges in the encoder chain
  * @bridge: bridge control structure
- * @old_state: old atomic state
+ * @state: atomic state being committed
  *
  * Calls &drm_bridge_funcs.atomic_disable (falls back on
  * &drm_bridge_funcs.disable) op for all the bridges in the encoder chain,
  * starting from the last bridge to the first. These are called before calling
  * &drm_encoder_helper_funcs.atomic_disable
  *
  * Note: the bridge passed should be the one closest to the encoder
  */
 void drm_atomic_bridge_chain_disable(struct drm_bridge *bridge,
-				     struct drm_atomic_state *old_state)
+				     struct drm_atomic_state *state)
 {
 	struct drm_encoder *encoder;
 	struct drm_bridge *iter;
 
 	if (!bridge)
 		return;
 
 	encoder = bridge->encoder;
 	list_for_each_entry_reverse(iter, &encoder->bridge_chain, chain_node) {
 		if (iter->funcs->atomic_disable) {
-			iter->funcs->atomic_disable(iter, old_state);
+			iter->funcs->atomic_disable(iter, state);
 		} else if (iter->funcs->disable) {
 			iter->funcs->disable(iter);
 		}
 
 		if (iter == bridge)

-- 
2.48.0


  parent reply	other threads:[~2025-02-04 14:59 UTC|newest]

Thread overview: 71+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-02-04 14:57 [PATCH v2 00/35] drm/bridge: Various quality of life improvements Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 01/35] drm/atomic: Document history of drm_atomic_state Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 02/35] drm/bridge: Pass full state to atomic_pre_enable Maxime Ripard
2025-02-05  2:53   ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 03/35] drm/bridge: Pass full state to atomic_enable Maxime Ripard
2025-02-05  2:54   ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 04/35] drm/bridge: Pass full state to atomic_disable Maxime Ripard
2025-02-05  3:19   ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 05/35] drm/bridge: Pass full state to atomic_post_disable Maxime Ripard
2025-02-08  5:19   ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 06/35] drm/atomic-helper: Fix commit_tail state variable name Maxime Ripard
2025-02-09  1:20   ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 07/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_wait_for_dependencies() Maxime Ripard
2025-02-09  2:01   ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 08/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_commit_tail() Maxime Ripard
2025-02-09  2:03   ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 09/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_commit_tail_rpm() Maxime Ripard
2025-02-09  2:03   ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 10/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_modeset_disables() Maxime Ripard
2025-02-09  2:11   ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 11/35] drm/atomic-helper: Change parameter name of disable_outputs() Maxime Ripard
2025-02-09  2:12   ` Dmitry Baryshkov
2025-02-04 14:57 ` Maxime Ripard [this message]
2025-02-09  2:45   ` [PATCH v2 12/35] drm/bridge: Change parameter name of drm_atomic_bridge_chain_disable() Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 13/35] drm/bridge: Change parameter name of drm_atomic_bridge_chain_post_disable() Maxime Ripard
2025-02-08  1:08   ` Doug Anderson
2025-02-04 14:57 ` [PATCH v2 14/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_update_legacy_modeset_state() Maxime Ripard
2025-02-09  5:08   ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 15/35] drm/atomic-helper: Change parameter name of crtc_set_mode() Maxime Ripard
2025-02-09  5:08   ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 16/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_commit_planes() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 17/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_commit_modeset_enables() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 18/35] drm/bridge: Change parameter name of drm_atomic_bridge_chain_pre_enable() Maxime Ripard
2025-02-08  1:08   ` Doug Anderson
2025-02-04 14:57 ` [PATCH v2 19/35] drm/bridge: Change parameter name of drm_atomic_bridge_chain_enable() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 20/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_commit_writebacks() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 21/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_fake_vblank() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 22/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_commit_hw_done() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 23/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_wait_for_vblanks() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 24/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_cleanup_planes() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 25/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_commit_cleanup_done() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 26/35] drm/atomic-helper: Change parameter name of drm_atomic_helper_wait_for_flip_done() Maxime Ripard
2025-02-04 14:57 ` [PATCH v2 27/35] drm/bridge: Add encoder parameter to drm_bridge_funcs.attach Maxime Ripard
2025-02-09  6:18   ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 28/35] drm/bridge: Provide a helper to retrieve current bridge state Maxime Ripard
2025-02-09  6:12   ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 29/35] drm/bridge: Assume that a bridge is atomic if it has atomic_reset Maxime Ripard
2025-02-09  6:18   ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 30/35] drm/bridge: Provide pointers to the connector and crtc in bridge state Maxime Ripard
2025-02-09  7:00   ` Dmitry Baryshkov
2025-02-04 14:57 ` [PATCH v2 31/35] drm/bridge: Make encoder pointer deprecated Maxime Ripard
2025-02-09  7:01   ` Dmitry Baryshkov
2025-02-04 14:58 ` [PATCH v2 32/35] drm/bridge: cdns-csi: Switch to atomic helpers Maxime Ripard
2025-02-09  7:06   ` Dmitry Baryshkov
2025-02-04 14:58 ` [PATCH v2 33/35] drm/bridge: tc358775: Switch to atomic commit Maxime Ripard
2025-02-09  7:07   ` Dmitry Baryshkov
2025-02-04 14:58 ` [PATCH v2 34/35] drm/bridge: tc358768: Convert to atomic helpers Maxime Ripard
2025-02-09  7:13   ` Dmitry Baryshkov
2025-02-11 14:33     ` Maxime Ripard
2025-02-12  0:38       ` Dmitry Baryshkov
2025-02-12  8:24         ` Maxime Ripard
2025-02-12 10:51           ` Dmitry Baryshkov
2025-02-04 14:58 ` [PATCH v2 35/35] drm/bridge: ti-sn65dsi86: Use bridge_state crtc pointer Maxime Ripard
2025-02-08  1:44   ` Doug Anderson
2025-02-11 13:14     ` Maxime Ripard
2025-02-11 17:52       ` Doug Anderson
2025-02-11 22:16   ` Doug Anderson
2025-02-12 15:14     ` Doug Anderson
2025-02-09  3:27 ` [PATCH v2 00/35] drm/bridge: Various quality of life improvements Dmitry Baryshkov
2025-02-11 13:17   ` Maxime Ripard
2025-02-12  0:51     ` Dmitry Baryshkov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250204-bridge-connector-v2-12-35dd6c834e08@kernel.org \
    --to=mripard@kernel.org \
    --cc=Laurent.pinchart@ideasonboard.com \
    --cc=airlied@gmail.com \
    --cc=andrzej.hajda@intel.com \
    --cc=dianders@chromium.org \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=jernej.skrabec@gmail.com \
    --cc=jonas@kwiboo.se \
    --cc=linux-kernel@vger.kernel.org \
    --cc=maarten.lankhorst@linux.intel.com \
    --cc=neil.armstrong@linaro.org \
    --cc=rfoss@kernel.org \
    --cc=simona@ffwll.ch \
    --cc=tzimmermann@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.