From: "Darrick J. Wong" <djwong@kernel.org>
To: Christoph Hellwig <hch@lst.de>
Cc: Carlos Maiolino <cem@kernel.org>, Zorro Lang <zlang@kernel.org>,
linux-xfs@vger.kernel.org
Subject: Re: [PATCH 2/2] xfs: rename xfs_iomap_swapfile_activate to xfs_vm_swap_activate
Date: Wed, 5 Feb 2025 10:24:01 -0800 [thread overview]
Message-ID: <20250205182401.GK21808@frogsfrogsfrogs> (raw)
In-Reply-To: <20250205162813.2249154-3-hch@lst.de>
On Wed, Feb 05, 2025 at 05:28:01PM +0100, Christoph Hellwig wrote:
> Match the method name and the naming convention or address_space
> operations.
>
> Signed-off-by: Christoph Hellwig <hch@lst.de>
> ---
> fs/xfs/xfs_aops.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/fs/xfs/xfs_aops.c b/fs/xfs/xfs_aops.c
> index c792297aa0a3..fc492a1724c3 100644
> --- a/fs/xfs/xfs_aops.c
> +++ b/fs/xfs/xfs_aops.c
> @@ -681,7 +681,7 @@ xfs_vm_readahead(
> }
>
> static int
> -xfs_iomap_swapfile_activate(
> +xfs_vm_swap_activate(
Hee hee.
Reviewed-by: "Darrick J. Wong" <djwong@kernel.org>
--D
> struct swap_info_struct *sis,
> struct file *swap_file,
> sector_t *span)
> @@ -717,11 +717,11 @@ const struct address_space_operations xfs_address_space_operations = {
> .migrate_folio = filemap_migrate_folio,
> .is_partially_uptodate = iomap_is_partially_uptodate,
> .error_remove_folio = generic_error_remove_folio,
> - .swap_activate = xfs_iomap_swapfile_activate,
> + .swap_activate = xfs_vm_swap_activate,
> };
>
> const struct address_space_operations xfs_dax_aops = {
> .writepages = xfs_dax_writepages,
> .dirty_folio = noop_dirty_folio,
> - .swap_activate = xfs_iomap_swapfile_activate,
> + .swap_activate = xfs_vm_swap_activate,
> };
> --
> 2.45.2
>
>
next prev parent reply other threads:[~2025-02-05 18:24 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-02-05 16:27 fix swapon for recently unshared blocks Christoph Hellwig
2025-02-05 16:28 ` [PATCH 1/2] xfs: flush inodegc before swapon Christoph Hellwig
2025-02-05 18:23 ` Darrick J. Wong
2025-02-05 21:08 ` Dave Chinner
2025-02-05 21:16 ` Darrick J. Wong
2025-02-05 21:53 ` Dave Chinner
2025-02-05 22:05 ` Darrick J. Wong
2025-02-05 16:28 ` [PATCH 2/2] xfs: rename xfs_iomap_swapfile_activate to xfs_vm_swap_activate Christoph Hellwig
2025-02-05 18:24 ` Darrick J. Wong [this message]
-- strict thread matches above, loose matches on Subject: below --
2025-02-06 6:14 fix swapon for recently unshared blocks v2 Christoph Hellwig
2025-02-06 6:15 ` [PATCH 2/2] xfs: rename xfs_iomap_swapfile_activate to xfs_vm_swap_activate Christoph Hellwig
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250205182401.GK21808@frogsfrogsfrogs \
--to=djwong@kernel.org \
--cc=cem@kernel.org \
--cc=hch@lst.de \
--cc=linux-xfs@vger.kernel.org \
--cc=zlang@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.