All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Darrick J. Wong" <djwong@kernel.org>
To: Christoph Hellwig <hch@infradead.org>
Cc: fdmanana@kernel.org, fstests@vger.kernel.org,
	linux-btrfs@vger.kernel.org, Filipe Manana <fdmanana@suse.com>
Subject: Re: [PATCH] generic: suggest fs specific fix only if the tested filesystem matches
Date: Thu, 6 Feb 2025 07:55:01 -0800	[thread overview]
Message-ID: <20250206155501.GM21799@frogsfrogsfrogs> (raw)
In-Reply-To: <Z6TC_yP7pTlzDOH4@infradead.org>

On Thu, Feb 06, 2025 at 06:11:11AM -0800, Christoph Hellwig wrote:
> On Thu, Feb 06, 2025 at 01:05:06PM +0000, fdmanana@kernel.org wrote:
> > +if [ "$FSTYP" = "xfs" ]; then
> > +	_fixed_by_kernel_commit 68415b349f3f \
> > +		"xfs: Fix the owner setting issue for rmap query in xfs fsmap"
> > +	_fixed_by_kernel_commit ca6448aed4f1 \
> > +		"xfs: Fix missing interval for missing_owner in xfs fsmap"
> > +fi
> 
> How about you add a new helper instead of the boilerplate, something
> like
> 
> _fixed_by_fs_kernel_commit xfs 68415b349f3f \
> 	"xfs: Fix the owner setting issue for rmap query in xfs fsmap"

While we're at it, we should move these _fixed_by* functions to a
separate file to declutter common/rc?

And maybe add a few more dumb wrappers like

_fixed_by_xfsprogs_commit()
{
	test "$FSTYP" = "xfs" && \
		__fixed_by_git_commit xfsprogs "$@"
}

to replace the opencoded versions?

--D

> ?
> 

  reply	other threads:[~2025-02-06 15:55 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-02-06 13:05 [PATCH] generic: suggest fs specific fix only if the tested filesystem matches fdmanana
2025-02-06 14:11 ` Christoph Hellwig
2025-02-06 15:55   ` Darrick J. Wong [this message]
2025-02-10 14:37     ` Zorro Lang
2025-02-11 10:55       ` Filipe Manana
2025-02-06 21:12   ` Qu Wenruo
2025-02-06 22:33     ` Darrick J. Wong
2025-02-12  1:53 ` Zorro Lang
2025-02-12 12:38   ` Filipe Manana
2025-02-12 14:12     ` Zorro Lang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250206155501.GM21799@frogsfrogsfrogs \
    --to=djwong@kernel.org \
    --cc=fdmanana@kernel.org \
    --cc=fdmanana@suse.com \
    --cc=fstests@vger.kernel.org \
    --cc=hch@infradead.org \
    --cc=linux-btrfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.