From: Leo Yan <leo.yan@arm.com>
To: Suzuki K Poulose <suzuki.poulose@arm.com>
Cc: Mike Leach <mike.leach@linaro.org>,
James Clark <james.clark@linaro.org>,
Jonathan Corbet <corbet@lwn.net>,
Alexander Shishkin <alexander.shishkin@linux.intel.com>,
Arnaldo Carvalho de Melo <acme@redhat.com>,
Namhyung Kim <namhyung@kernel.org>,
coresight@lists.linaro.org, linux-arm-kernel@lists.infradead.org,
linux-doc@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 2/8] coresight: Introduce pause and resume APIs for source
Date: Mon, 10 Mar 2025 12:32:13 +0000 [thread overview]
Message-ID: <20250310123213.GF9682@e132581.arm.com> (raw)
In-Reply-To: <65979e92-0047-427c-848d-53f908671905@arm.com>
On Mon, Mar 10, 2025 at 12:01:25PM +0000, Suzuki Kuruppassery Poulose wrote:
> On 10/03/2025 10:49, Leo Yan wrote:
> > Introduce APIs for pausing and resuming trace source and export as GPL
> > symbols.
> >
> > Signed-off-by: Leo Yan <leo.yan@arm.com>
> > ---
> > drivers/hwtracing/coresight/coresight-core.c | 20 ++++++++++++++++++++
> > drivers/hwtracing/coresight/coresight-priv.h | 2 ++
> > include/linux/coresight.h | 4 ++++
> > 3 files changed, 26 insertions(+)
> >
> > diff --git a/drivers/hwtracing/coresight/coresight-core.c b/drivers/hwtracing/coresight/coresight-core.c
> > index 0a9380350fb5..eb7b83a7bfa2 100644
> > --- a/drivers/hwtracing/coresight/coresight-core.c
> > +++ b/drivers/hwtracing/coresight/coresight-core.c
> > @@ -365,6 +365,26 @@ void coresight_disable_source(struct coresight_device *csdev, void *data)
> > }
> > EXPORT_SYMBOL_GPL(coresight_disable_source);
> > +void coresight_pause_source(struct coresight_device *csdev)
> > +{
> > + if (!csdev || !coresight_is_percpu_source(csdev))
>
> You may remove the !csdev check, coresight_is_percpu_source() already checks
> that.
Will do.
> > + return;
> > +
> > + if (source_ops(csdev)->pause)
> > + source_ops(csdev)->pause(csdev);
> > +}
> > +EXPORT_SYMBOL_GPL(coresight_pause_source);
> > +
> > +void coresight_resume_source(struct coresight_device *csdev)
> > +{
> > + if (!csdev || !coresight_is_percpu_source(csdev))
> > + return;
> > +
>
> Same as above.
Will do.
> > + if (source_ops(csdev)->resume)
> > + source_ops(csdev)->resume(csdev);
> > +}
> > +EXPORT_SYMBOL_GPL(coresight_resume_source);
> > +
> > /*
> > * coresight_disable_path_from : Disable components in the given path beyond
> > * @nd in the list. If @nd is NULL, all the components, except the SOURCE are
> > diff --git a/drivers/hwtracing/coresight/coresight-priv.h b/drivers/hwtracing/coresight/coresight-priv.h
> > index 76403530f33e..a9f14c075e91 100644
> > --- a/drivers/hwtracing/coresight/coresight-priv.h
> > +++ b/drivers/hwtracing/coresight/coresight-priv.h
> > @@ -247,5 +247,7 @@ void coresight_add_helper(struct coresight_device *csdev,
> > void coresight_set_percpu_sink(int cpu, struct coresight_device *csdev);
> > struct coresight_device *coresight_get_percpu_sink(int cpu);
> > void coresight_disable_source(struct coresight_device *csdev, void *data);
> > +void coresight_pause_source(struct coresight_device *csdev);
> > +void coresight_resume_source(struct coresight_device *csdev);
> > #endif
> > diff --git a/include/linux/coresight.h b/include/linux/coresight.h
> > index 17276965ff1d..703e1b8dbe22 100644
> > --- a/include/linux/coresight.h
> > +++ b/include/linux/coresight.h
> > @@ -385,6 +385,8 @@ struct coresight_ops_link {
> > * is associated to.
> > * @enable: enables tracing for a source.
> > * @disable: disables tracing for a source.
> > + * @resume: resumes tracing for a source.
> > + * @pause: pauses tracing for a source.
> > */
> > struct coresight_ops_source {
> > int (*cpu_id)(struct coresight_device *csdev);
> > @@ -392,6 +394,8 @@ struct coresight_ops_source {
> > enum cs_mode mode, struct coresight_trace_id_map *id_map);
> > void (*disable)(struct coresight_device *csdev,
> > struct perf_event *event);
> > + int (*resume)(struct coresight_device *csdev);
> > + void (*pause)(struct coresight_device *csdev);
>
> Given these callbacks are for perf mode, does it make sense to pass the
> parameters similar to enable() ?
It is not necessary to pass perf event handle to resume() and pause()
callbacks.
The main reason is perf related operations have been processed in the
coresight-etm-perf.c layer, the low level's callbacks (pause/resume)
should simply take actions on hardware logic.
> Also, should we rename these as :
>
> resume_perf
> pause_perf
>
> To explicitly mark them perf mode specific ?
This makes sense to me. The naming "resume" might be confused with
CPUIdle's terminology (CPU resume). pause_perf/resume_perf can
perfectly avoid any confusion.
Thanks,
Leo
next prev parent reply other threads:[~2025-03-10 13:38 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-03-10 10:49 [PATCH v2 0/8] Arm CoreSight: Support AUX pause and resume Leo Yan
2025-03-10 10:49 ` [PATCH v2 1/8] coresight: etm4x: Extract the trace unit controlling Leo Yan
2025-03-10 10:57 ` Suzuki K Poulose
2025-03-10 11:59 ` Leo Yan
2025-03-10 10:49 ` [PATCH v2 2/8] coresight: Introduce pause and resume APIs for source Leo Yan
2025-03-10 12:01 ` Suzuki K Poulose
2025-03-10 12:32 ` Leo Yan [this message]
2025-03-10 10:49 ` [PATCH v2 3/8] coresight: etm4x: Hook pause and resume callbacks Leo Yan
2025-03-10 10:49 ` [PATCH v2 4/8] coresight: perf: Support AUX trace pause and resume Leo Yan
2025-03-10 10:49 ` [PATCH v2 5/8] coresight: etm: Add an attribute for updating buffer Leo Yan
2025-03-10 13:29 ` Suzuki K Poulose
2025-03-10 15:50 ` Leo Yan
2025-03-10 16:37 ` Suzuki K Poulose
2025-03-10 18:03 ` Leo Yan
2025-03-10 10:49 ` [PATCH v2 6/8] coresight: perf: Update buffer on AUX pause Leo Yan
2025-03-10 10:49 ` [PATCH v2 7/8] Documentation: coresight: Document AUX pause and resume Leo Yan
2025-03-10 10:49 ` [PATCH v2 8/8] perf cs-etm: Sync kernel coresight-pmu.h header Leo Yan
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250310123213.GF9682@e132581.arm.com \
--to=leo.yan@arm.com \
--cc=acme@redhat.com \
--cc=alexander.shishkin@linux.intel.com \
--cc=corbet@lwn.net \
--cc=coresight@lists.linaro.org \
--cc=james.clark@linaro.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-doc@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mike.leach@linaro.org \
--cc=namhyung@kernel.org \
--cc=suzuki.poulose@arm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.