All of lore.kernel.org
 help / color / mirror / Atom feed
From: Sun YangKai <sunk67188@gmail.com>
To: linux-btrfs@vger.kernel.org
Cc: David Sterba <dsterba@suse.cz>, Sun YangKai <sunk67188@gmail.com>
Subject: [PATCH v2 0/3] btrfs: random code cleanup
Date: Tue, 11 Mar 2025 16:13:11 +0800	[thread overview]
Message-ID: <20250311081317.13860-1-sunk67188@gmail.com> (raw)

These patches are not intended to change any behavior of current code.
Just trying to make the codes easier to read, and, maybe, perform better.
I'm working on btrfs_search_forward(), trying to improve it and fix some
misbehaviors. And I'll send some patches that will change the behavior of
the code later.

I'm new to the maillist, trying to read the implements, and improve it from
my perspective.
If you have any feedback or questions, please let me know :)

--
Changelog
v2:
- Improve the commit messages advised by David Sterba
- Fix some code style issues advised by David Sterba

Sun YangKai (3):
  btrfs: simplify the return value handling in search_ioctl()
  btrfs: remove the unnecessary local variable in btrfs_search_forward()
  btrfs: avoid redundant slot assignment in btrfs_search_forward()

 fs/btrfs/ctree.c | 15 ++++++---------
 fs/btrfs/ioctl.c | 15 +++++++--------
 2 files changed, 13 insertions(+), 17 deletions(-)

-- 
2.48.1


             reply	other threads:[~2025-03-11  8:13 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-03-11  8:13 Sun YangKai [this message]
2025-03-11  8:13 ` [PATCH v2 1/3] btrfs: simplify the return value handling in search_ioctl() Sun YangKai
2025-03-11  8:13 ` [PATCH v2 2/3] btrfs: remove the unnecessary local variable in btrfs_search_forward() Sun YangKai
2025-03-11  8:13 ` [PATCH v2 3/3] btrfs: avoid redundant slot assignment " Sun YangKai
2025-03-11 19:07 ` [PATCH v2 0/3] btrfs: random code cleanup David Sterba

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250311081317.13860-1-sunk67188@gmail.com \
    --to=sunk67188@gmail.com \
    --cc=dsterba@suse.cz \
    --cc=linux-btrfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.