All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Philippe Mathieu-Daudé" <philmd@linaro.org>
To: qemu-devel@nongnu.org
Cc: "Philippe Mathieu-Daudé" <philmd@linaro.org>
Subject: [PULL v2 00/14] Misc HW patches for 2025-03-11
Date: Wed, 12 Mar 2025 11:14:54 +0100	[thread overview]
Message-ID: <20250312101455.99631-1-philmd@linaro.org> (raw)

The following changes since commit 825b96dbcee23d134b691fc75618b59c5f53da32:

  Merge tag 'migration-20250310-pull-request' of https://gitlab.com/farosas/qemu into staging (2025-03-11 09:32:07 +0800)

are available in the Git repository at:

  https://github.com/philmd/qemu.git tags/hw-misc-20250312

for you to fetch changes up to 7f2a5272ff3893ef412c093aae66b7ed34ab3dfc:

  hw/sd/sdhci: Remove need for SDHCI_VENDOR_IMX definition (2025-03-12 11:11:42 +0100)

Since v1:
- Fixed typo in last patch subject (Zoltan)

----------------------------------------------------------------
Misc HW patches

- Set correct values for MPC8569E's eSDHC (Zoltan)
- Emulate Ricoh RS5C372 RTC device (Bernhard)
- Array overflow fixes in SMSC91C111 netdev (Peter)
- Fix typo in Xen HVM (Philippe)
- Move graphic height/width/depth globals to their own file (Philippe)
- Introduce qemu_arch_available() helper (Philippe)
- Check fw_cfg's ACPI availability at runtime (Philippe)
- Remove virtio-mem dependency on CONFIG_DEVICES (Philippe)
- Sort HyperV SYNDBG API definitions (Pierrick)
- Remove need for SDHCI_VENDOR_FSL definition (Philippe)

----------------------------------------------------------------

BALATON Zoltan (1):
  hw/sd/sdhci: Set reset value of interrupt registers

Bernhard Beschow (1):
  hw/rtc: Add Ricoh RS5C372 RTC emulation

Peter Maydell (4):
  hw/net/smc91c111: Sanitize packet numbers
  hw/net/smc91c111: Sanitize packet length on tx
  hw/net/smc91c111: Use MAX_PACKET_SIZE instead of magic numbers
  hw/net/smc91c111: Don't allow data register access to overrun buffer

Philippe Mathieu-Daudé (7):
  hw/xen/hvm: Fix Aarch64 typo
  system: Extract target-specific globals to their own compilation unit
  system: Replace arch_type global by qemu_arch_available() helper
  hw/acpi: Introduce acpi_builtin() helper
  hw/i386/fw_cfg: Check ACPI availability with acpi_builtin()
  hw/virtio/virtio-mem: Remove CONFIG_DEVICES include
  hw/sd/sdhci: Remove need for SDHCI_VENDOR_IMX definition

Pierrick Bouvier (1):
  hw/hyperv/hyperv-proto: Move SYNDBG definitions from target/i386

 MAINTAINERS                      |   2 +
 include/hw/acpi/acpi.h           |   3 +
 include/hw/hyperv/hyperv-proto.h |  12 ++
 include/hw/sd/sdhci.h            |   2 +-
 include/hw/xen/arch_hvm.h        |   2 +-
 include/system/arch_init.h       |   2 +-
 target/i386/kvm/hyperv-proto.h   |  12 --
 hw/acpi/acpi-stub.c              |   8 ++
 hw/acpi/core.c                   |   5 +
 hw/arm/fsl-imx25.c               |   2 -
 hw/arm/fsl-imx6.c                |   2 -
 hw/arm/fsl-imx6ul.c              |   2 -
 hw/arm/fsl-imx7.c                |   2 -
 hw/arm/fsl-imx8mp.c              |   2 -
 hw/i386/fw_cfg.c                 |   8 +-
 hw/net/smc91c111.c               | 148 ++++++++++++++++---
 hw/ppc/e500.c                    |   1 +
 hw/rtc/rs5c372.c                 | 236 +++++++++++++++++++++++++++++++
 hw/scsi/scsi-disk.c              |   2 +-
 hw/sd/sdhci.c                    |  18 ++-
 hw/virtio/virtio-mem.c           |   6 +-
 system/arch_init.c               |  19 +--
 system/globals-target.c          |  24 ++++
 system/qdev-monitor.c            |   4 +-
 system/vl.c                      |   6 +-
 tests/qtest/rs5c372-test.c       |  43 ++++++
 hw/rtc/Kconfig                   |   5 +
 hw/rtc/meson.build               |   1 +
 hw/rtc/trace-events              |   4 +
 system/meson.build               |   1 +
 tests/qtest/meson.build          |   1 +
 31 files changed, 503 insertions(+), 82 deletions(-)
 create mode 100644 hw/rtc/rs5c372.c
 create mode 100644 system/globals-target.c
 create mode 100644 tests/qtest/rs5c372-test.c

-- 
2.47.1



             reply	other threads:[~2025-03-12 10:15 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-03-12 10:14 Philippe Mathieu-Daudé [this message]
2025-03-12 10:14 ` [PULL v2 14/14] hw/sd/sdhci: Remove need for SDHCI_VENDOR_IMX definition Philippe Mathieu-Daudé
2025-03-13  7:05 ` [PULL v2 00/14] Misc HW patches for 2025-03-11 Stefan Hajnoczi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250312101455.99631-1-philmd@linaro.org \
    --to=philmd@linaro.org \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.