From: Masami Hiramatsu (Google) <mhiramat@kernel.org>
To: Douglas RAILLARD <douglas.raillard@arm.com>
Cc: rostedt@goodmis.org, Masami Hiramatsu <mhiramat@kernel.org>,
Mathieu Desnoyers <mathieu.desnoyers@efficios.com>,
linux-kernel@vger.kernel.org, linux-trace-kernel@vger.kernel.org
Subject: Re: [PATCH 3/3] tracing: Rename trace_synth() to synth_event_trace2()
Date: Wed, 19 Mar 2025 22:37:28 +0900 [thread overview]
Message-ID: <20250319223728.ca7a5ac6fa37798d17bd2e29@kernel.org> (raw)
In-Reply-To: <20250318180814.226644-3-douglas.raillard@arm.com>
On Tue, 18 Mar 2025 18:08:12 +0000
Douglas RAILLARD <douglas.raillard@arm.com> wrote:
> From: Douglas Raillard <douglas.raillard@arm.com>
>
> Rename the frehsly exposed trace_synth() to synth_event_trace2() to
> comply with the existing naming convention. Since synth_event_trace()
> already exists (and operates on a "struct trace_event_file *"), use a
> new name for it.
>
I don't like this '2' and similar version digit naming for the functions.
Can you choose another better name?
BTW, can you also write a cover mail so that what is the goal of this
series, background and results?
Thank you,
> Signed-off-by: Douglas Raillard <douglas.raillard@arm.com>
> ---
> include/linux/trace_events.h | 2 +-
> kernel/trace/trace_events_hist.c | 2 +-
> kernel/trace/trace_events_synth.c | 4 ++--
> 3 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/include/linux/trace_events.h b/include/linux/trace_events.h
> index e069d84a73f0..753ce8aecfe4 100644
> --- a/include/linux/trace_events.h
> +++ b/include/linux/trace_events.h
> @@ -521,7 +521,7 @@ struct synth_event;
>
> extern struct synth_event *synth_event_find(const char *name);
>
> -extern void trace_synth(struct synth_event *event, u64 *var_ref_vals,
> +extern void synth_event_trace2(struct synth_event *event, u64 *var_ref_vals,
> unsigned int *var_ref_idx);
>
> extern int synth_event_delete(const char *name);
> diff --git a/kernel/trace/trace_events_hist.c b/kernel/trace/trace_events_hist.c
> index 7067f6fedb1a..ee0fee123c91 100644
> --- a/kernel/trace/trace_events_hist.c
> +++ b/kernel/trace/trace_events_hist.c
> @@ -822,7 +822,7 @@ static void action_trace(struct hist_trigger_data *hist_data,
> {
> struct synth_event *event = data->synth_event;
>
> - trace_synth(event, var_ref_vals, data->var_ref_idx);
> + synth_event_trace2(event, var_ref_vals, data->var_ref_idx);
> }
>
> struct hist_var_data {
> diff --git a/kernel/trace/trace_events_synth.c b/kernel/trace/trace_events_synth.c
> index 4a9a44d37ffc..8837aa258479 100644
> --- a/kernel/trace/trace_events_synth.c
> +++ b/kernel/trace/trace_events_synth.c
> @@ -850,7 +850,7 @@ EXPORT_SYMBOL_GPL(synth_event_find);
> typedef void (*synth_probe_func_t) (void *__data, u64 *var_ref_vals,
> unsigned int *var_ref_idx);
>
> -void trace_synth(struct synth_event *event, u64 *var_ref_vals,
> +void synth_event_trace2(struct synth_event *event, u64 *var_ref_vals,
> unsigned int *var_ref_idx)
> {
> struct tracepoint *tp = event->tp;
> @@ -873,7 +873,7 @@ void trace_synth(struct synth_event *event, u64 *var_ref_vals,
> }
> }
> }
> -EXPORT_SYMBOL_GPL(trace_synth);
> +EXPORT_SYMBOL_GPL(synth_event_trace2);
>
> static struct trace_event_fields synth_event_fields_array[] = {
> { .type = TRACE_FUNCTION_TYPE,
> --
> 2.43.0
>
--
Masami Hiramatsu (Google) <mhiramat@kernel.org>
next prev parent reply other threads:[~2025-03-19 13:37 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-03-18 18:08 [PATCH 1/3] tracing: Expose functions to trace a synth event Douglas RAILLARD
2025-03-18 18:08 ` [PATCH 2/3] tracing: Rename find_synth_event() into synth_event_find() Douglas RAILLARD
2025-03-18 18:08 ` [PATCH 3/3] tracing: Rename trace_synth() to synth_event_trace2() Douglas RAILLARD
2025-03-19 13:37 ` Masami Hiramatsu [this message]
2025-03-19 14:51 ` Douglas Raillard
2025-03-24 6:29 ` Masami Hiramatsu
2025-03-24 14:30 ` Steven Rostedt
2025-03-25 16:05 ` Douglas Raillard
2025-03-25 16:25 ` Steven Rostedt
2025-03-25 18:16 ` Douglas Raillard
2025-03-25 20:13 ` Douglas Raillard
-- strict thread matches above, loose matches on Subject: below --
2025-03-25 21:40 Adnan-khan Ruzwan1
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250319223728.ca7a5ac6fa37798d17bd2e29@kernel.org \
--to=mhiramat@kernel.org \
--cc=douglas.raillard@arm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-trace-kernel@vger.kernel.org \
--cc=mathieu.desnoyers@efficios.com \
--cc=rostedt@goodmis.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.