From: Kees Cook <kees@kernel.org>
To: Petr Pavlu <petr.pavlu@suse.com>
Cc: Luis Chamberlain <mcgrof@kernel.org>,
Sami Tolvanen <samitolvanen@google.com>,
Daniel Gomez <da.gomez@samsung.com>,
linux-modules@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-hardening@vger.kernel.org
Subject: Re: [PATCH] module/decompress: Adjust module_extend_max_pages() allocation type
Date: Wed, 30 Apr 2025 13:06:24 -0700 [thread overview]
Message-ID: <202504301305.2A0CD4E8@keescook> (raw)
In-Reply-To: <d7382c8a-cfb2-4389-b120-f01a17e248ab@suse.com>
On Mon, Apr 28, 2025 at 12:30:03PM +0200, Petr Pavlu wrote:
> On 4/26/25 08:24, Kees Cook wrote:
> > In preparation for making the kmalloc family of allocators type aware,
> > we need to make sure that the returned type from the allocation matches
> > the type of the variable being assigned. (Before, the allocator would
> > always return "void *", which can be implicitly cast to any pointer type.)
> >
> > The assigned type is "struct page **" but the returned type will be
> > "struct page ***". These have the same allocation size (pointer size), but
> > the types don't match. Adjust the allocation type to match the assignment.
> >
> > Signed-off-by: Kees Cook <kees@kernel.org>
> > ---
> > Cc: Luis Chamberlain <mcgrof@kernel.org>
> > Cc: Petr Pavlu <petr.pavlu@suse.com>
> > Cc: Sami Tolvanen <samitolvanen@google.com>
> > Cc: Daniel Gomez <da.gomez@samsung.com>
> > Cc: <linux-modules@vger.kernel.org>
> > ---
> > kernel/module/decompress.c | 2 +-
> > 1 file changed, 1 insertion(+), 1 deletion(-)
> >
> > diff --git a/kernel/module/decompress.c b/kernel/module/decompress.c
> > index 474e68f0f063..bbb2a55568cd 100644
> > --- a/kernel/module/decompress.c
> > +++ b/kernel/module/decompress.c
> > @@ -19,7 +19,7 @@ static int module_extend_max_pages(struct load_info *info, unsigned int extent)
> > struct page **new_pages;
> >
> > new_pages = kvmalloc_array(info->max_pages + extent,
> > - sizeof(info->pages), GFP_KERNEL);
> > + sizeof(*new_pages), GFP_KERNEL);
> > if (!new_pages)
> > return -ENOMEM;
> >
>
> The function has a similar type mismatch a few lines below:
>
> memcpy(new_pages, info->pages, info->max_pages * sizeof(info->pages));
>
> The sizeof operator is used on 'struct page **', but it should be really
> on 'struct page *'.
>
> Could you please fix this as well? For consistency with your patch,
> I suggest changing it to 'sizeof(*new_pages)'.
Actually, this whole function is basically just open-coded kvrealloc...
I will send a v2.
--
Kees Cook
prev parent reply other threads:[~2025-04-30 20:06 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-04-26 6:24 [PATCH] module/decompress: Adjust module_extend_max_pages() allocation type Kees Cook
2025-04-28 10:30 ` Petr Pavlu
2025-04-30 20:06 ` Kees Cook [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=202504301305.2A0CD4E8@keescook \
--to=kees@kernel.org \
--cc=da.gomez@samsung.com \
--cc=linux-hardening@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-modules@vger.kernel.org \
--cc=mcgrof@kernel.org \
--cc=petr.pavlu@suse.com \
--cc=samitolvanen@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.