All of lore.kernel.org
 help / color / mirror / Atom feed
From: Lee Jones <lee@kernel.org>
To: nuno.sa@analog.com
Cc: linux-gpio@vger.kernel.org, linux-pwm@vger.kernel.org,
	devicetree@vger.kernel.org, linux-input@vger.kernel.org,
	"Rob Herring" <robh@kernel.org>,
	"Krzysztof Kozlowski" <krzk+dt@kernel.org>,
	"Conor Dooley" <conor+dt@kernel.org>,
	"Uwe Kleine-König" <ukleinek@kernel.org>,
	"Linus Walleij" <linus.walleij@linaro.org>,
	"Bartosz Golaszewski" <brgl@bgdev.pl>,
	"Dmitry Torokhov" <dmitry.torokhov@gmail.com>,
	"Laurent Pinchart" <laurent.pinchart@ideasonboard.com>,
	"Liu Ying" <victor.liu@nxp.com>,
	"Bartosz Golaszewski" <bartosz.golaszewski@linaro.org>,
	"Krzysztof Kozlowski" <krzysztof.kozlowski@linaro.org>
Subject: Re: [PATCH v5 00/20] mfd: adp5585: support keymap events and drop legacy Input driver
Date: Thu, 19 Jun 2025 14:38:34 +0100	[thread overview]
Message-ID: <20250619133834.GC795775@google.com> (raw)
In-Reply-To: <20250614-dev-adp5589-fw-v5-0-7e9d84906268@analog.com>

On Sat, 14 Jun 2025, Nuno Sá via B4 Relay wrote:

> Hi all,
> 
> Here it goes v4. Main changes is to drop chip info based struct and
> directly use an enum in the FW .data pointer, use the notifier API for
> dispatching events and multiple calls to mfd_add_devices().
> 
> Regarding the last point, I think I could have used multiple calls to
> devm_mfd_add_devices() and avoid those gotos in adp5585_add_devices()
> but I do not feel that would have been "correct".
> 
> Thanks!
> - Nuno Sá
> 
> ---
> Changes in v5:

In future, these should be inside the patches themselves please.

> - Patch 2:
>   * Use the existing devm_mfd_add_devices().
> - Patch 3:
>   * Remove TODO comment.
> - Patch 4:
>   * Mention in the commit message the Copyright update.
> - Patch 6:
>   * Return a struct regmap_config pointer in
>     adp5585_fill_regmap_config();
>   * Just leave a blank entry in the adp5585_regmap_defaults array.
> - Patch 13:
>   * Improve comments for pin6 (row5) validation;
>   * Don't use magic numbers;
>   * Drop some odd line breaks;
>   * Initialize vartiable when declaring.
> - Patch 14:
>   * Drop double spaces;
>   * Don't use magic numbers;
>   * Improve some comments.
> - Patch 16:
>   * Fix missing semicolon.
> - Patch 20:
>   * DS -> datasheet. 
> 
> - Link to v4: https://lore.kernel.org/r/20250521-dev-adp5589-fw-v4-0-f2c988d7a7a0@analog.com
> - Link to v3: https://lore.kernel.org/r/20250512-dev-adp5589-fw-v3-0-092b14b79a88@analog.com
> - Link to v2: https://lore.kernel.org/r/20250415-dev-adp5589-fw-v2-0-3a799c3ed812@analog.com
> - Link to v1: https://lore.kernel.org/r/20250313-dev-adp5589-fw-v1-0-20e80d4bd4ea@analog.com
> 
> ---
> Nuno Sá (20):
>       dt-bindings: mfd: adp5585: ease on the required properties
>       mfd: adp5585: only add devices given in FW
>       mfd: adp5585: enable oscilator during probe
>       mfd: adp5585: make use of MFD_CELL_NAME()
>       dt-bindings: mfd: adp5585: document adp5589 I/O expander
>       mfd: adp5585: refactor how regmap defaults are handled
>       mfd: adp5585: add support for adp5589
>       mfd: adp5585: add a per chip reg struture
>       gpio: adp5585: add support for the adp5589 expander
>       pwm: adp5585: add support for adp5589
>       dt-bindings: mfd: adp5585: add properties for input events
>       mfd: adp5585: add support for event handling
>       mfd: adp5585: support reset and unlock events
>       mfd: adp5585: add support for input devices
>       gpio: adp5585: support gpi events
>       Input: adp5585: Add Analog Devices ADP5585/89 support
>       Input: adp5589: remove the driver
>       mfd: adp5585: support getting vdd regulator
>       dt-bindings: mfd: adp5585: document reset gpio
>       mfd: adp5585: add support for a reset pin
> 
>  .../devicetree/bindings/mfd/adi,adp5585.yaml       |  240 ++++-
>  .../devicetree/bindings/trivial-devices.yaml       |    2 -
>  MAINTAINERS                                        |    1 +
>  drivers/gpio/Kconfig                               |    1 +
>  drivers/gpio/gpio-adp5585.c                        |  364 ++++++-
>  drivers/input/keyboard/Kconfig                     |   21 +-
>  drivers/input/keyboard/Makefile                    |    2 +-
>  drivers/input/keyboard/adp5585-keys.c              |  371 +++++++
>  drivers/input/keyboard/adp5589-keys.c              | 1066 --------------------
>  drivers/mfd/adp5585.c                              |  743 +++++++++++++-
>  drivers/pwm/pwm-adp5585.c                          |   78 +-
>  include/linux/mfd/adp5585.h                        |  118 ++-
>  12 files changed, 1799 insertions(+), 1208 deletions(-)
> ---
> base-commit: 407f60a151df3c44397e5afc0111eb9b026c38d3
> change-id: 20250311-dev-adp5589-fw-e04cfd945286
> --
> 
> Thanks!
> - Nuno Sá
> 
> 

-- 
Lee Jones [李琼斯]

  parent reply	other threads:[~2025-06-19 13:38 UTC|newest]

Thread overview: 57+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-06-14 14:35 [PATCH v5 00/20] mfd: adp5585: support keymap events and drop legacy Input driver Nuno Sá
2025-06-14 14:35 ` Nuno Sá via B4 Relay
2025-06-14 14:35 ` [PATCH v5 01/20] dt-bindings: mfd: adp5585: ease on the required properties Nuno Sá
2025-06-14 14:35   ` Nuno Sá via B4 Relay
2025-06-14 14:35 ` [PATCH v5 02/20] mfd: adp5585: only add devices given in FW Nuno Sá
2025-06-14 14:35   ` Nuno Sá via B4 Relay
2025-06-14 14:35 ` [PATCH v5 03/20] mfd: adp5585: enable oscilator during probe Nuno Sá
2025-06-14 14:35   ` Nuno Sá via B4 Relay
2025-06-18 17:41   ` Uwe Kleine-König
2025-06-14 14:35 ` [PATCH v5 04/20] mfd: adp5585: make use of MFD_CELL_NAME() Nuno Sá
2025-06-14 14:35   ` Nuno Sá via B4 Relay
2025-06-14 14:35 ` [PATCH v5 05/20] dt-bindings: mfd: adp5585: document adp5589 I/O expander Nuno Sá
2025-06-14 14:35   ` Nuno Sá via B4 Relay
2025-06-14 14:35 ` [PATCH v5 06/20] mfd: adp5585: refactor how regmap defaults are handled Nuno Sá
2025-06-14 14:35   ` Nuno Sá via B4 Relay
2025-06-19 14:19   ` Lee Jones
2025-06-14 14:35 ` [PATCH v5 07/20] mfd: adp5585: add support for adp5589 Nuno Sá
2025-06-14 14:35   ` Nuno Sá via B4 Relay
2025-06-14 14:35 ` [PATCH v5 08/20] mfd: adp5585: add a per chip reg struture Nuno Sá
2025-06-14 14:35   ` Nuno Sá via B4 Relay
2025-06-14 14:36 ` [PATCH v5 09/20] gpio: adp5585: add support for the adp5589 expander Nuno Sá
2025-06-14 14:36   ` Nuno Sá via B4 Relay
2025-06-16  7:57   ` Bartosz Golaszewski
2025-06-14 14:36 ` [PATCH v5 10/20] pwm: adp5585: add support for adp5589 Nuno Sá
2025-06-14 14:36   ` Nuno Sá via B4 Relay
2025-06-18 17:42   ` Uwe Kleine-König
2025-06-14 14:36 ` [PATCH v5 11/20] dt-bindings: mfd: adp5585: add properties for input events Nuno Sá
2025-06-14 14:36   ` Nuno Sá via B4 Relay
2025-06-14 14:36 ` [PATCH v5 12/20] mfd: adp5585: add support for event handling Nuno Sá
2025-06-14 14:36   ` Nuno Sá via B4 Relay
2025-06-14 14:36 ` [PATCH v5 13/20] mfd: adp5585: support reset and unlock events Nuno Sá
2025-06-14 14:36   ` Nuno Sá via B4 Relay
2025-06-14 14:36 ` [PATCH v5 14/20] mfd: adp5585: add support for input devices Nuno Sá
2025-06-14 14:36   ` Nuno Sá via B4 Relay
2025-06-14 14:36 ` [PATCH v5 15/20] gpio: adp5585: support gpi events Nuno Sá
2025-06-14 14:36   ` Nuno Sá via B4 Relay
2025-06-14 14:36 ` [PATCH v5 16/20] Input: adp5585: Add Analog Devices ADP5585/89 support Nuno Sá
2025-06-14 14:36   ` Nuno Sá via B4 Relay
2025-06-17 21:10   ` Dmitry Torokhov
2025-06-14 14:36 ` [PATCH v5 17/20] Input: adp5589: remove the driver Nuno Sá
2025-06-14 14:36   ` Nuno Sá via B4 Relay
2025-06-14 14:36 ` [PATCH v5 18/20] mfd: adp5585: support getting vdd regulator Nuno Sá
2025-06-14 14:36   ` Nuno Sá via B4 Relay
2025-06-19 14:22   ` Lee Jones
2025-06-14 14:36 ` [PATCH v5 19/20] dt-bindings: mfd: adp5585: document reset gpio Nuno Sá
2025-06-14 14:36   ` Nuno Sá via B4 Relay
2025-06-14 14:36 ` [PATCH v5 20/20] mfd: adp5585: add support for a reset pin Nuno Sá
2025-06-14 14:36   ` Nuno Sá via B4 Relay
2025-06-19 13:38 ` Lee Jones [this message]
2025-06-27 15:46   ` [PATCH v5 00/20] mfd: adp5585: support keymap events and drop legacy Input driver Nuno Sá
2025-07-01 11:05     ` Lee Jones
2025-07-01 11:09       ` Nuno Sá
2025-07-01 11:15         ` Krzysztof Kozlowski
2025-07-01 11:19         ` Laurent Pinchart
2025-07-01 13:37           ` Lee Jones
2025-07-01 13:42             ` Nuno Sá
2025-06-19 14:23 ` Lee Jones

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250619133834.GC795775@google.com \
    --to=lee@kernel.org \
    --cc=bartosz.golaszewski@linaro.org \
    --cc=brgl@bgdev.pl \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=dmitry.torokhov@gmail.com \
    --cc=krzk+dt@kernel.org \
    --cc=krzysztof.kozlowski@linaro.org \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=linus.walleij@linaro.org \
    --cc=linux-gpio@vger.kernel.org \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-pwm@vger.kernel.org \
    --cc=nuno.sa@analog.com \
    --cc=robh@kernel.org \
    --cc=ukleinek@kernel.org \
    --cc=victor.liu@nxp.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.