All of lore.kernel.org
 help / color / mirror / Atom feed
From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
To: Bart Van Assche <bvanassche@acm.org>
Cc: "Martin K . Petersen" <martin.petersen@oracle.com>,
	linux-scsi@vger.kernel.org,
	"James E.J. Bottomley" <James.Bottomley@hansenpartnership.com>,
	Bean Huo <huobean@gmail.com>, Huan Tang <tanghuan@vivo.com>,
	Peter Wang <peter.wang@mediatek.com>,
	Avri Altman <avri.altman@wdc.com>,
	"Bao D. Nguyen" <quic_nguyenb@quicinc.com>,
	Ziqi Chen <quic_ziqichen@quicinc.com>,
	Keoseong Park <keosung.park@samsung.com>,
	Gwendal Grignou <gwendal@chromium.org>,
	Stanislav Nijnikov <stanislav.nijnikov@wdc.com>,
	Al Viro <viro@zeniv.linux.org.uk>
Subject: Re: [PATCH] scsi: ufs: core: Fix spelling of a sysfs attribute name
Date: Wed, 25 Jun 2025 09:00:02 +0100	[thread overview]
Message-ID: <2025062523-cheesy-engaged-88e9@gregkh> (raw)
In-Reply-To: <20250624181658.336035-1-bvanassche@acm.org>

On Tue, Jun 24, 2025 at 11:16:44AM -0700, Bart Van Assche wrote:
> Change "resourse" into "resource" in the name of a sysfs attribute.
> 
> Fixes: d829fc8a1058 ("scsi: ufs: sysfs: unit descriptor")
> Signed-off-by: Bart Van Assche <bvanassche@acm.org>
> ---
>  Documentation/ABI/testing/sysfs-driver-ufs | 2 +-
>  drivers/ufs/core/ufs-sysfs.c               | 4 ++--
>  2 files changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/Documentation/ABI/testing/sysfs-driver-ufs b/Documentation/ABI/testing/sysfs-driver-ufs
> index f3de8c521bbd..a90612ab5780 100644
> --- a/Documentation/ABI/testing/sysfs-driver-ufs
> +++ b/Documentation/ABI/testing/sysfs-driver-ufs
> @@ -711,7 +711,7 @@ Description:	This file shows the thin provisioning type. This is one of
>  
>  		The file is read only.
>  
> -What:		/sys/class/scsi_device/*/device/unit_descriptor/physical_memory_resourse_count
> +What:		/sys/class/scsi_device/*/device/unit_descriptor/physical_memory_resource_count
>  Date:		February 2018

As you are changing the name of a sysfs file that has been in the kernel
for a very long time, what userspace code is now going to break that was
using the old name?

thanks,

greg k-h

  parent reply	other threads:[~2025-06-25  8:00 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-06-24 18:16 [PATCH] scsi: ufs: core: Fix spelling of a sysfs attribute name Bart Van Assche
2025-06-24 18:45 ` Avri Altman
2025-06-25  1:48 ` Peter Wang (王信友)
2025-06-25  8:00 ` Greg Kroah-Hartman [this message]
2025-06-25  9:18   ` Avri Altman
2025-06-25 10:03     ` Greg Kroah-Hartman
2025-06-25 11:36       ` Avri Altman

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2025062523-cheesy-engaged-88e9@gregkh \
    --to=gregkh@linuxfoundation.org \
    --cc=James.Bottomley@hansenpartnership.com \
    --cc=avri.altman@wdc.com \
    --cc=bvanassche@acm.org \
    --cc=gwendal@chromium.org \
    --cc=huobean@gmail.com \
    --cc=keosung.park@samsung.com \
    --cc=linux-scsi@vger.kernel.org \
    --cc=martin.petersen@oracle.com \
    --cc=peter.wang@mediatek.com \
    --cc=quic_nguyenb@quicinc.com \
    --cc=quic_ziqichen@quicinc.com \
    --cc=stanislav.nijnikov@wdc.com \
    --cc=tanghuan@vivo.com \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.