All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Daniel P. Berrangé" <berrange@redhat.com>
To: qemu-devel@nongnu.org
Cc: "Marc-André Lureau" <marcandre.lureau@redhat.com>,
	"Jagannathan Raman" <jag.raman@oracle.com>,
	"Zhao Liu" <zhao1.liu@intel.com>,
	"Eric Blake" <eblake@redhat.com>,
	"Stefan Hajnoczi" <stefanha@redhat.com>,
	"Michael S. Tsirkin" <mst@redhat.com>,
	"Hanna Reitz" <hreitz@redhat.com>,
	"Gustavo Romero" <gustavo.romero@linaro.org>,
	"Thanos Makatos" <thanos.makatos@nutanix.com>,
	"Cédric Le Goater" <clg@redhat.com>,
	"Darren Kenny" <darren.kenny@oracle.com>,
	"Stefano Garzarella" <sgarzare@redhat.com>,
	"Kevin Wolf" <kwolf@redhat.com>,
	"Fabiano Rosas" <farosas@suse.de>,
	qemu-block@nongnu.org, "Peter Xu" <peterx@redhat.com>,
	"Laurent Vivier" <lvivier@redhat.com>,
	"Jason Wang" <jasowang@redhat.com>,
	"Elena Ufimtseva" <elena.ufimtseva@oracle.com>,
	"John Levon" <john.levon@nutanix.com>,
	"Fam Zheng" <fam@euphon.net>, "Alexander Bulekov" <alxndr@bu.edu>,
	"Stefan Weil" <sw@weilnetz.de>,
	"Gerd Hoffmann" <kraxel@redhat.com>,
	"Coiby Xu" <Coiby.Xu@gmail.com>,
	"Daniel P. Berrangé" <berrange@redhat.com>,
	"Qiuhao Li" <Qiuhao.Li@outlook.com>,
	"Michael Roth" <michael.roth@amd.com>,
	"Vladimir Sementsov-Ogievskiy" <vsementsov@yandex-team.ru>,
	"Paolo Bonzini" <pbonzini@redhat.com>,
	"Bandan Das" <bsd@redhat.com>,
	"Kostiantyn Kostiuk" <kkostiuk@redhat.com>,
	"Hailiang Zhang" <zhanghailiang@xfusion.com>
Subject: [PULL 06/16] util: add qemu_set_blocking() function
Date: Fri, 19 Sep 2025 12:50:07 +0100	[thread overview]
Message-ID: <20250919115017.1536203-7-berrange@redhat.com> (raw)
In-Reply-To: <20250919115017.1536203-1-berrange@redhat.com>

From: Vladimir Sementsov-Ogievskiy <vsementsov@yandex-team.ru>

In generic code we have qio_channel_set_blocking(), which takes
bool parameter, and qemu_file_set_blocking(), which as well takes
bool parameter.

At lower fd-layer we have a mess of functions:

- enough direct calls to Unix-specific g_unix_set_fd_nonblocking()
(of course, all calls are out of Windows-compatible code), which
is glib specific with GError, which we can't use, and have to
handle error-reporting by hand after the call.

and several platform-agnostic qemu_* helpers:

- qemu_socket_set_nonblock(), which asserts success for posix (still,
  in most cases we can handle the error in better way) and ignores
  error for win32 realization

- qemu_socket_try_set_nonblock(), providing and error, but not errp,
so we have to handle it after the call

- qemu_socket_set_block(), which simply ignores an error

Note, that *_socket_* word in original API, which we are going
to substitute was intended, because Windows support these operations
only for sockets. What leads to solution of dropping it again?

1. Having a QEMU-native wrapper with errp parameter
for g_unix_set_fd_nonblocking() for non-socket fds worth doing,
at least to unify error handling.

2. So, if try to keep _socket_ vs _file_ words, we'll have two
actually duplicated functions for Linux, which actually will
be executed successfully on any (good enough) fds, and nothing
prevent using them improperly except for the name. That doesn't
look good.

3. Naming helped us in the world where we crash on errors or
ignore them. Now, with errp parameter, callers are intended to
proper error checking. And for places where we really OK with
crash-on-error semantics (like tests), we have an explicit
&error_abort.

So, this commit starts a series, which will effectively revert
commit ff5927baa7ffb9 "util: rename qemu_*block() socket functions"
(which in turn was reverting f9e8cacc5557e43
"oslib-posix: rename socket_set_nonblock() to qemu_set_nonblock()",
so that's a long story).
Now we don't simply rename, instead we provide the new API and
update all the callers.

This commit only introduces a new fd-layer wrapper. Next commits
will replace old API calls with it, and finally remove old API.

Reviewed-by: Daniel P. Berrangé <berrange@redhat.com>
Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov@yandex-team.ru>
Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
---
 include/qemu/osdep.h |  1 +
 util/oslib-posix.c   | 15 +++++++++++++++
 util/oslib-win32.c   | 18 ++++++++++++++++++
 3 files changed, 34 insertions(+)

diff --git a/include/qemu/osdep.h b/include/qemu/osdep.h
index be3460b32f..1b38cb7e45 100644
--- a/include/qemu/osdep.h
+++ b/include/qemu/osdep.h
@@ -687,6 +687,7 @@ ssize_t qemu_write_full(int fd, const void *buf, size_t count)
     G_GNUC_WARN_UNUSED_RESULT;
 
 void qemu_set_cloexec(int fd);
+bool qemu_set_blocking(int fd, bool block, Error **errp);
 
 /* Return a dynamically allocated directory path that is appropriate for storing
  * local state.
diff --git a/util/oslib-posix.c b/util/oslib-posix.c
index 4ff577e5de..c737701075 100644
--- a/util/oslib-posix.c
+++ b/util/oslib-posix.c
@@ -250,6 +250,21 @@ void qemu_anon_ram_free(void *ptr, size_t size)
 #endif
 }
 
+bool qemu_set_blocking(int fd, bool block, Error **errp)
+{
+    g_autoptr(GError) err = NULL;
+
+    if (!g_unix_set_fd_nonblocking(fd, !block, &err)) {
+        error_setg_errno(errp, errno,
+                         "Can't set file descriptor %d %s: %s", fd,
+                         block ? "blocking" : "non-blocking",
+                         err->message);
+        return false;
+    }
+
+    return true;
+}
+
 void qemu_socket_set_block(int fd)
 {
     g_unix_set_fd_nonblocking(fd, false, NULL);
diff --git a/util/oslib-win32.c b/util/oslib-win32.c
index b7351634ec..03044f5b59 100644
--- a/util/oslib-win32.c
+++ b/util/oslib-win32.c
@@ -177,6 +177,24 @@ static int socket_error(void)
     }
 }
 
+bool qemu_set_blocking(int fd, bool block, Error **errp)
+{
+    unsigned long opt = block ? 0 : 1;
+
+    if (block) {
+        qemu_socket_unselect(fd, NULL);
+    }
+
+    if (ioctlsocket(fd, FIONBIO, &opt) != NO_ERROR) {
+        error_setg_errno(errp, socket_error(),
+                         "Can't set file descriptor %d %s", fd,
+                         block ? "blocking" : "non-blocking");
+        return false;
+    }
+
+    return true;
+}
+
 void qemu_socket_set_block(int fd)
 {
     unsigned long opt = 0;
-- 
2.50.1



  parent reply	other threads:[~2025-09-19 11:53 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-09-19 11:50 [PULL 00/16] Treewide I/O handle cleanup Daniel P. Berrangé
2025-09-19 11:50 ` [PULL 01/16] MAINTAINERS: list qemu-security@nongnu.org as security contact Daniel P. Berrangé
2025-09-19 11:50 ` [PULL 02/16] migration/qemu-file: don't make incoming fds blocking again Daniel P. Berrangé
2025-09-19 11:50 ` [PULL 03/16] io/channel: document how qio_channel_readv_full() handles fds Daniel P. Berrangé
2025-09-19 11:50 ` [PULL 04/16] char-socket: tcp_chr_recv(): drop extra _set_(block, cloexec) Daniel P. Berrangé via
2025-09-19 11:50 ` [PULL 05/16] char-socket: tcp_chr_recv(): add comment Daniel P. Berrangé
2025-09-19 11:50 ` Daniel P. Berrangé [this message]
2025-09-19 11:50 ` [PULL 07/16] treewide: handle result of qio_channel_set_blocking() Daniel P. Berrangé
2025-09-19 11:50 ` [PULL 08/16] migration: qemu_file_set_blocking(): add errp parameter Daniel P. Berrangé
2025-09-19 11:50 ` [PULL 09/16] util: drop qemu_socket_set_nonblock() Daniel P. Berrangé
2025-09-19 11:50 ` [PULL 10/16] util: drop qemu_socket_try_set_nonblock() Daniel P. Berrangé
2025-09-19 11:50 ` [PULL 11/16] io/channel-socket: rework qio_channel_socket_copy_fds() Daniel P. Berrangé
2025-09-19 11:50 ` [PULL 12/16] util: drop qemu_socket_set_block() Daniel P. Berrangé
2025-09-19 11:50 ` [PULL 13/16] treewide: use qemu_set_blocking instead of g_unix_set_fd_nonblocking Daniel P. Berrangé
2025-09-22 13:40   ` Peter Maydell
2025-09-22 14:19     ` Vladimir Sementsov-Ogievskiy
2025-09-19 11:50 ` [PULL 14/16] chardev: qemu_chr_open_fd(): add errp Daniel P. Berrangé
2025-09-22 13:45   ` Peter Maydell
2025-09-22 14:27     ` Vladimir Sementsov-Ogievskiy
2025-10-14 12:52       ` Peter Maydell
2025-10-14 13:20         ` Vladimir Sementsov-Ogievskiy
2025-09-22 14:29     ` Daniel P. Berrangé
2025-09-19 11:50 ` [PULL 15/16] chardev: close an fd on failure path Daniel P. Berrangé
2025-09-19 11:50 ` [PULL 16/16] util/vhost-user-server: vu_message_read(): improve error handling Daniel P. Berrangé
2025-09-19 20:47 ` [PULL 00/16] Treewide I/O handle cleanup Richard Henderson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20250919115017.1536203-7-berrange@redhat.com \
    --to=berrange@redhat.com \
    --cc=Coiby.Xu@gmail.com \
    --cc=Qiuhao.Li@outlook.com \
    --cc=alxndr@bu.edu \
    --cc=bsd@redhat.com \
    --cc=clg@redhat.com \
    --cc=darren.kenny@oracle.com \
    --cc=eblake@redhat.com \
    --cc=elena.ufimtseva@oracle.com \
    --cc=fam@euphon.net \
    --cc=farosas@suse.de \
    --cc=gustavo.romero@linaro.org \
    --cc=hreitz@redhat.com \
    --cc=jag.raman@oracle.com \
    --cc=jasowang@redhat.com \
    --cc=john.levon@nutanix.com \
    --cc=kkostiuk@redhat.com \
    --cc=kraxel@redhat.com \
    --cc=kwolf@redhat.com \
    --cc=lvivier@redhat.com \
    --cc=marcandre.lureau@redhat.com \
    --cc=michael.roth@amd.com \
    --cc=mst@redhat.com \
    --cc=pbonzini@redhat.com \
    --cc=peterx@redhat.com \
    --cc=qemu-block@nongnu.org \
    --cc=qemu-devel@nongnu.org \
    --cc=sgarzare@redhat.com \
    --cc=stefanha@redhat.com \
    --cc=sw@weilnetz.de \
    --cc=thanos.makatos@nutanix.com \
    --cc=vsementsov@yandex-team.ru \
    --cc=zhanghailiang@xfusion.com \
    --cc=zhao1.liu@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.