From: Philip Oberfichtner <pro@denx.de>
To: u-boot@lists.denx.de
Cc: Philip Oberfichtner <pro@denx.de>,
Andre Przywara <andre.przywara@arm.com>,
Anshul Dalal <anshuld@ti.com>,
Dario Binacchi <dario.binacchi@amarulasolutions.com>,
Greg Malysa <malysagreg@gmail.com>,
Heinrich Schuchardt <heinrich.schuchardt@canonical.com>,
Ilias Apalodimas <ilias.apalodimas@linaro.org>,
Jerome Forissier <jerome.forissier@linaro.org>,
Marek Vasut <marek.vasut@mailbox.org>,
Nathan Barrett-Morrison <nathan.morrison@timesys.com>,
Peng Fan <peng.fan@nxp.com>, Simon Glass <sjg@chromium.org>,
Tom Rini <trini@konsulko.com>,
Trevor Woerner <twoerner@gmail.com>, Ye Li <ye.li@nxp.com>
Subject: [PATCH v5 0/3] Harmonize image size checks
Date: Mon, 10 Nov 2025 10:12:53 +0100 [thread overview]
Message-ID: <20251110091256.2422534-1-pro@denx.de> (raw)
This patch series aims at harmonizing image size checks, which are
currently represented by the following Kconfig symbols:
CONFIG_HAS_BOARD_SIZE_LIMIT
CONFIG_BOARD_SIZE_LIMIT
CONFIG_SPL_SIZE_LIMIT
CONFIG_TPL_SIZE_LIMIT
CONFIG_VPL_SIZE_LIMIT
After this series, we would have
- Consistent logic
- Consistent help texts
- Less code duplication in the toplevel Makefile
Changes in v5:
- Minor style improvements
Changes in v4:
- Minimize the number of defconfig changes
- Drop patch "Simplify SPL_SIZE_LIMIT logic"
- Drop patch "Move all configs in one place"
- Improve help texts
- Use XXX_HAS_SIZE_LIMIT in the Makefile code
- Move "default y" statements to the respective main Kconfigs
Changes in v3:
V3 is a complete remake of the series. In the discussions on V2 we
decided to follow the approach of using CONFIG_HAS_XXX_SIZE_LIMIT
instead of my initial proposal, which was to disable a size check
by setting its limit to zero.
Changes in v2:
- Rebase on current master
- Rebase on my pending mips patch series (linked above)
- Incorporated Heinrich's Review
Philip Oberfichtner (3):
Image size checks: Use HAS_SIZE_LIMIT consistently
Image size checks: Clarify help texts
Makefile: Deduplicate image size checks
Kconfig | 10 +++---
Makefile | 48 ++++++++-------------------
arch/arm/mach-socfpga/Kconfig | 6 ----
arch/mips/mach-mtmips/Kconfig | 3 --
arch/x86/cpu/apollolake/Kconfig | 3 --
common/spl/Kconfig | 29 ++++++++++++----
common/spl/Kconfig.tpl | 15 ++++++---
common/spl/Kconfig.vpl | 13 +++++---
configs/am64x_evm_r5_defconfig | 1 +
configs/am65x_evm_r5_defconfig | 1 +
configs/am65x_evm_r5_usbmsc_defconfig | 1 +
configs/brcp150_defconfig | 1 +
configs/brcp170_defconfig | 1 +
configs/brcp1_1r_defconfig | 1 +
configs/brcp1_1r_switch_defconfig | 1 +
configs/brcp1_2r_defconfig | 1 +
configs/brsmarc2_defconfig | 1 +
configs/evb-ast2600_defconfig | 1 +
configs/evb-rk3288_defconfig | 1 +
configs/firefly-rk3288_defconfig | 1 +
configs/ibex-ast2700_defconfig | 1 +
configs/ibm-sbp1_defconfig | 1 +
configs/imx28_btt3_defconfig | 1 +
configs/imx28_xea_defconfig | 1 +
configs/imxrt1020-evk_defconfig | 1 +
configs/imxrt1050-evk_defconfig | 1 +
configs/imxrt1050-evk_fspi_defconfig | 1 +
configs/imxrt1170-evk_defconfig | 1 +
configs/kontron_sl28_defconfig | 1 +
configs/phycore_am64x_r5_defconfig | 1 +
configs/stm32746g-eval_spl_defconfig | 1 +
configs/stm32f746-disco_spl_defconfig | 1 +
configs/stm32f769-disco_spl_defconfig | 1 +
configs/tinker-rk3288_defconfig | 1 +
configs/tinker-s-rk3288_defconfig | 1 +
configs/verdin-am62p_a53_defconfig | 1 +
configs/xilinx_mbv32_defconfig | 1 +
configs/xilinx_zynqmp_kria_defconfig | 1 +
configs/xilinx_zynqmp_virt_defconfig | 1 +
39 files changed, 91 insertions(+), 67 deletions(-)
--
2.39.5
next reply other threads:[~2025-11-10 9:13 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-11-10 9:12 Philip Oberfichtner [this message]
2025-11-10 9:12 ` [PATCH v5 1/3] Image size checks: Use HAS_SIZE_LIMIT consistently Philip Oberfichtner
2025-12-31 21:27 ` Marek Vasut
2026-01-07 17:34 ` Philip Oberfichtner
2025-11-10 9:12 ` [PATCH v5 2/3] Image size checks: Clarify help texts Philip Oberfichtner
2025-12-31 21:20 ` Marek Vasut
2025-11-10 9:12 ` [PATCH v5 3/3] Makefile: Deduplicate image size checks Philip Oberfichtner
2025-12-31 21:25 ` Marek Vasut
2025-12-01 18:30 ` [PATCH v5 0/3] Harmonize " Philip Oberfichtner
2025-12-01 18:37 ` Tom Rini
2025-12-01 18:38 ` Philip Oberfichtner
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20251110091256.2422534-1-pro@denx.de \
--to=pro@denx.de \
--cc=andre.przywara@arm.com \
--cc=anshuld@ti.com \
--cc=dario.binacchi@amarulasolutions.com \
--cc=heinrich.schuchardt@canonical.com \
--cc=ilias.apalodimas@linaro.org \
--cc=jerome.forissier@linaro.org \
--cc=malysagreg@gmail.com \
--cc=marek.vasut@mailbox.org \
--cc=nathan.morrison@timesys.com \
--cc=peng.fan@nxp.com \
--cc=sjg@chromium.org \
--cc=trini@konsulko.com \
--cc=twoerner@gmail.com \
--cc=u-boot@lists.denx.de \
--cc=ye.li@nxp.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.