All of lore.kernel.org
 help / color / mirror / Atom feed
From: David Laight <david.laight.linux@gmail.com>
To: Michael Kelley <mhklinux@outlook.com>
Cc: Josh Poimboeuf <jpoimboe@kernel.org>,
	"x86@kernel.org" <x86@kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	Petr Mladek <pmladek@suse.com>, Miroslav Benes <mbenes@suse.cz>,
	Joe Lawrence <joe.lawrence@redhat.com>,
	"live-patching@vger.kernel.org" <live-patching@vger.kernel.org>,
	Song Liu <song@kernel.org>, laokz <laokz@foxmail.com>,
	Jiri Kosina <jikos@kernel.org>,
	Marcos Paulo de Souza <mpdesouza@suse.com>,
	Weinan Liu <wnliu@google.com>,
	Fazla Mehrab <a.mehrab@bytedance.com>,
	Chen Zhongjin <chenzhongjin@huawei.com>,
	Puranjay Mohan <puranjay@kernel.org>,
	Dylan Hatch <dylanbhatch@google.com>,
	Peter Zijlstra <peterz@infradead.org>
Subject: Re: [PATCH v4 49/63] objtool/klp: Add --checksum option to generate per-function checksums
Date: Wed, 12 Nov 2025 13:25:57 +0000	[thread overview]
Message-ID: <20251112132557.6928f799@pumpkin> (raw)
In-Reply-To: <BN7PR02MB414887B3CA73281177406A5BD4CCA@BN7PR02MB4148.namprd02.prod.outlook.com>

On Wed, 12 Nov 2025 04:32:02 +0000
Michael Kelley <mhklinux@outlook.com> wrote:

> From: Josh Poimboeuf <jpoimboe@kernel.org> Sent: Tuesday, November 11, 2025 8:04 PM
> > 
> > On Wed, Nov 12, 2025 at 02:26:18AM +0000, Michael Kelley wrote:  
> > > > I've been able to debug this.  Two problems:
> > > >
> > > > 1) On Ubuntu (both 20.04 and 24.04), /bin/sh and /usr/bin/sh are symlinks
> > > > to "dash" (not "bash"). So the "shell" command in "make" invokes dash. The
> > > > man page for dash shows that the built-in echo command accepts only -n as
> > > > an option. The -e behavior of processing "\n" and similar sequences is always
> > > > enabled. So on my Ubuntu systems, the "-e" is ignored by echo and becomes
> > > > part of the C source code sent to gcc, and of course it barfs. Dropping the -e
> > > > makes it work for me (and the \n is handled correctly), but that might not work
> > > > with other shells. Using "/bin/echo" with the -e solves the problem in a more
> > > > compatible way across different shells.  
> > 
> > Ah.  I think we can use "printf" here.

Much better than echo - and a bultin on most shells.

> >   
> > > > 2) With make v4.2.1 on my Ubuntu 20.04 system, the "#" character in the
> > > > "#include" added to the echo command is problematic. "make" seems to be
> > > > treating it as a comment character, though I'm not 100% sure of that
> > > > interpretation. Regardless, the "#" causes a syntax error in the "make" shell
> > > > command. Adding a backslash before the "#" solves that problem. On an Ubuntu
> > > > 24.04 system with make v4.3, the "#" does not cause any problems. (I tried to put
> > > > make 4.3 on my Ubuntu 20.04 system, but ran into library compatibility problems
> > > > so I wasn’t able to definitively confirm that it is the make version that changes the
> > > > handling of the "#"). Unfortunately, adding the backslash before the # does *not*
> > > > work with make v4.3. The backslash becomes part of the C source code sent to
> > > > gcc, which barfs. I don't immediately have a suggestion on how to resolve this
> > > > in a way that is compatible across make versions.  
> > >
> > > Using "\043" instead of the "#" is a compatible solution that works in make
> > > v4.2.1 and v4.3 and presumably all other versions as well.  
> > 
> > Hm... I've seen similar portability issues with "," for which we had to
> > change it to "$(comma)" which magically worked for some reason that I am
> > forgetting.
> > 
> > Does "$(pound)" work?  This seems to work here:

Please not 'pound' - that is the uk currency symbol (not what US greengrocers
scrawl for lb).

	David

> > 
> >         HAVE_XXHASH = $(shell printf "$(pound)include <xxhash.h>\nXXH3_state_t *state;int main() {}" | \
> >   
> 
> Yes, the above line works in my Ubuntu 20.04 and 24.04 environments.
> It properly detects the presence and absence of xxhash 0.8. Seems like a
> good solution to me.
> 
> Michael


  reply	other threads:[~2025-11-12 13:26 UTC|newest]

Thread overview: 93+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-09-17 16:03 [PATCH v4 00/63] objtool,livepatch: klp-build livepatch module generation Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 01/63] s390/vmlinux.lds.S: Prevent thunk functions from getting placed with normal text Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 02/63] vmlinux.lds: Unify TEXT_MAIN, DATA_MAIN, and related macros Josh Poimboeuf
2025-12-20 16:25   ` Carlos Llamas
2026-01-06 22:46     ` Will Deacon
2026-01-08 21:59       ` Carlos Llamas
2025-09-17 16:03 ` [PATCH v4 03/63] x86/module: Improve relocation error messages Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 04/63] x86/kprobes: Remove STACK_FRAME_NON_STANDARD annotation Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 05/63] compiler: Tweak __UNIQUE_ID() naming Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 06/63] compiler.h: Make addressable symbols less of an eyesore Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 07/63] elfnote: Change ELFNOTE() to use __UNIQUE_ID() Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 08/63] kbuild: Remove 'kmod_' prefix from __KBUILD_MODNAME Josh Poimboeuf
2025-10-20 12:20   ` Alexander Stein
2025-10-20 17:22     ` Josh Poimboeuf
2025-10-22  9:53       ` Anders Roxell
2025-10-20 12:59   ` Marek Szyprowski
2025-10-20 16:34   ` Mark Brown
2025-10-20 16:37   ` Cosmin Tanislav
2025-09-17 16:03 ` [PATCH v4 09/63] modpost: Ignore unresolved section bounds symbols Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 10/63] x86/alternative: Refactor INT3 call emulation selftest Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 11/63] interval_tree: Sync interval_tree_generic.h with tools Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 12/63] interval_tree: Fix ITSTATIC usage for *_subtree_search() Josh Poimboeuf
2025-09-18 16:30   ` [PATCH v4.1 " Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 13/63] objtool: Make find_symbol_containing() less arbitrary Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 14/63] objtool: Fix broken error handling in read_symbols() Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 15/63] objtool: Propagate elf_truncate_section() error in elf_write() Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 16/63] objtool: Remove error handling boilerplate Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 17/63] objtool: Add empty symbols to the symbol tree again Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 18/63] objtool: Fix interval tree insertion for zero-length symbols Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 19/63] objtool: Fix weak symbol detection Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 20/63] objtool: Fix x86 addend calculation Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 21/63] objtool: Fix __pa_symbol() relocation handling Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 22/63] objtool: Fix "unexpected end of section" warning for alternatives Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 23/63] objtool: Check for missing annotation entries in read_annotate() Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 24/63] objtool: Const string cleanup Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 25/63] objtool: Clean up compiler flag usage Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 26/63] objtool: Remove .parainstructions reference Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 27/63] objtool: Convert elf iterator macros to use 'struct elf' Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 28/63] objtool: Add section/symbol type helpers Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 29/63] objtool: Mark .cold subfunctions Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 30/63] objtool: Fix weak symbol hole detection for .cold functions Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 31/63] objtool: Mark prefix functions Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 32/63] objtool: Simplify reloc offset calculation in unwind_read_hints() Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 33/63] objtool: Avoid emptying lists for duplicate sections Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 34/63] objtool: Rename --Werror to --werror Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 35/63] objtool: Resurrect --backup option Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 36/63] objtool: Reindent check_options[] Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 37/63] objtool: Refactor add_jump_destinations() Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 38/63] objtool: Simplify special symbol handling in elf_update_symbol() Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 39/63] objtool: Generalize elf_create_symbol() Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 40/63] objtool: Generalize elf_create_section() Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 41/63] objtool: Add elf_create_data() Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 42/63] objtool: Add elf_create_reloc() and elf_init_reloc() Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 43/63] objtool: Add elf_create_file() Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 44/63] objtool: Add annotype() helper Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 45/63] objtool: Move ANNOTATE* macros to annotate.h Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 46/63] objtool: Add ANNOTATE_DATA_SPECIAL Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 47/63] x86/asm: Annotate special section entries Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 48/63] objtool: Unify STACK_FRAME_NON_STANDARD entry sizes Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 49/63] objtool/klp: Add --checksum option to generate per-function checksums Josh Poimboeuf
2025-10-27  1:19   ` Michael Kelley
2025-10-27 22:22     ` Josh Poimboeuf
2025-11-05 15:22       ` Michael Kelley
2025-11-11 20:09         ` Josh Poimboeuf
2025-11-12  1:39           ` Michael Kelley
2025-11-12  2:26             ` Michael Kelley
2025-11-12  4:04               ` Josh Poimboeuf
2025-11-12  4:32                 ` Michael Kelley
2025-11-12 13:25                   ` David Laight [this message]
2025-11-12 16:16                     ` Josh Poimboeuf
2025-11-12 21:39                       ` David Laight
2025-09-17 16:03 ` [PATCH v4 50/63] objtool/klp: Add --debug-checksum=<funcs> to show per-instruction checksums Josh Poimboeuf
2025-09-17 16:03 ` [PATCH v4 51/63] objtool/klp: Introduce klp diff subcommand for diffing object files Josh Poimboeuf
2025-10-08 14:01   ` Petr Mladek
2025-10-08 15:27     ` Josh Poimboeuf
2025-10-09 12:29       ` Petr Mladek
2025-10-09 23:19         ` Josh Poimboeuf
2025-09-17 16:04 ` [PATCH v4 52/63] objtool/klp: Add --debug option to show cloning decisions Josh Poimboeuf
2025-09-17 16:04 ` [PATCH v4 53/63] objtool/klp: Add post-link subcommand to finalize livepatch modules Josh Poimboeuf
2025-09-17 16:04 ` [PATCH v4 54/63] objtool: Refactor prefix symbol creation code Josh Poimboeuf
2025-09-17 16:04 ` [PATCH v4 55/63] objtool: Add base objtool support for livepatch modules Josh Poimboeuf
2025-09-17 16:04 ` [PATCH v4 56/63] livepatch: Add CONFIG_KLP_BUILD Josh Poimboeuf
2025-09-17 16:04 ` [PATCH v4 57/63] kbuild,objtool: Defer objtool validation step for CONFIG_KLP_BUILD Josh Poimboeuf
2025-09-17 16:04 ` [PATCH v4 58/63] livepatch/klp-build: Introduce fix-patch-lines script to avoid __LINE__ diff noise Josh Poimboeuf
2025-09-17 16:04 ` [PATCH v4 59/63] livepatch/klp-build: Add stub init code for livepatch modules Josh Poimboeuf
2025-09-17 16:04 ` [PATCH v4 60/63] livepatch/klp-build: Introduce klp-build script for generating " Josh Poimboeuf
2025-09-17 16:04 ` [PATCH v4 61/63] livepatch/klp-build: Add --debug option to show cloning decisions Josh Poimboeuf
2025-09-17 16:04 ` [PATCH v4 62/63] livepatch/klp-build: Add --show-first-changed option to show function divergence Josh Poimboeuf
2025-09-17 16:04 ` [PATCH v4 63/63] livepatch: Introduce source code helpers for livepatch modules Josh Poimboeuf
2025-09-18 16:32 ` [PATCH v4 00/63] objtool,livepatch: klp-build livepatch module generation Josh Poimboeuf
2025-10-07 17:38 ` Joe Lawrence
2025-10-10  7:30 ` Petr Mladek
2025-10-11  0:54   ` Josh Poimboeuf

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20251112132557.6928f799@pumpkin \
    --to=david.laight.linux@gmail.com \
    --cc=a.mehrab@bytedance.com \
    --cc=chenzhongjin@huawei.com \
    --cc=dylanbhatch@google.com \
    --cc=jikos@kernel.org \
    --cc=joe.lawrence@redhat.com \
    --cc=jpoimboe@kernel.org \
    --cc=laokz@foxmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=live-patching@vger.kernel.org \
    --cc=mbenes@suse.cz \
    --cc=mhklinux@outlook.com \
    --cc=mpdesouza@suse.com \
    --cc=peterz@infradead.org \
    --cc=pmladek@suse.com \
    --cc=puranjay@kernel.org \
    --cc=song@kernel.org \
    --cc=wnliu@google.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.