All of lore.kernel.org
 help / color / mirror / Atom feed
From: Keith Busch <kbusch@meta.com>
To: <linux-pci@vger.kernel.org>, <helgaas@kernel.org>
Cc: <alex@shazbot.org>, <lukas@wunner.de>, <dan.j.williams@intel.com>,
	<guojinhui.liam@bytedance.com>, <ilpo.jarvinen@linux.intel.com>,
	Keith Busch <kbusch@kernel.org>
Subject: [PATCHv3 0/4] pci slot reset handling fixes
Date: Thu, 5 Feb 2026 13:25:29 -0800	[thread overview]
Message-ID: <20260205212533.1512153-1-kbusch@meta.com> (raw)

From: Keith Busch <kbusch@kernel.org>

Changes from previous:

Incorporating suggestions from Dan:

  There's a prep patch changing the names of the functions for clarity.

  Introduced symbolic names to the reset bridge parameters to indicate
  whether it's a masked or unmasked reset attempt.

  Renamed the new "pci_reset_bridge" to "pci_try_reset_bridge", in
  keeping with the convention this series introduced.

I've also include a new patch specifically to allow pciehp slots to
claim all bus devices. I'm almost certain this is what pciehp wanted in
the first place. If this is acceptable, patch 3/4 here becomes
unnecessary, but I'm including that patch as an option here just in case
it's preferred to remove the slot specific lock handling.

Keith Busch (4):
  pci: rename __pci_bus_reset and __pci_slot_reset
  pci: allow all bus devices to use the same slot
  pci: remove slot specific lock/unlock and save/restore
  pci: make reset_subordinate hotplug safe

 drivers/pci/hotplug/pciehp_core.c |   3 +-
 drivers/pci/pci-sysfs.c           |   3 +-
 drivers/pci/pci.c                 | 228 +++++++++---------------------
 drivers/pci/pci.h                 |   2 +-
 drivers/pci/slot.c                |  22 ++-
 include/linux/pci.h               |   8 +-
 6 files changed, 93 insertions(+), 173 deletions(-)

-- 
2.47.3


             reply	other threads:[~2026-02-05 21:26 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-02-05 21:25 Keith Busch [this message]
2026-02-05 21:25 ` [PATCHv3 1/4] pci: rename __pci_bus_reset and __pci_slot_reset Keith Busch
2026-02-06 17:22   ` Keith Busch
2026-02-10 20:44   ` dan.j.williams
2026-02-05 21:25 ` [PATCHv3 2/4] pci: allow all bus devices to use the same slot Keith Busch
2026-02-10 20:00   ` dan.j.williams
2026-02-10 20:28     ` Keith Busch
2026-02-10 20:51       ` dan.j.williams
2026-02-05 21:25 ` [PATCHv3 3/4] pci: remove slot specific lock/unlock and save/restore Keith Busch
2026-02-10 22:03   ` dan.j.williams
2026-02-10 23:25     ` Keith Busch
2026-02-10 23:48       ` dan.j.williams
2026-02-10 23:46   ` Alex Williamson
2026-02-11  0:12     ` Keith Busch
2026-02-11 15:22       ` Alex Williamson
2026-02-11 15:54         ` Keith Busch
2026-02-05 21:25 ` [PATCHv3 4/4] pci: make reset_subordinate hotplug safe Keith Busch
2026-02-10 22:14   ` dan.j.williams

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260205212533.1512153-1-kbusch@meta.com \
    --to=kbusch@meta.com \
    --cc=alex@shazbot.org \
    --cc=dan.j.williams@intel.com \
    --cc=guojinhui.liam@bytedance.com \
    --cc=helgaas@kernel.org \
    --cc=ilpo.jarvinen@linux.intel.com \
    --cc=kbusch@kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=lukas@wunner.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.