From: sashiko-bot@kernel.org
To: "Paresh Bhagat" <p-bhagat@ti.com>
Cc: devicetree@vger.kernel.org, robh@kernel.org, conor+dt@kernel.org
Subject: Re: [PATCH] arm64: dts: ti: Rename DM firmware reserved memory nodes
Date: Tue, 30 Jun 2026 15:19:53 +0000 [thread overview]
Message-ID: <20260630151954.5F9EE1F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260630150919.457160-1-p-bhagat@ti.com>
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Medium] Incomplete refactoring of DM firmware reserved memory nodes, missing k3-am654-base-board and the entire AM64x family.
--
commit 8c190c8bbecf4c9714e791b5c5c8d1f70710854f
Author: Paresh Bhagat <p-bhagat@ti.com>
arm64: dts: ti: Rename DM firmware reserved memory nodes
Rename DM reserved memory nodes for K3 devices.
This allows U-Boot to identify and resize these regions using
fdt_fixup_reserved_memory() as done for TFA and optee.
Also drop unnecessary bootph-pre-ram property from AM62D2.
> diff --git a/arch/arm64/boot/dts/ti/k3-am65-iot2050-common.dtsi b/arch/arm64/boot/dts/ti/k3-am65-iot2050-common.dtsi
> index f3ee73e64d69c..78b4e5d61dfc2 100644
> --- a/arch/arm64/boot/dts/ti/k3-am65-iot2050-common.dtsi
> +++ b/arch/arm64/boot/dts/ti/k3-am65-iot2050-common.dtsi
> @@ -53,7 +53,7 @@ mcu_r5fss0_core0_dma_memory_region: memory@a0000000 {
> no-map;
> };
>
> - mcu_r5fss0_core0_memory_region: memory@a0100000 {
> + mcu_r5fss0_core0_memory_region: dm@a0100000 {
> compatible = "shared-dma-pool";
> reg = <0 0xa0100000 0 0xf00000>;
> no-map;
[Severity: Medium]
Were some K3 devices missed in this refactoring?
This patch renames DM reserved memory nodes so U-Boot can locate and resize
them, but it appears to miss k3-am654-base-board.dts, which still retains the
old naming convention:
arch/arm64/boot/dts/ti/k3-am654-base-board.dts:
mcu_r5fss0_core0_memory_region: memory@a0100000 {
compatible = "shared-dma-pool";
reg = <0 0xa0100000 0 0xf00000>;
no-map;
};
Additionally, the AM64x family appears to be omitted entirely, as they use
main_r5fss0_core0 for DM instead of wkup or mcu. For example:
arch/arm64/boot/dts/ti/k3-am642-evm.dts:
main_r5fss0_core0_memory_region: memory@a0100000 {
compatible = "shared-dma-pool";
reg = <0x00 0xa0100000 0x00 0xf00000>;
no-map;
};
Will U-Boot silently skip resizing the DM memory regions on these unpatched
boards, potentially leading to incorrectly sized regions during boot?
[ ... ]
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260630150919.457160-1-p-bhagat@ti.com?part=1
next prev parent reply other threads:[~2026-06-30 15:19 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-06-30 15:09 [PATCH] arm64: dts: ti: Rename DM firmware reserved memory nodes Paresh Bhagat
2026-06-30 15:19 ` sashiko-bot [this message]
2026-07-01 12:50 ` Markus Schneider-Pargmann
2026-07-03 18:16 ` Paresh Bhagat
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260630151954.5F9EE1F000E9@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=p-bhagat@ti.com \
--cc=robh@kernel.org \
--cc=sashiko-reviews@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.