From: SJ Park <sj@kernel.org>
To: Shivank Garg <shivankg@amd.com>
Cc: SJ Park <sj@kernel.org>,
Andrew Morton <akpm@linux-foundation.org>,
David Hildenbrand <david@kernel.org>, Zi Yan <ziy@nvidia.com>,
Matthew Brost <matthew.brost@intel.com>,
Joshua Hahn <joshua.hahnjy@gmail.com>,
Rakie Kim <rakie.kim@sk.com>, Byungchul Park <byungchul@sk.com>,
Gregory Price <gourry@gourry.net>,
Ying Huang <ying.huang@linux.alibaba.com>,
"Alistair Popple" <apopple@nvidia.com>,
Lorenzo Stoakes <ljs@kernel.org>,
"Liam R. Howlett" <liam@infradead.org>,
Vlastimil Babka <vbabka@kernel.org>,
"Mike Rapoport" <rppt@kernel.org>,
Suren Baghdasaryan <surenb@google.com>,
"Michal Hocko" <mhocko@suse.com>,
linux-mm@kvack.org, linux-kernel@vger.kernel.org,
Jonathan Cameron <jic23@kernel.org>
Subject: Re: [PATCH v2 3/3] mm/migrate: use migrate_info field instead of private
Date: Wed, 1 Jul 2026 17:00:32 -0700 [thread overview]
Message-ID: <20260702000033.85939-1-sj@kernel.org> (raw)
In-Reply-To: <20260701-migrate-cleanups-prep-v2-3-d9e8f17130b1@amd.com>
On Wed, 1 Jul 2026 05:17:22 +0000 Shivank Garg <shivankg@amd.com> wrote:
> Add an unsigned long migrate_info member to the struct folio union and
> use it to store migration state (anon_vma pointer and FOLIO_WAS_*
> markers) instead of using folio->private. While at it, switch to bitwise
> OR.
>
> No functional change.
>
> Suggested-by: David Hildenbrand (Arm) <david@kernel.org>
> Reviewed-by: Jonathan Cameron <jic23@kernel.org>
> Acked-by: David Hildenbrand (Arm) <david@kernel.org>
> Reviewed-by: Huang Ying <ying.huang@linux.alibaba.com>
> Acked-by: Zi Yan <ziy@nvidia.com>
> Signed-off-by: Shivank Garg <shivankg@amd.com>
Reviewed-by: SJ Park <sj@kernel.org>
Thanks,
SJ
[...]
prev parent reply other threads:[~2026-07-02 0:00 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-01 5:17 [PATCH v2 0/3] mm/migrate: preparatory cleanups for batch copy and offload Shivank Garg
2026-07-01 5:17 ` [PATCH v2 1/3] mm/migrate: rename page to folio leftovers Shivank Garg
2026-07-01 15:39 ` Zi Yan
2026-07-01 23:54 ` SJ Park
2026-07-01 5:17 ` [PATCH v2 2/3] mm/migrate: fix stale list name in migrate_folios_move() comment Shivank Garg
2026-07-01 5:17 ` [PATCH v2 3/3] mm/migrate: use migrate_info field instead of private Shivank Garg
2026-07-02 0:00 ` SJ Park [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260702000033.85939-1-sj@kernel.org \
--to=sj@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=apopple@nvidia.com \
--cc=byungchul@sk.com \
--cc=david@kernel.org \
--cc=gourry@gourry.net \
--cc=jic23@kernel.org \
--cc=joshua.hahnjy@gmail.com \
--cc=liam@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=matthew.brost@intel.com \
--cc=mhocko@suse.com \
--cc=rakie.kim@sk.com \
--cc=rppt@kernel.org \
--cc=shivankg@amd.com \
--cc=surenb@google.com \
--cc=vbabka@kernel.org \
--cc=ying.huang@linux.alibaba.com \
--cc=ziy@nvidia.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.