From: SJ Park <sj@kernel.org>
To: sashiko-bot@kernel.org
Cc: SJ Park <sj@kernel.org>, damon@lists.linux.dev
Subject: Re: [RFC PATCH v1.1 07/16] mm/damon/core: extend merge function to work with probe hits
Date: Mon, 6 Jul 2026 16:52:00 -0700 [thread overview]
Message-ID: <20260706235215.97085-1-sj@kernel.org> (raw)
In-Reply-To: <20260706145538.DF9291F000E9@smtp.kernel.org>
On Mon, 06 Jul 2026 14:55:38 +0000 sashiko-bot@kernel.org wrote:
> Thank you for your contribution! Sashiko AI review found 2 potential issue(s) to consider:
> - [High] API Misuse / Silent Overflow: Using `abs()` on the difference of two large unsigned integers causes incorrect results.
> - [High] Integer Overflow: `damon_probe_hits_wsum()` wraps around the 32-bit boundary when large weights are used.
> --
>
> commit b2b82783307a6d10c78010502dd30f5168036627
> Author: SJ Park <sj@kernel.org>
>
> mm/damon/core: extend merge function to work with probe hits
>
> When probe weights are set, this commit extends damon_merge_regions_of() to
> work with the weighted sum of probe hits. It also introduces a placeholder
> detection function to allow safe incremental changes.
>
> > diff --git a/mm/damon/core.c b/mm/damon/core.c
> > index 42f27849af722..7aff741d43bd4 100644
> > --- a/mm/damon/core.c
> > +++ b/mm/damon/core.c
>
> [ ... ]
>
> > @@ -3230,6 +3235,16 @@ static void damon_merge_two_regions(struct damon_target *t,
> > damon_destroy_region(r, t);
> > }
> >
> > +static unsigned int damon_merge_score(struct damon_region *r, bool last,
> > + struct damon_ctx *ctx, bool use_probe_hits)
> > +{
> > + if (use_probe_hits)
> > + return damon_probe_hits_wsum(r, last, ctx);
> ^^^^^^^^^^^^^^^^^^^^^^^^^
>
> [Severity: High]
> Does this code wrap around the 32-bit boundary when large weights are used?
>
> Looking at damon_probe_hits_wsum(), it accumulates probe_hits[i] * probe->weight
> into a 32-bit unsigned int sum:
>
> mm/damon/core.c:damon_probe_hits_wsum() {
> ...
> unsigned int sum = 0;
> ...
> if (last)
> sum += r->last_probe_hits[i++] * probe->weight;
> else
> sum += r->probe_hits[i++] * probe->weight;
> ...
> return sum;
> }
>
> If a user configures a large weight (e.g., > 16,843,000) for a probe via
> sysfs, this could wrap around (e.g., 255 hits * 40,000,000 weight = 10.2
> billion, which wraps to ~1.6 billion).
>
> Could this break the scoring mechanism, causing damon_merge_regions_of() to
> merge active and inactive regions incorrectly?
Known low priority issue. No blocker.
>
> > + if (last)
> > + return r->last_nr_accesses;
> > + return r->nr_accesses;
> > +}
> > +
>
> [ ... ]
>
> > @@ -3238,24 +3253,37 @@ static void damon_merge_regions_of(struct damon_target *t, unsigned int thres,
> > - unsigned long sz_limit)
> > + unsigned long sz_limit, struct damon_ctx *ctx)
> > {
> > struct damon_region *r, *prev = NULL, *next;
> > + bool use_probe_hits = damon_has_probe_weights(ctx);
> >
> > damon_for_each_region_safe(r, next, t) {
> > - if (abs(r->nr_accesses - r->last_nr_accesses) > thres)
> > + unsigned int score, last_score;
> > +
> > + score = damon_merge_score(r, false, ctx, use_probe_hits);
> > + last_score = damon_merge_score(r, true, ctx, use_probe_hits);
> > +
> > + if (abs(score - last_score) > thres)
> ^^^^^^^^^^^^^^^^^^^^^^^^
>
> [Severity: High]
> Can this call to abs() cause incorrect results due to silent overflow?
>
> Since score and last_score are unsigned integers, abs(score - last_score)
> casts the unsigned difference to a signed int.
>
> If the actual difference exceeds the maximum signed integer value, it wraps
> to a negative value, which abs() then negates into a smaller positive value.
>
> Could this falsely small difference cause the threshold check > thres to fail
> incorrectly, allowing vastly different regions to be merged and affecting the
> accuracy of the monitor?
Same issue exists for the above abs() call. User impact is minor and I'm
separately working [1] on it.
>
> > r->age = 0;
> > - else if ((r->nr_accesses == 0) != (r->last_nr_accesses == 0))
> > + else if ((score == 0) != (last_score == 0))
> > r->age = 0;
> > else
> > r->age++;
> >
> > - if (prev && prev->ar.end == r->ar.start &&
> > - abs(prev->nr_accesses - r->nr_accesses) <= thres &&
> > - damon_sz_region(prev) + damon_sz_region(r) <= sz_limit)
> > - damon_merge_two_regions(t, prev, r);
> > - else
> > - prev = r;
> > + if (!prev)
> > + goto set_prev_continue;
> > + if (prev->ar.end != r->ar.start)
> > + goto set_prev_continue;
> > + if (abs(damon_merge_score(prev, false, ctx, use_probe_hits) -
> > + score) > thres)
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
>
> [Severity: High]
> Does this second use of abs() on the unsigned difference of the merge scores
> suffer from the exact same signed-integer overflow vulnerability?
Ditto.
>
> > + goto set_prev_continue;
> > + if (damon_sz_region(prev) + damon_sz_region(r) > sz_limit)
> > + goto set_prev_continue;
> > + damon_merge_two_regions(t, prev, r);
> > + continue;
> > +set_prev_continue:
> > + prev = r;
> > }
> > }
>
> --
> Sashiko AI review · https://sashiko.dev/#/patchset/20260706141912.88445-1-sj@kernel.org?part=7
[1] https://lore.kernel.org/20260705211101.F2F061F000E9@smtp.kernel.org
Thanks,
SJ
[...]
next prev parent reply other threads:[~2026-07-06 23:52 UTC|newest]
Thread overview: 40+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-06 14:18 [RFC PATCH v1.1 00/16] mm/damon: introduce data attributes only monitoring SJ Park
2026-07-06 14:18 ` [RFC PATCH v1.1 01/16] mm/damon/core: introduce damon_probe->weight SJ Park
2026-07-06 14:18 ` [RFC PATCH v1.1 02/16] mm/damon/core: ask apply_probes() ops callback to set sampling address SJ Park
2026-07-06 14:18 ` [RFC PATCH v1.1 03/16] mm/damon/paddr: set samples in apply_probes() if requested SJ Park
2026-07-06 14:18 ` [RFC PATCH v1.1 04/16] mm/damon/core: ask apply_probe() to return max probe hits weighted sum SJ Park
2026-07-06 14:39 ` sashiko-bot
2026-07-06 23:42 ` SJ Park
2026-07-06 14:18 ` [RFC PATCH v1.1 05/16] mm/damon/core: implement damon_probe_hits_wsum() SJ Park
2026-07-06 14:41 ` sashiko-bot
2026-07-06 23:46 ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 06/16] mm/damon/paddr: respect return_max_wsum SJ Park
2026-07-06 14:44 ` sashiko-bot
2026-07-06 23:47 ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 07/16] mm/damon/core: extend merge function to work with probe hits SJ Park
2026-07-06 14:55 ` sashiko-bot
2026-07-06 23:52 ` SJ Park [this message]
2026-07-07 3:30 ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 08/16] mm/damon/core: disable access monitoring when probe weights are set SJ Park
2026-07-06 15:03 ` sashiko-bot
2026-07-06 23:54 ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 09/16] mm/damon/core: set samples in apply_probes() if " SJ Park
2026-07-06 15:02 ` sashiko-bot
2026-07-06 23:56 ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 10/16] mm/damon/core: s/max_nr_accesses/max_merge_score/ in kdamond_fn() SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 11/16] mm/damon/core: get merge threshold from probe hits when weights are set SJ Park
2026-07-06 15:18 ` sashiko-bot
2026-07-07 0:03 ` SJ Park
2026-07-07 3:34 ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 12/16] mm/damon/core: implement damon_has_probe_weight() SJ Park
2026-07-06 15:16 ` sashiko-bot
2026-07-07 0:05 ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 13/16] mm/damon/sysfs: implement probe/weight file SJ Park
2026-07-06 15:19 ` sashiko-bot
2026-07-07 0:08 ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 14/16] Docs/mm/damon/design: document attrs-only monitoring SJ Park
2026-07-06 15:34 ` sashiko-bot
2026-07-07 0:11 ` SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 15/16] Docs/admin-guide/mm/damon/usage: document weight sysfs file SJ Park
2026-07-06 14:19 ` [RFC PATCH v1.1 16/16] Docs/ABI/damon: document probe weight file SJ Park
2026-07-07 0:13 ` [RFC PATCH v1.1 00/16] mm/damon: introduce data attributes only monitoring SJ Park
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260706235215.97085-1-sj@kernel.org \
--to=sj@kernel.org \
--cc=damon@lists.linux.dev \
--cc=sashiko-bot@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.