From: Greg KH <gregkh@linuxfoundation.org>
To: "André Moreira" <andrem.33333@gmail.com>
Cc: sudipm.mukherjee@gmail.com, teddy.wang@siliconmotion.com,
linux-fbdev@vger.kernel.org, linux-staging@lists.linux.dev,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] staging: sm750fb: rename variables to avoid CamelCase
Date: Tue, 7 Jul 2026 11:11:30 +0200 [thread overview]
Message-ID: <2026070710-exact-unveiling-e321@gregkh> (raw)
In-Reply-To: <20260623220614.29682-1-andrem.33333@gmail.com>
On Tue, Jun 23, 2026 at 07:06:14PM -0300, André Moreira wrote:
> Rename 'pvReg' to 'pv_reg' and 'setAllEngOff' to 'set_all_eng_off'
> throughout the driver to comply with the Linux kernel coding style.
>
> Signed-off-by: André Moreira <andrem.33333@gmail.com>
> ---
> drivers/staging/sm750fb/sm750.c | 6 +++---
> drivers/staging/sm750fb/sm750.h | 4 ++--
> drivers/staging/sm750fb/sm750_hw.c | 12 ++++++------
> 3 files changed, 11 insertions(+), 11 deletions(-)
>
> diff --git a/drivers/staging/sm750fb/sm750.c b/drivers/staging/sm750fb/sm750.c
> index 89c811e0806c4..716a8935f58d1 100644
> --- a/drivers/staging/sm750fb/sm750.c
> +++ b/drivers/staging/sm750fb/sm750.c
> @@ -743,7 +743,7 @@ static int lynxfb_set_fbinfo(struct fb_info *info, int index)
> * must be set after crtc member initialized
> */
> crtc->cursor.offset = crtc->o_screen + crtc->vidmem_size - 1024;
> - crtc->cursor.mmio = sm750_dev->pvReg +
> + crtc->cursor.mmio = sm750_dev->pv_reg +
This variable name is still in hungarian notation, which is not allowed
in kernel variable names.
thanks,
greg k-h
next prev parent reply other threads:[~2026-07-07 9:11 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-06-23 22:06 [PATCH] staging: sm750fb: rename variables to avoid CamelCase André Moreira
2026-07-07 9:11 ` Greg KH [this message]
2026-07-07 10:27 ` [PATCH v2] staging: sm750fb: rename variables to comply with kernel style André Moreira
2026-07-07 10:56 ` Greg Kroah-Hartman
2026-07-07 11:43 ` [PATCH v3] " André Moreira
2026-07-07 11:49 ` Greg Kroah-Hartman
2026-07-07 13:15 ` [PATCH v4] " André Moreira
2026-07-07 13:28 ` Andre Moreira
2026-07-07 14:17 ` Greg Kroah-Hartman
2026-07-07 20:15 ` [PATCH v5] " André Moreira
2026-07-08 5:03 ` Greg Kroah-Hartman
2026-07-08 6:03 ` [PATCH v6] staging: sm750fb: Remove unused variable 'setAllEngOff' André Moreira
2026-07-08 11:59 ` Greg Kroah-Hartman
2026-07-08 13:09 ` Andre Moreira
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2026070710-exact-unveiling-e321@gregkh \
--to=gregkh@linuxfoundation.org \
--cc=andrem.33333@gmail.com \
--cc=linux-fbdev@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
--cc=sudipm.mukherjee@gmail.com \
--cc=teddy.wang@siliconmotion.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.