From: sashiko-bot@kernel.org
To: "Jim Cromie" <jim.cromie@gmail.com>
Cc: dri-devel@lists.freedesktop.org, linux-modules@vger.kernel.org
Subject: Re: [PATCH v6 10/24] dyndbg: drop NUM_TYPE_ARGS
Date: Wed, 08 Jul 2026 02:24:24 +0000 [thread overview]
Message-ID: <20260708022424.AC02F1F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260707-dd-maint-2-v6-10-381f3edb0045@gmail.com>
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] The newly defined macro __DDEBUG_ARRAY_SIZE is unused because the array size calculation is manually open-coded.
--
--- Patch [10]: [PATCH v6 10/24] dyndbg: drop NUM_TYPE_ARGS ---
commit 0ca0f4a344ab62c4d4df9c27a60daf65fecad136
Author: Jim Cromie <jim.cromie@gmail.com>
dyndbg: drop NUM_TYPE_ARGS
This commit removes the NUM_TYPE_ARGS macro and replaces it with an array
size calculation. The commit message mentions adding a new local macro named
__DDEBUG_ARRAY_SIZE to handle this without causing include conflicts.
> diff --git a/include/linux/dynamic_debug.h b/include/linux/dynamic_debug.h
> index 9607121c3072e..9ae1accb9bf63 100644
> --- a/include/linux/dynamic_debug.h
> +++ b/include/linux/dynamic_debug.h
> @@ -8,6 +8,8 @@
>
> #include <linux/build_bug.h>
>
> +#define __DDEBUG_ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
> +
[ ... ]
> @@ -122,11 +124,9 @@ struct ddebug_class_param {
> .mod_name = KBUILD_MODNAME, \
> .base = _base, \
> .map_type = _maptype, \
> - .length = NUM_TYPE_ARGS(char*, __VA_ARGS__), \
> + .length = (sizeof(_var##_classnames) / sizeof(_var##_classnames[0])), \
[Severity: Low]
This isn't a bug, but should this line use the new __DDEBUG_ARRAY_SIZE macro
introduced above? The calculation appears to be manually open-coded here,
leaving the newly defined macro unused.
> .class_names = _var##_classnames, \
> }
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260707-dd-maint-2-v6-0-381f3edb0045@gmail.com?part=10
next prev parent reply other threads:[~2026-07-08 2:24 UTC|newest]
Thread overview: 34+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-08 2:18 [PATCH v6 00/24] fix dynamic-debug classmaps API for DRM Jim Cromie
2026-07-08 2:18 ` [PATCH v6 01/24] vmlinux.lds.h: refactor BOUNDED_SECTION_* macros into bounded_sections.lds.h Jim Cromie
2026-07-08 2:18 ` [PATCH v6 02/24] vmlinux.lds.h: drop unused HEADERED_SECTION* macros Jim Cromie
2026-07-08 2:18 ` [PATCH v6 03/24] vmlinux.lds.h: Fix ALIGN(8) omission causing NULL ptr on i386 Jim Cromie
2026-07-08 2:18 ` [PATCH v6 04/24] vmlinux.lds.h: remove redundant ALIGN(8) directives Jim Cromie
2026-07-08 2:18 ` [PATCH v6 05/24] dyndbg.lds.S: fix lost dyndbg sections in modules Jim Cromie
2026-07-08 2:18 ` [PATCH v6 06/24] dyndbg: factor ddebug_match_desc out from ddebug_change Jim Cromie
2026-07-08 2:18 ` [PATCH v6 07/24] dyndbg: add stub macro for DECLARE_DYNDBG_CLASSMAP Jim Cromie
2026-07-08 2:18 ` [PATCH v6 08/24] dyndbg: reword "class unknown," to "class:_UNKNOWN_" Jim Cromie
2026-07-08 2:18 ` [PATCH v6 09/24] dyndbg-API: remove DD_CLASS_TYPE_(DISJOINT|LEVEL)_NAMES and code Jim Cromie
2026-07-08 2:18 ` [PATCH v6 10/24] dyndbg: drop NUM_TYPE_ARGS Jim Cromie
2026-07-08 2:24 ` sashiko-bot [this message]
2026-07-08 19:30 ` jim.cromie
2026-07-08 2:18 ` [PATCH v6 11/24] dyndbg: bump num-tokens in a query-cmd from 9 to 15 Jim Cromie
2026-07-08 2:18 ` [PATCH v6 12/24] dyndbg: reduce verbose/debug clutter Jim Cromie
2026-07-08 2:18 ` [PATCH v6 13/24] lib/parser: add match_wildcard_hyphen() for agnostic matching Jim Cromie
2026-07-08 2:18 ` [PATCH v6 14/24] dyndbg: use KBUILD_MODFILE for unique builtin module names Jim Cromie
2026-07-08 2:18 ` [PATCH v6 15/24] dyndbg: refactor param_set_dyndbg_classes and below Jim Cromie
2026-07-08 2:29 ` sashiko-bot
2026-07-08 19:28 ` jim.cromie
2026-07-08 2:18 ` [PATCH v6 16/24] dyndbg: tighten fn-sig of ddebug_apply_class_bitmap Jim Cromie
2026-07-08 2:18 ` [PATCH v6 17/24] dyndbg: replace classmap list with an array-slice Jim Cromie
2026-07-08 2:18 ` [PATCH v6 18/24] dyndbg: macrofy a 2-index for-loop pattern Jim Cromie
2026-07-08 2:18 ` [PATCH v6 19/24] dyndbg: pin class param storage to u32 Jim Cromie
2026-07-08 2:37 ` sashiko-bot
2026-07-08 20:48 ` jim.cromie
2026-07-08 2:18 ` [PATCH v6 20/24] dyndbg,module: make proper substructs in _ddebug_info Jim Cromie
2026-07-08 2:30 ` sashiko-bot
2026-07-08 2:18 ` [PATCH v6 21/24] dyndbg: move mod_name down from struct ddebug_table to _ddebug_info Jim Cromie
2026-07-08 2:18 ` [PATCH v6 22/24] dyndbg: hoist classmap-filter-by-modname up to ddebug_add_module Jim Cromie
2026-07-08 2:18 ` [PATCH v6 23/24] dyndbg: change __dynamic_func_call_cls* macros into expressions Jim Cromie
2026-07-08 2:41 ` sashiko-bot
2026-07-08 2:18 ` [PATCH v6 24/24] dyndbg-API: replace DECLARE_DYNDBG_CLASSMAP Jim Cromie
2026-07-08 2:36 ` sashiko-bot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260708022424.AC02F1F000E9@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=jim.cromie@gmail.com \
--cc=linux-modules@vger.kernel.org \
--cc=sashiko-reviews@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.