All of lore.kernel.org
 help / color / mirror / Atom feed
From: SJ Park <sj@kernel.org>
To: sashiko-bot@kernel.org
Cc: SJ Park <sj@kernel.org>, damon@lists.linux.dev
Subject: Re: [RFC PATCH v1.3 02/19] mm/damon/core: ask apply_probes() ops callback to set sampling address
Date: Thu,  9 Jul 2026 18:01:28 -0700	[thread overview]
Message-ID: <20260710010129.112598-1-sj@kernel.org> (raw)
In-Reply-To: <20260710003328.23B831F00A3A@smtp.kernel.org>

On Fri, 10 Jul 2026 00:33:27 +0000 sashiko-bot@kernel.org wrote:

> Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
> - [Medium] The `set_samples` parameter in `damon_pa_apply_probes()` is ignored, failing to set `r->sampling_addr` when requested.
> --
> 
> --- Patch [2]: [RFC PATCH v1.3 02/19] mm/damon/core: ask apply_probes() ops callback to set sampling address ---
> commit 5855b0123b327412c4065a90363e8586c4bafda9
> Author: SJ Park <sj@kernel.org>
> 
> mm/damon/core: ask apply_probes() ops callback to set sampling address
> 
> This commit updates the protocol for the DAMON apply_probes callback to
> accept a boolean set_samples argument. It updates the callback signatures
> so it can handle sampling address setup in the future to minimize region
> iteration.
> 
> > diff --git a/include/linux/damon.h b/include/linux/damon.h
> > index d8251c83e6e55..aee28b05acc6c 100644
> > --- a/include/linux/damon.h
> > +++ b/include/linux/damon.h
> 
> [ ... ]
> 
> > @@ -647,7 +647,8 @@ enum damon_ops_id {
> >   * It should also return max number of observed accesses that made as a result
> >   * of its update.  The value will be used for regions adjustment threshold.
> >   * @apply_probes should apply the data attribute probes to each region and
> > - * accordingly update the probe hits counter of the region.
> > + * accordingly update the probe hits counter of the region.  It should also
> > + * set &damon_region->sampling_addr of each region if ``set_samples`` is true.
> >   * @get_scheme_score should return the priority score of a region for a scheme
> 
> [ ... ]
> 
> > diff --git a/mm/damon/paddr.c b/mm/damon/paddr.c
> > index 6172464981730..b13bf7c6eade3 100644
> > --- a/mm/damon/paddr.c
> > +++ b/mm/damon/paddr.c
> > @@ -166,7 +166,7 @@ static bool damon_pa_filter_pass(phys_addr_t pa, struct folio *folio,
> >  	return pass;
> >  }
> >  
> > -static void damon_pa_apply_probes(struct damon_ctx *ctx)
> > +static void damon_pa_apply_probes(struct damon_ctx *ctx, bool set_samples)
> >  {
> >  	struct damon_target *t;
> >  	struct damon_region *r;
> 
> [Severity: Medium]
> Does this implementation actually use the new set_samples parameter?
> 
> The updated documentation in include/linux/damon.h states that apply_probes
> should set the region's sampling_addr when set_samples is true, but it
> appears this parameter is ignored in damon_pa_apply_probes() in
> mm/damon/paddr.c.
> 
> While it is currently called with false from kdamond_fn(), if future code
> passes true as the docstring suggests is possible, could this result in
> using a stale or uninitialized address because the API contract is not
> fulfilled here?

Intentional.  The later patch of this series implement that.

> 
> -- 
> Sashiko AI review · https://sashiko.dev/#/patchset/20260710002349.111414-1-sj@kernel.org?part=2


Thanks,
SJ

  reply	other threads:[~2026-07-10  1:01 UTC|newest]

Thread overview: 30+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-10  0:23 [RFC PATCH v1.3 00/19] mm/damon: introduce data attributes only monitoring SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 01/19] mm/damon/core: introduce damon_probe->weight SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 02/19] mm/damon/core: ask apply_probes() ops callback to set sampling address SJ Park
2026-07-10  0:33   ` sashiko-bot
2026-07-10  1:01     ` SJ Park [this message]
2026-07-10  0:23 ` [RFC PATCH v1.3 03/19] mm/damon/paddr: set samples in apply_probes() if requested SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 04/19] mm/damon/core: ask apply_probe() to return max probe hits weighted sum SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 05/19] mm/damon/core: implement damon_probe_hits_wsum() SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 06/19] mm/damon/paddr: respect return_max_wsum SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 07/19] mm/damon/core: use abs_diff() instead of abs() SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 08/19] mm/damon/core: extend merge function to work with probe hits SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 09/19] mm/damon/core: disallow probe_hits overflow on attrs only monitoring SJ Park
2026-07-10  0:42   ` sashiko-bot
2026-07-10  1:02     ` SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 10/19] mm/damon/core: validate params for probe hits weighted sum overflow SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 11/19] mm/damon/core: disable access monitoring when probe weights are set SJ Park
2026-07-10  0:43   ` sashiko-bot
2026-07-10  1:08     ` SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 12/19] mm/damon/core: set samples in apply_probes() if " SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 13/19] mm/damon/core: s/max_nr_accesses/max_merge_score/ in kdamond_fn() SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 14/19] mm/damon/core: get merge threshold from probe hits when weights are set SJ Park
2026-07-10  0:38   ` sashiko-bot
2026-07-10  1:10     ` SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 15/19] mm/damon/core: implement damon_has_probe_weight() SJ Park
2026-07-10  0:46   ` sashiko-bot
2026-07-10  1:18     ` SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 16/19] mm/damon/sysfs: implement probe/weight file SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 17/19] Docs/mm/damon/design: document attrs-only monitoring SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 18/19] Docs/admin-guide/mm/damon/usage: document weight sysfs file SJ Park
2026-07-10  0:23 ` [RFC PATCH v1.3 19/19] Docs/ABI/damon: document probe weight file SJ Park

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260710010129.112598-1-sj@kernel.org \
    --to=sj@kernel.org \
    --cc=damon@lists.linux.dev \
    --cc=sashiko-bot@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.