From: Ziran Zhang <zhangcoder@yeah.net>
To: linux-kernel@vger.kernel.org, kernel-janitors@vger.kernel.org
Cc: "Paul E . McKenney" <paulmck@kernel.org>,
Andrew Morton <akpm@linux-foundation.org>,
Randy Dunlap <rdunlap@infradead.org>,
Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
Simona Vetter <simona.vetter@ffwll.ch>,
David Howells <dhowells@redhat.com>,
Jonathan Corbet <corbet@lwn.net>,
Nicolas Frattaroli <nicolas.frattaroli@collabora.com>,
Bagas Sanjaya <bagasdotme@gmail.com>,
Shuah Khan <skhan@linuxfoundation.org>,
Ziran Zhang <zhangcoder@yeah.net>
Subject: [Question] list_add() naming: why not list_add_head()?
Date: Fri, 10 Jul 2026 11:19:58 +0800 [thread overview]
Message-ID: <20260710031958.6845-1-zhangcoder@yeah.net> (raw)
I noticed list_add() inserts at the head->next,
but the name doesn't reflect that.
Why wasn't it called list_add_head()? Is there
any historical or design reason?
Thanks for your time.
Regards,
Ziran Zhang
reply other threads:[~2026-07-10 3:22 UTC|newest]
Thread overview: [no followups] expand[flat|nested] mbox.gz Atom feed
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260710031958.6845-1-zhangcoder@yeah.net \
--to=zhangcoder@yeah.net \
--cc=akpm@linux-foundation.org \
--cc=andriy.shevchenko@linux.intel.com \
--cc=bagasdotme@gmail.com \
--cc=corbet@lwn.net \
--cc=dhowells@redhat.com \
--cc=kernel-janitors@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=nicolas.frattaroli@collabora.com \
--cc=paulmck@kernel.org \
--cc=rdunlap@infradead.org \
--cc=simona.vetter@ffwll.ch \
--cc=skhan@linuxfoundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.